Перейти к основному контенту
Поддержка
Войдите с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Выберите другую учетную запись.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой нужно войти.

Данная статья относится к Microsoft Dynamics NAV для всех стран и всех языковых стандартов.

Симптомы

Когда веб-служб в Пакет обновления 1 (SP1) для Microsoft Dynamics NAV 2009 г. в формате FORMAT(Time,0,9), два раза выполняется преобразование для всеобщего скоординированного времени (UTC). Таким образом реальном времени отличается от времени, возвращаемый веб-служб.

Примечание. Формат FORMAT(Time,0,9) — это формат, используемый для преобразования времени в формате xml. Этот формат настраивает время для часового пояса и летнего времени.

Причина

Эта проблема возникает, поскольку веб-службы уже был преобразован все время в формате UTC.

Решение

Сведения об исправлении

Существует исправление от корпорации Майкрософт. Имеется раздел «Исправление доступно для загрузки» в верхней части этой статьи базы знаний. Если появляются проблемы загрузки установки исправления или другие вопросы технической поддержки, обратитесь к своему партнеру или зарегистрированы в плане поддержки непосредственно с корпорацией Майкрософт, можно обратитесь в службу технической поддержки Microsoft Dynamics и создайте новый запрос на обслуживание. Чтобы сделать это, посетите следующий веб-сайт корпорации Майкрософт:

https://mbs.microsoft.com/support/newstart.aspxМожно также службу технической поддержки для Microsoft Dynamics по телефону с помощью этих ссылок для телефонов конкретной страны. Для этого посетите один из следующих веб-узлов корпорации Майкрософт:

Партнеры

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+ContactsКлиенты

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmВ особых случаях оплата, предусмотренная в службу поддержки может быть отменена Если специалист службы технической поддержки Microsoft Dynamics и связанных продуктов определит, что решения проблемы является специально выпущенное. Затраты на обычные службы поддержки будет применяться к любые дополнительные вопросы и проблемы, которые не соответствуют требованиям особым обновлением.



Как получить исправление Microsoft Dynamics NAV или обновления файлов

После запроса исправления Microsoft Dynamics NAV, гиперссылка будет отправлено вам по электронной почте.


Это сообщение будет содержать гиперссылку и пароль. Можно использовать гиперссылки для загрузки исправления Microsoft Dynamics NAV или файлов обновления. Если щелкнуть гиперссылку, откроется диалоговое окно Загрузка файла — предупреждение безопасности . Затем вы предложение запустить, сохранить или отменить загрузку.


Если нажать кнопку выполнить, начнется процесс извлечения и загрузки. Необходимо указать папку для новых файлов и затем указать пароль.


Если нажать кнопку Сохранить, укажите путь для сохранения сжатого файла. При открытии сохраненного файла, вам будет предложено указать путь к файлам. Затем необходимо указать пароль, полученный в сообщении электронной почты.


Если нажать кнопку Отмена, процесс загрузки прекратится.


Установка исправления Microsoft Dynamics NAV или файл обновления

Обновления и исправления платформы Microsoft Dynamics NAV будут доступны как отдельные файлы. Чтобы установить Microsoft Dynamics NAV исправление или обновление, необходимо заменить существующие файлы установки Microsoft Dynamics NAV с исправление или обновление файлов. Чтобы сделать это, выполните следующие действия.

Шаг 1: Замените файлы в Microsoft Dynamics NAV классический клиент установки

В установке Microsoft Dynamics NAV классический клиент Замените следующие файлы с помощью исправления или обновления файла.

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Dbm.dll

6.0.31671.0

427,848

19-Sep-2010

08:42

x86

Fin.exe

6.0.31671.0

12,640,584

19-Sep-2010

08:42

x86

Finhlink.exe

6.0.31671.0

452,432

19-Sep-2010

08:42

x86

Finsql.exe

6.0.31671.0

12,762,960

19-Sep-2010

08:42

x86

Nc_netb.dll

6.0.31671.0

96,592

19-Sep-2010

08:42

x86

Nc_tcp.dll

6.0.31671.0

98,640

19-Sep-2010

08:42

x86

Nc_tcps.dll

6.0.31671.0

141,136

19-Sep-2010

08:42

x86

Ndbcs.dll

6.0.31671.0

1,350,480

19-Sep-2010

08:42

x86

Slave.exe

6.0.31671.0

152,400

19-Sep-2010

08:42

x86

Чтобы заменить существующие файлы Microsoft Dynamics NAV, выполните следующие действия.

  1. Закройте Microsoft Dynamics NAV классический клиент.

  2. Перейдите в каталог установки Microsoft Dynamics NAV классический клиент. Классический клиента Microsoft Dynamics NAV обычно устанавливается в следующий каталог:

    Dynamics создаваемую C:\Program NAV\60\Classic

  3. Скопируйте файлы, которые вы загрузили.

  4. Вставьте загруженные файлы в каталоге установки Microsoft Dynamics NAV классический клиент.

  5. Нажмите кнопку Да, чтобы перезаписать файлы в каталоге.

Шаг 2: Замените файлы в Microsoft Dynamics NAV ролеориентированного установки клиента

В Microsoft Dynamics NAV ролеориентированного установки клиента Замените следующие файлы с помощью исправления или обновления файла.

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Microsoft.dynamics.framework.patterns.dll

1.3.10803.316

71,656

18-Sep-2010

23:16

x86

Microsoft.dynamics.framework.ui.dll

1.3.10803.316

698,328

18-Sep-2010

23:16

x86

Microsoft.dynamics.framework.ui.mapping.dll

1.3.10803.316

104,424

18-Sep-2010

23:16

x86

Microsoft.dynamics.framework.ui.navigation.dll

1.3.10803.316

34,800

18-Sep-2010

23:16

x86

Microsoft.dynamics.framework.ui.ux2006.dll

1.3.10803.316

92,136

18-Sep-2010

23:16

x86

Microsoft.dynamics.framework.ui.ux2006.winforms.dll

1.3.10803.316

63,480

18-Sep-2010

23:16

x86

Microsoft.dynamics.framework.ui.windows.dll

1.3.10803.316

83,944

18-Sep-2010

23:16

x86

Microsoft.dynamics.framework.ui.winforms.controls.dll

1.3.10803.316

2,217,984

18-Sep-2010

23:16

x86

Microsoft.dynamics.framework.ui.winforms.dll

1.3.10803.316

694,256

18-Sep-2010

23:16

x86

Microsoft.dynamics.nav.client.builder.dll

6.0.31671.0

198,544

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.client.exe

6.0.31671.0

149,376

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.client.interop.communicator.dll

1.0.559.183

75,688

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.client.serviceconnection.dll

6.0.31671.0

104,352

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.client.ui.dll

6.0.31671.0

509,824

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.client.winforms.dll

6.0.31671.0

341,904

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.client.winforms.tlb

Неприменимо

2,680

19-Sep-2010

05:25

Неприменимо

Microsoft.dynamics.nav.language.dll

6.0.31671.0

2,000,768

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.types.dll

6.0.31671.0

567,160

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.watson.dll

6.0.31671.0

42,880

19-Sep-2010

08:31

x86

Microsoft.office.interop.outlook.dll

10.0.4504.0

395,136

19-Sep-2010

08:42

x86

Чтобы заменить эти файлы, выполните следующие действия.

  1. Закройте Microsoft Dynamics NAV ролеориентированного клиента.

  2. Перейдите в каталог установки Microsoft Dynamics NAV ролеориентированного клиента. Microsoft Dynamics NAV ролеориентированный клиент обычно устанавливается в следующий каталог:

    Клиент NAV\60\RoleTailored Dynamics создаваемую C:\Program

  3. Скопируйте файлы, которые вы загрузили.

  4. Вставьте загруженные файлы в каталоге установки Microsoft Dynamics NAV ролеориентированного клиента.

  5. Нажмите кнопку Да, чтобы перезаписать файлы в каталоге.

Шаг 3: Замените файлы в Microsoft Dynamics NAV Server установки

В установке Microsoft Dynamics NAV Server Замените следующие файлы с помощью исправления или обновления файла.

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Httpcfg.exe

5.2.3790.0

22,352

19-Sep-2010

08:41

x86

Microsoft.dynamics.nav.language.dll

6.0.31671.0

2,000,768

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.ncl.dll

6.0.31671.0

608,120

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.server.exe

6.0.31671.0

141,184

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.service.dll

6.0.31671.0

145,280

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.service.runtime.dll

6.0.31671.0

75,664

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.service.webservices.dll

6.0.31671.0

145,304

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.types.dll

6.0.31671.0

567,160

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.watson.dll

6.0.31671.0

42,880

19-Sep-2010

08:31

x86

Nclcsrt.etx

Неприменимо

89,525

19-Sep-2010

01:46

Неприменимо

Nclcsrt.stx

Неприменимо

91,724

19-Sep-2010

01:46

Неприменимо

Nclcsrts.dll

6.0.31671.0

1,485,648

19-Sep-2010

08:41

x86

Ndbcs.dll

6.0.31671.0

1,350,480

19-Sep-2010

08:41

x86

Чтобы заменить эти файлы, выполните следующие действия.

  1. Остановите Microsoft Dynamics NAV Server.

  2. Перейдите в каталог установки Microsoft Dynamics NAV Server. Microsoft Dynamics NAV Server обычно устанавливается в следующий каталог:

    Dynamics создаваемую C:\Program NAV\60\Service

  3. Скопируйте файлы, которые вы загрузили.

  4. Вставьте загруженные файлы в каталоге установки Microsoft Dynamics NAV Server.

  5. Нажмите кнопку Да, чтобы перезаписать файлы в каталоге.

  6. Для запуска Microsoft Dynamics NAV Server.

Шаг 4: Замена файлов на сервер приложения Microsoft Dynamics NAV

Если установлено приложение сервер Microsoft Dynamics NAV, замените следующие файлы при установке сервера приложений Microsoft Dynamics NAV, с помощью исправления или обновления.

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Dbm.dll

6.0.31671.0

427,848

19-Sep-2010

08:42

x86

Nas.exe

6.0.31671.0

2,271,560

19-Sep-2010

08:42

x86

Nassql.exe

6.0.31671.0

2,370,384

19-Sep-2010

08:42

x86

Ndbcs.dll

6.0.31671.0

1,350,480

19-Sep-2010

08:42

x86

Slave.exe

6.0.31671.0

152,400

19-Sep-2010

08:42

x86

Чтобы заменить файлы, выполните следующие действия.

  1. Остановите сервер приложений Microsoft Dynamics NAV.

  2. Перейдите в каталог установки сервера приложений Microsoft Dynamics NAV. Приложение Microsoft Dynamics NAV Server обычно устанавливается в следующий каталог:

    Сервер NAV\60\Application Dynamics создаваемую C:\Program

  3. Скопируйте файлы, которые вы загрузили.

  4. Вставьте в каталоге установки сервера приложений Microsoft Dynamics NAV загруженные файлы.

  5. Нажмите кнопку Да, чтобы перезаписать файлы в каталоге.

  6. Запустите сервер Microsoft Dynamics NAV Application Server.

Шаг 5: Замените файлы в установку Microsoft Dynamics NAV SDK

Если у вас есть Microsoft Dynamics NAV установлен пакет SDK, замените следующие файлы.

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Cf.h

Неприменимо

57,736

19-Sep-2010

05:24

Неприменимо

Cfront.dll

6.0.31671.0

1,577,808

19-Sep-2010

08:42

x86

Cfront.ocx

6.0.31671.0

111,952

19-Sep-2010

08:42

x86

Cfrontsql.dll

6.0.31671.0

1,787,736

19-Sep-2010

08:42

x86

Libload.c

Неприменимо

31,718

19-Sep-2010

00:06

Неприменимо

Microsoft.dynamics.nav.cfront.cfrontdotnet.dll

6.0.31671.0

182,168

19-Sep-2010

08:31

x86

Microsoft.dynamics.nav.cfront.cfrontdotnet.xml

Неприменимо

442,447

19-Sep-2010

00:28

Неприменимо

Sample.c

Неприменимо

28,718

19-Sep-2010

00:06

Неприменимо

Sample.exe

6.0.31671.0

152,400

19-Sep-2010

08:42

x86

Чтобы заменить файлы, выполните следующие действия.

  1. Найдите пакет SDK Microsoft Dynamics NAV папки установки. В пакет SDK Microsoft Dynamics NAV обычно устанавливается в следующих каталогах:

    Dynamics создаваемую C:\Program NAV\60\SDK\CFRONT

    Компоненты NAV\60\SDK\Communication Dynamics создаваемую C:\Program

    C:\Program Files\Common создаваемую Dynamics NAV\Communication компонента

  2. Выберите для обновления, C/Front и коммуникационные компоненты SDK.

  3. Скопируйте файлы, которые вы загрузили.

  4. Вставьте в соответствующий каталог установки пакета SDK Microsoft Dynamics NAV загруженные файлы.

  5. Нажмите кнопку Да, чтобы перезаписать файлы в каталоге.

Примечание. Если вы загрузили исправление или обновление для связи компонентов, необходимо зарегистрировать DLL-файлы по отдельности.

Шаг 6: Замените файлы в установку Microsoft Dynamics NAV ODBC

Если у вас установлен драйвер Microsoft Dynamics NAV ODBC, замените следующие файлы установки драйвера Microsoft Dynamics NAV ODBC.

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Cfront.dll

6.0.31671.0

1,577,808

19-Sep-2010

08:42

x86

Dbm.dll

6.0.31671.0

427,848

19-Sep-2010

08:42

x86

Nc_netb.dll

6.0.31671.0

96,592

19-Sep-2010

08:42

x86

Nc_tcp.dll

6.0.31671.0

98,640

19-Sep-2010

08:42

x86

Nc_tcps.dll

6.0.31671.0

141,136

19-Sep-2010

08:42

x86

Nodbc.dll

6.0.31671.0

2,141,008

19-Sep-2010

08:42

x86

Nodbc.xml

Неприменимо

1,209

25-Aug-2009

16:43

Неприменимо

Nodbccfg.cfg

6.0.31671.0

724,480

19-Sep-2010

01:20

Неприменимо

Nodbccfg.xml

Неприменимо

2,472

25-Aug-2009

16:43

Неприменимо

Slave.exe

6.0.31671.0

152,400

19-Sep-2010

08:42

x86

Чтобы заменить файлы, выполните следующие действия.

  1. Перейдите в каталог установки драйвера Microsoft Dynamics NAV ODBC. Microsoft Dynamics NAV ODBC драйвер обычно устанавливается в следующий каталог:

    Dynamics создаваемую C:\Program NAV\60\ODBC

  2. Скопируйте файлы, которые вы загрузили.

  3. Вставьте загруженные файлы в каталоге установки Microsoft Dynamics NAV ODBC драйвер.

  4. Нажмите кнопку Да, чтобы перезаписать файлы в каталоге.

Предварительные условия

Необходимо иметь Microsoft Dynamics NAV 2009 Пакет обновления 1 для установки этого исправления.

Статус

Корпорация Майкрософт подтверждает, что это является ошибкой в продуктах Майкрософт, перечисленных в разделе "Относится к".

Дополнительные сведения

Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:

Описание 824684 Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт

Примечание. Это статья «БЫСТРАЯ ПУБЛИКАЦИЯ», созданная непосредственно из технической поддержки корпорации Майкрософт. Сведения, содержащиеся в настоящем документе, предоставляются "как есть" в ответ на возникающие проблемы. В результате скорости предоставления материалов они могут включать опечаток и быть изменены в любое время без предварительного уведомления. Другие вопросы, связанные с Условиями использования см.

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?
После нажатия кнопки "Отправить" ваш отзыв будет использован для улучшения продуктов и служб Майкрософт. Эти данные будут доступны для сбора ИТ-администратору. Заявление о конфиденциальности.

Спасибо за ваш отзыв!

×