Проблемы
В 2019 Microsoft Exchange Server или Exchange Server 2016 Предположим, что набор веб-прокси сервера Exchange Server использует для доступа в Интернет с помощью параметра InternetWebProxy и нет прямого доступа к Интернету. Может наблюдаться что OAuth подключения всегда завершается неудачей, если проверить его с помощью командлета Теста OAuthConnectivity , даже если соединение работает нормально.
Причина
Эта проблема возникает, так как командлет OAuthConnectivity тест не учитывают InternetWebProxy набор настроек, заданных на Exchange Server. Таким образом Если Exchange Server заблокирован для прямого подключения к Интернету, вы не проверить правильно OAuth возможность подключения.
Статус
Корпорация Майкрософт подтверждает наличие этой проблемы в своих продуктах, которые перечислены в разделе "Применяется к".
Решение
Чтобы устранить эту проблему, установите одно из следующих обновлений.Для Exchange Server 2019 установка накопительного обновления 1 для Exchange Server 2019 или более поздней версии накопительного обновлениядля Exchange Server 2019.
2016 Exchange Server установите Накопительное обновление 12 2016 Exchange Server или более поздней версии накопительного обновления для Exchange Server 2016.
Ссылки
Дополнительные сведения о терминологии, которую корпорация Майкрософт использует для описания обновлений программного обеспечения.