Проблемы
При попытке открыть базу знаний (KB) для управления доменом или для других действий в клиенте качества данных в Microsoft SQL Server 2012 появляется следующее сообщение об ошибке:
В базе данных уже есть конфигурация с именем "RecentList: KB: домен \ имя_пользователя". Код сообщения: ConfigServiceConfigurationAlreadyExists
Причина
Эта проблема возникает, несмотря на то, что в сравнении с текущим зарегистрированным именем пользователя и списком последних имен пользователей учитывается регистр, но при этом имя пользователя, которое хранится во внутреннем списке последних открытых баз знаний, не учитывает регистр. Например, выполните указанные ниже действия.
-
Вход в Windows осуществляется с помощью учетной записи с именем "domain\user1" один раз.
-
Клиент качества данных успешно используется.
-
Вы выйдете из Windows, а затем снова войдите в Windows с помощью учетной записи с именем "DOMAIN\USER1.".
-
Вы пытаетесь использовать клиент качества данных, чтобы открыть базу знаний.
Ошибка может возникать из-за различий в строчных и прописных буквах, которые использовались при вводе имени пользователя для входа в Windows.
Решение
Сведения о накопительном пакете обновления
SQL Server 2012
Исправление для этой проблемы впервые выпущено в накопительном обновлении 1. Для получения дополнительных сведений о том, как получить этот накопительный пакет обновления для SQL Server 2012, щелкните следующий номер статьи базы знаний Майкрософт:
2679368 Накопительный пакет обновления 1 (SP1) для SQL Server 2012Примечание. Так как сборки являются кумулятивными, каждый новый выпуск исправлений содержит все исправления и все исправления безопасности, которые были включены в предыдущий выпуск исправлений для SQL Server 2012. Рекомендуется установить последнюю версию исправления, которая включает это исправление. Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
2692828 Сборки SQL Server 2012, выпущенные после выпуска SQL Server 2012
Статус
Корпорация Майкрософт подтверждает наличие этой проблемы в своих продуктах, которые перечислены в разделе "Применяется к".
Обходное решение
Чтобы обойти эту проблему, воспользуйтесь одним из описанных ниже методов.
-
Вручную удалите запись из внутренней таблицы для соответствующего пользователя. Для этого выполните указанные ниже действия.
-
Выполните следующую инструкцию, чтобы убедиться в наличии записей.
SELECT * FROM DQS_MAIN.dbo.A_CONFIGURATION WHERE NAME like 'RecentList%';
-
Чтобы удалить запись для соответствующего пользователя, выполните следующую инструкцию:
DELETE DQS_MAIN.dbo.A_Configuration WHERE NAME LIKE 'RecentList%<Domainname>\<Username>';
Или выполните следующую инструкцию, чтобы удалить все недавние записи для всех пользователей. (Это удаляет список всех последних пользователей в клиенте).
DELETE DQS_MAIN.dbo.A_Configuration WHERE NAME LIKE 'RecentList%';
-
-
Используйте правила соответствия прописных букв, чтобы указать учетную запись пользователя при входе на клиентский компьютер качества данных.