Применяется к
Windows 10, version 22H2, all editions

Примечание: В этой статье описано решение известной проблемы, описанной в разделе Работоспособности выпусков Windows и Центре администрирования Майкрософт.

Проблема

У небольшого подмножества клиентов Виртуального рабочего стола Azure, которые используют узлы с несколькими сеансами (AVD) и установили Windows Обновления, выпущенные в период с 23 июля 2024 г. (KB5040525) по 8 октября 2024 г. (KB5044273), могут столкнуться со следующими проблемами: 

  • Длительное зависание от 10 до 30 минут на черном экране после входа пользователя.

  • В приложениях Office, включая Outlook и Teams, возникают сбои единого входа, что препятствует подключению или синхронизации данных пользователями.

Причина

Эта проблема вызвана взаимоблокировкой во взаимодействии между брокером Azure Active Directory (AAD) и базовой службой развертывания AppX (AppxSvc) и службой инфраструктуры фоновых задач. Эта проблема с большей вероятностью возникает, если вы используете контейнеры профилей пользователей FSLogix в многосеансовых средах. FSLogix — это инструмент Майкрософт, который помогает управлять профилями пользователей на компьютерах и ускорять их работу, особенно в виртуальных средах, таких как удаленные рабочие столы.

пользователи Windows 10 для образовательных учреждений выпусков и домашние пользователи Windows, использующие выпуски Home или Pro, вряд ли столкнутся с этой проблемой, так как Виртуальный рабочий стол Azure чаще используется в корпоративных средах.

Решение

Чтобы устранить эту проблему, примените один из следующих параметров, если вы видите событие Microsoft-Windows-AppModel-State с идентификатором 10 в журнале событий приложений со следующей подписью:

  • Описание: не удается загрузить параметры приложения для Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy пакета

  • Код ошибки: -2147024893

Вариант 1. Повторное создание образа затронутого устройства

Выполните следующие действия, чтобы создать пользовательский образ с помощью последнего образа коллекции "Windows 10 Корпоративная с несколькими сеансами, версия 22H2" из Azure Marketplace:

  1. Перейдите в Azure Marketplace Майкрософт. В строке поиска в Marketplace введите Microsoft Windows 10.

  2. На странице Microsoft Windows 10 нажмите кнопку Получить сейчас.

  3. Выполните вход после того, как вам будет предложено ввести свой адрес электронной почты.

  4. На странице Создание приложения в Azure выберите Windows 10 Корпоративная многосеансовой версии 22H2 в раскрывающемся списке План программного обеспечения.

  5. Выбрав образ, нажмите кнопку Создать, чтобы создать новую виртуальную машину.

  6. Выполните следующие действия на странице Создание золотого образа в Azure:

    1. Создайте образ на виртуальной машине Azure, чтобы создать пользовательский образ.

    2. Настройте виртуальную машину, а затем установите 24 октября 2024 г. клиентский компонент Центра обновления Windows (KB5045594).

    3. Заключите snapshot.

    4. Запустите sysprep.

    5. Запишите виртуальную машину.

  7. Теперь вы можете повторно создать образ затронутого устройства AVD с помощью только что созданного пользовательского образа из шага 6.

ЗАМЕТКА  Если вам нужен образ, содержащий KB5045594 исправления этой проблемы, вам придется подождать до 19 ноября 2024 г., чтобы повторно создать образ устройства (чтобы избежать шага 6).

Вариант 2. Установка KB5045594 Центра обновления Windows и добавление скрипта входа пользователя

  1. Выполните обновление на месте затронутого устройства с обновлением Windows 10 версии 22H2 (KB5045594).

  2. После установки обновления Windows (KB5045594) для пользователей, у которых нет существующего сценария входа, создайте новый файл скрипта PowerShell (.ps1), а затем добавьте приведенную ниже команду PowerShell:

    Add-AppxPackage -Register -Path "C:\Windows\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\AppxManifest.xml" -DisableDevelopmentMode

  3. Если у вас уже есть скрипт входа, использующий скрипт PowerShell в групповая политика, можно добавить команду PowerShell, упомянутую в шаге 2, в существующий скрипт PowerShell.

  4. Если у вас есть скрипт входа в систему в формате, отличном от PowerShell, например .bat или .cmd файл, можно выполнить следующие действия.

    1. Создайте файл скриптаPowerShell.ps1 и добавьте команду PowerShell, упомянутую в шаге 2.

    2. Затем добавьте одну из следующих команд в .bat или .cmd файл для выполнения скрипта:

      • Пример использования примера пути SYSVOL: powershell -File "scripts\script.ps1"

      • Пример использования примера локального пути: powershell -File "D:\scripts\script.ps1"

Дополнительная помощь

Для получения дополнительной помощи по этой проблеме рекомендуется отправить запрос на поддержку в службу поддержки Azure.

Ссылки

Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.