Príznaky
Pri pokuse o zdieľanie kalendára pomocou služby Microsoft Outlook, Outlook na webe alebo prostredia Exchange Online PowerShell sa zobrazí niektoré z nasledujúcich chybových hlásení.
Outlook pre Windows
Tento kalendár nemôže zdieľať jedna alebo viac osôb.
Outlook na webe
Nemáte povolenie na zdieľanie kalendára s inými e-mailovými <adresami>.
Exchange Online PowerShell
Vašu žiadosť nie je možné dokončiť. Na zdieľanie tohto kalendára nemáte povolenie.
Príčina
Tento problém sa vyskytuje, ak je kalendár, ktorý zdieľate, dvakrát uvedený na table Kalendár v Outlook. Duplicitný názov kalendára sa zobrazuje rovnako ako názov <poštovej schránky>.
Alternatívne riešenie
Ak chcete tento problém obísť, na odstránenie duplicitného kalendára na table Kalendár použite jeden z nasledujúcich postupov.
Metóda 1: Použitie Outlook pre Windows klienta na odstránenie kalendára
-
Vo Outlook pre Windows otvorte tablu Kalendár a potom vyhľadajte názov kalendára, ktorý je rovnaký ako názov <schránky>.
-
Kliknite pravým tlačidlom myši na kalendár a potom vyberte položku Odstrániť kalendár.
-
Reštartujte Outlook.
Metóda 2: Outlook na webe na odstránenie kalendára
-
Vo Outlook na webe otvorte tablu Kalendár a potom vyhľadajte názov kalendára, ktorý je rovnaký ako názov <vlastníka>.
-
Kliknite pravým tlačidlom myši na kalendár a potom vyberte položku Odstrániť.
Metóda 3: Odstránenie kalendára pomocou mapy MFC
-
Ukončite Outlook a potom zavrite Outlook na webe vo všetkých počítačoch, ktoré sú pripojené k poštovej schránke používateľa.
-
Ak chcete odstrániť duplicitný názov kalendára, postupujte podľa týchto krokov v časti Mapa MFC.
Poznámka Na to, aby ste mohli vykonať tieto kroky, musíte použiť klienta Windows na prihlásenie do počítača vlastníka kalendára alebo mať v klientovi Outlook nakonfigurovaný profil vlastníka Windows.-
Stiahnite si MFCMapi z GitHub.
-
Spustite Mfcmapi.exe.
-
Vyberte ponuku Nástroje a potom vyberte položku Možnosti.
-
Začiarknite toto políčko: Pri volaní MDB_ONLINE OpenMsgStore použite funkciu MDB_ONLINE.
-
Vyberte tlačidlo OK.
-
V ponuke Relácia vyberte položku Prihlásiť sa.
-
Ak sa zobrazí výzva na zadanie profilu, vyberte názov svojho profilu a potom vyberte tlačidlo OK.
-
Na hornej table vyhľadajte a dvakrát kliknite na riadok, ktorý zodpovedá vašej poštovej schránke.
-
Na ľavej table rozbaľte položku Koreňový kontajner.
-
Kliknite pravým tlačidlom myši na položku Bežnézobrazenia a potom vyberte položku Otvoriť tabuľku Priradeného obsahu.
-
V stĺpci Predmet vyhľadajte a vyberte názov kalendára, ktorý je rovnaký ako názov <vlastníka>.
-
Otvorte ponuku Akcie a potom vyberte položku Odstrániť správu.
-
Zavrite okno.
-
V ponuke Relácia vyberte položku Odhlásiť sa a odhláste sa z MFCMapi.
-
Stav
Incident Microsoft 365 služby EX249095, ktorý sledoval tento problém, bol vyriešený tak, ako bol opravený 31. mája 2021.