Oprava: IIS Manager nezobrazí adresy IP, ktoré sú priradené k sieťovému adaptéru spolu s skipassource

Príznaky

Predstavte si nasledujúcu situáciu:

  • Nainštalujete Internet Information Services (IIS) 7.0 v počítači so systémom Windows Vista alebo Windows Server 2008. Alebo nainštalovať IIS 7.5 v počítači so systémom Windows 7 alebo Windows Server 2008 R2.

  • Nainštalujte rýchlu opravu KB975808 v počítači so systémom Windows Vista alebo Windows Server 2008. Alebo môžete nainštalovať rýchlu opravu KB2386184 v počítači so systémom Windows 7 alebo Windows Server 2008 R2. Jej inštalácii slúži na priradenie adresy IP, ktoré nie sú registrované pre odchádzajúce prenosy serveroch systém DNS (Domain Name) pomocou príkazu netshskipassource príznak.Poznámka: Ďalšie informácie o rýchle opravy, kliknite na nasledovné číslo článku v závislosti od situácie, zobrazte článok databázy Microsoft Knowledge Base:

    Všetky adresy IP sú registrované na servery DNS, keď sú priradené adresy IP jeden sieťový adaptér v počítači so systémom Windows Server 2008 SP2 alebo Windows Vista SP2 IP adresy sú stále zaregistrované na DNS servery, aj keď IP adresy sa nepoužívajú pre odchádzajúce prenosy v počítači so systémom Windows 7 alebo Windows Server 2008 R2

  • Môžete pridať novú IP pre sieťový adaptér spolu s skipassource príkaz netsh . Napríklad, používate príkaz:

    Netsh int ipv4 pridajte adresu Interface_NameIP_Address skipassource = true

  • V službe IIS Manager, pokúsite pridať väzby adresu webovej lokality.

V takomto prípade nie je zobrazená adresu do poľa adresa IP v službe IIS Manager.

Príčina

Tento problém sa vyskytuje, pretože IIS Manager používa len postup vráti adresy IP servera DNS dotaz. Adresy IP, ktoré sú priradené spolu s skipassource nie sú zaregistrované v systéme DNS. Preto nie sú zobrazené adresy IP.

Riešenie

Ak chcete vyriešiť tento problém, použiť túto rýchlu opravu. Po použití tejto rýchlej opravy, Služba IIS Manager vráti zoznam všetkých dostupných adries IP.

Informácie o rýchlej oprave

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba problém popísaný v tomto článku. Rýchlu opravu použite len v systémoch, v ktorých sa vyskytuje problém popísaný v tomto článku. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu. Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy. Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo postup, ako vytvoriť samostatnú servisnú požiadavku, nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:

Poznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Požiadavky

Musíte mať IIS 7.0 a IIS 7.5 nainštalovaný na jeden z nasledujúcich operačných systémov tejto rýchlej opravy:

  • Windows 7

  • Windows 7 Service Pack 1 (SP1)

  • Windows Server 2008 R2

  • Windows Server 2008 R2 Service Pack 1 (SP1)

  • Windows Vista Service Pack 2 (SP2)

  • Windows Server 2008 Service Pack 2 (SP2)

Informácie o reštartovaní

Po použití tejto rýchlej opravy nie je potrebné reštartovať počítač.

Informácie o nahradení

Táto rýchla oprava nenahrádza predchádzajúcu rýchlu opravu.

Informácie o súboroch

Anglická verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu Časové pásmo v položke Dátum a čas v ovládacom paneli.

Windows Vista a Windows Server 2008 súbor informácií poznámky

Dôležité upozornenie: Rýchle opravy systémov Windows Vista a Windows Server 2008 sa nachádzajú v rovnakých balíkoch. Avšak iba "Windows Vista" je uvedené na stránke žiadosti o rýchlu opravu. Ak chcete požiadať o opravu hotfix, ktorá je určená pre jeden alebo oba operačné systémy, vyberte rýchlu opravu, ktorá je uvedená v časti "Windows Vista" na stránke. Vždy si pozrite časti "Vzťahuje sa na" v článkoch, aby ste zistili skutočný operačný systém, pre ktorý je daná rýchla oprava určená.

  • Súbory vzťahujúce sa na konkrétny produkt, SR_Level (RTM, SPn), a priečinok služby (LDR, GDR) je identifikovať na základe kontroly čísel verzií súborov tak, ako je uvedené v nasledujúcej tabuľke.

  • Service Pack 1 je integrovaný do verziou Windows Server 2008. Medzníky RTM sa preto vzťahujú iba na systém Windows Vista. Medzníky RTM majú číslo verzie 6.0.0000.xxxxx.

  • Súbory MANIFEST (.manifest) a MUM (.mum), ktoré sa inštalujú pre jednotlivé prostredia, sú uvedené samostatne v časti „Ďalšie informácie o súboroch pre systémy Windows Vista a Windows Server 2008“. Súbory MUM a súbory MANIFEST a priradené súbory katalógu zabezpečenia (.cat), sú mimoriadne dôležité na zachovanie stavu aktualizovaných súčastí. Súbory katalógov zabezpečenia, pre ktoré nie sú uvedené atribúty, sú podpísané digitálnym podpisom spoločnosti Microsoft.

Potrebujete ďalšiu pomoc?

Rozšírte svoje zručnosti
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pripojiť k Microsoft insiderov chcú

Považujete poskytnuté informácie za užitočné?

Ďakujem za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×