Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

Predstavte si nasledujúcu situáciu:

  • Máte aplikáciu, ktorá pracuje v Internet Information Services (IIS) 7.0 v počítači so systémom Windows Vista alebo v počítači so systémom Windows Server 2008.

  • Používate overovanie systému Windows a v režime jadra overovania zapnuté.

    Poznámka: Toto je predvolené.

  • Máte useAppPoolCredentials atribút nastavený na hodnotu true v časti overenie v súbore Applicationhost.config. Možno ste pridali tento atribút na používanie overovania Kerberos použijete konto v doméne pre identita fondu aplikácií. Napríklad tento atribút musí pridať, ak používate lokalitu Microsoft Office SharePoint Server. V časti overenie nasledujúcemu.

    <windowsAuthentication enabled="true" useKernelMode="true" useAppPoolCredentials="true"/>

    Poznámka: V súbore Applicationhost.config sa nachádza v jednotke: \Windows\System32\inetsrv\config priečinok.

V tomto prípade operačný systém môže zlyhať. Okrem toho zobrazí Stop 0x0000007e chybové hlásenie na modrej obrazovke.

Poznámka: Tento problém sa zvyčajne vyskytuje na webových serveroch hostiteľské Office SharePoint Server 2007. Príčinou tohto problému požiadavky konfigurácie balíka Office SharePoint Server 2007 používa overenie protokolom Kerberos. Problém sa môže vyskytnúť na ktorúkoľvek webovú lokalitu, ktorá sa používa v režime jadra overovania protokolom Kerberos a doménu ako identita fondu aplikácií vlastné.

Príčina

Tento problém sa vyskytuje z dôvodu chyby ovládač režimu jadra HTTP (HTTP.sys).

Riešenie

Informácie o rýchlej oprave

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v systémoch, v ktorých sa vyskytuje problém popísaný v tomto článku. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy.

Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na webovej lokalite spoločnosti Microsoft:

http://support.microsoft.com/contactus/?ws=supportPoznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Dôležité rýchlych opráv systému Windows Vista a Windows Server 2008 sa nachádzajú v rovnakých balíkoch. Však iba jeden z týchto produktov môže uvedené na stránke "Rýchla oprava žiadosť". Ak chcete požiadať o opravu hotfix, ktorá je určená pre systém Windows Vista a Windows Server 2008, stačí vybrať produkt, ktorý je uvedený na stránke.

Požiadavky

Musíte mať systém Windows Vista Service Pack 1 (SP1) alebo Windows Server 2008 nainštalovaný použiť túto rýchlu opravu.

Požiadavka na reštartovanie

Po použití tejto rýchlej opravy je nutné reštartovať počítač.

Informácie o nahradení rýchlej opravy

Táto rýchla oprava nenahrádza predchádzajúcu rýchlu opravu.

Informácie o súboroch

Anglická verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu Časové pásmo v položke Dátum a čas v ovládacom paneli.

Služba IIS 7.0, x86

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Http.sys

6.0.600 1.22375

401,408

12-Feb-2009

03:33

x86

Služba IIS 7.0, x64

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Http.sys

6.0.600 1.22375

596,480

12-Feb-2009

04:10

x64

SLUŽBA IIS 7.0, IA-64

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Http.sys

6.0.600 1.22375

1,143,808

12-Feb-2009

02:54

IA-64

Alternatívne riešenie

Obísť tento problém, vypnite overovania v režime jadra pomocou jedného z nasledujúcich postupov.

Metóda 1

Nastavte hodnotu prvku useKernelMode False v príslušných windowsauthentication v súbore ApplicationHost.config.

<windowsAuthentication enabled="true" useKernelMode="false"/>

Metóda 2

Zakázať overovania v režime jadra pomocou IIS Manager. Ak to chcete urobiť, postupujte nasledovne:

  1. Kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajte príkaz
    inetmgr.exe, a potom kliknite na tlačidlo OK.

  2. V službe IIS Manager, rozbaľte
    názov servera, rozbaľte webovej lokalitya kliknite na webovej lokalite, ktoré chcete zmeniť.

  3. Dvakrát kliknite na overeniekliknite na položku Windows Authentication zvýraznite a na table akcií kliknite na tlačidlo Rozšírené nastavenia .

  4. Zrušte začiarknutie políčka povoliť overovanie režime jadra .

Po vypnutí režimu jadra overovania, musíte reštartovať službu HTTP. Tým sa zastaví IIS. Spustite nasledujúce príkazy v príkazovom riadku.

  • NET STOP HTTP

  • NET START HTTP

  • IISRESET TLAČIDLÁ/ŠTART

Poznámka: Tieto príkazy sa zastaviť službu HTTP. Po zastavení služby HTTP, zobrazí sa hlásenie s upozornením, že pravdepodobne zastavená aj služby, ktoré sú závislé od služby HTTP. Pozor zaznamenajte závislé služby tak, aby môžete určiť, či chcete pokračovať a reštartovaní ich po reštartovaní služby HTTP. Služby, ktoré sú závislé od služby HTTP závisí Windows úlohy a aplikácie, ktoré sú nainštalované v počítači.

Stav

Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.

Ďalšie informácie

Výstup zásobníka volania

Ak používate Debugging Tools for Windows a symbolového servera spoločnosti Microsoft na kontrolu súboru výpisu pamäte, ktorý vzniká, keď dôjde k zlyhaniu, zistíte Zásobník volaní, ktorý sa podobá nasledujúcemu hláseniu:
Child-SP RetAddr Call Sitefffffa60`02ff5b58 fffff800`01ba3644 nt!KeBugCheckEx
fffffa60`02ff5b60 fffff800`01b60f71 nt!PspUnhandledExceptionInSystemThread+0x24
fffffa60`02ff5ba0 fffff800`018c87d8 nt!PspSystemThreadStartup+0x9e
fffffa60`02ff5bd0 fffff800`018c86bd nt!_C_specific_handler+0x8c
fffffa60`02ff5c40 fffff800`018cfcff nt!RtlpExecuteHandlerForException+0xd
fffffa60`02ff5c70 fffff800`0188cd83 nt!RtlDispatchException+0x22f
fffffa60`02ff6360 fffff800`018b51a9 nt!KiDispatchException+0xc3
fffffa60`02ff6960 fffff800`018b3fa5 nt!KiExceptionDispatch+0xa9
fffffa60`02ff6b40 00000000`00010005 nt!KiPageFault+0x1e5
fffffa60`02ff6cd8 fffffa60`0805129e 0x10005
fffffa60`02ff6ce0 fffff800`01ad7ff3 HTTP!UlpThreadPoolWorker+0x28e
fffffa60`02ff6d50 fffff800`018ef546 nt!PspSystemThreadStartup+0x57
fffffa60`02ff6d80 00000000`00000000 nt!KxStartSystemThread+0x16
Poznámka: Zásobník volaní, ktorý znamená, že dochádza k zlyhaniu tento systém predstavuje HTTP! UlpThreadPoolWorker.

Odkazy

Ďalšie informácie o používaní protokolom Kerberos s Office SharePoint Server, nájdete na nasledujúcich webových lokalitách:

http://www.harbar.net/archive/2008/05/18/Using-Kerberos-with-SharePoint-on-Windows-Server-2008.aspx

http://blogs.msdn.com/webtopics/archive/2009/01/19/service-principal-name-spn-checklist-for-kerberos-authentication-with-iis-7-0.aspx

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×