Príznaky
Automatické spustenia postupu pracovnej plochy zlyhajú s kódom chyby AADMachineAlwaysPromptingForPassword , ako je znázornené na nasledujúcej snímke obrazovky.
Príčina
Power Automate pre počítače sa nepodarilo overiť vaše poverenia služby Azure Active Directory v počítači. Zvyčajne je to spôsobené nastavením skupinovej politiky v počítači.
Riešenie
Ak chcete zistiť, či problém spôsobuje nastavenie skupinovej politiky, môžete prejsť do editora lokálnych skupinová politika (spustiť > spustiť > "gpedit.msc"). V tejto časti si pozrite politiku lokálneho počítača > konfiguráciu počítača > šablóny na správu > súčasti systému Windows > služby vzdialenej pracovnej plochy > hostiteľa relácie vzdialenej pracovnej plochy > zabezpečenie a pozrite si hodnotu Vždy po pripojení zobraziť výzvu na zadanie hesla. Ak je táto hodnota nastavená na hodnotu true, na zakázaní politiky pre daný počítač je potrebné spolupracovať s IT oddelením. Všimnite si, že táto hodnota sa v databáze Registry prejaví aj v nasledujúcej ceste: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services; ak kľúč služieb Terminal Services má hodnotu fPromptForPassword nastavenú na hodnotu 1, znamená to, že nastavenie je povolené a musíte ho zakázať v spolupráci s IT oddelením (jednoducho zmena hodnoty databázy Registry vo všeobecnosti nestačí, pretože sa môže vrátiť).
Ak "Vždy výzva na zadanie hesla pri pripojení" nie je povolená, ale stále sa vyskytuje chyba, potom použite regedit otvoriť nasledujúci kľúč databázy Registry: Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp. Potom vyhľadajte DWORD fPromptForPassword a nastavte ho na hodnotu 0. Ak DWORD neexistuje, môžete ho vytvoriť.