Príznaky
Ak máte dlhodobý pracovný postup, ktorý obsahuje podmienky čakania v systéme Microsoft Dynamics CRM 2011, pracovný postup sa môže prejsť do stavu čakania a môže sa stať, že sa bude musieť obnoviť.
Príčina
Tento problém sa vyskytuje, ak podmienky v čakacej podmienke nie je možné vyhodnotiť správne, keď sa entity v podmienke čakania zmenia mimo vykonávania pracovného postupu pred alebo súčasne s vyhodnotením podmienky čakania.
Riešenie
Ak chcete problém vyriešiť, použite súhrnnú aktualizáciu 13 pre systém Microsoft Dynamics CRM 2011 alebo novšiu verziu. Ďalšie informácie nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné čísla článkov:
2791312 K dispozícii je súhrnná aktualizácia 13 pre systém Microsoft Dynamics CRM 2011
2849744 K dispozícii je súhrnná aktualizácia 14 pre systém Microsoft Dynamics CRM 2011
2843571 K dispozícii je súhrnná aktualizácia 15 pre systém Microsoft Dynamics CRM 2011 Po použití súhrnnej aktualizácie budete musieť použiť nástroj OrgDBOrgSettings pre systém Microsoft Dynamics CRM 2011. Ďalšie informácie o tomto nástroji nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku:
2691237 Nástroj OrgDBOrgSettings pre systém Microsoft Dynamics CRM 2011 Musíte zmeniť nastavenie ActivateAdditionalRefreshOfWorkflowConditions v OrgDBOrgSettings na hodnotu True. Poznámka: Predvolená hodnota tohto nastavenia je False.
Stav
Spoločnosť Microsoft potvrdzuje, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v tomto článku v časti Informácie v tomto článku sa týkajú nasledujúcich produktov.