Príznaky
V počítači so systémom Microsoft Internet a Acceleration (ISA) Server 2004, ISA Server 2000 alebo zablokovať údaje vzdialeného volania Procedúr. Pri výskyte tohto problému niektoré klientom Microsoft Outlook sa nespustí, alebo môže byť schopný pripojiť k serveru Microsoft Exchange. Keď sa prejaví toto správanie, príslušné klientov zobraziť niektoré z nasledujúcich chybových hlásení:
Úloha "Microsoft Exchange Server" ohlásila chybu (0x80040115): "pripojenie k serveru Microsoft Exchange nie je k dispozícii. Program Outlook musí byť v režime online alebo pripojený na dokončenie tejto akcie."
Microsoft Office Outlook sa nedá spustiť.
Nepodarilo sa otvoriť okno programu Outlook.
Súbor priečinkov sa nepodarilo otvoriť.
Nepodarilo sa otvoriť okno programu Outlook.
Poznámka: V prípadoch Microsoft Small Business Server, tento problém môže nastať, keď program Outlook je nainštalovaný na serveri so spustenými Terminálovými službami režime zdieľanie aplikácie.
Príčina
Tento problém sa môže vyskytnúť, ak sú splnené nasledujúce podmienky:
-
Outlook klientsky počítač je spustený systém Microsoft Windows Server 2003 Service Pack 1 (SP1) alebo 64-bitovú verziu systému Microsoft Windows XP.
-
ISA Server počítač je pripojený do klientskeho počítača a servera Microsoft Exchange.
Keď zapnete filter ISA Server RPC, RPC filter vynúti dodržiavanie podmnožinou používa program Microsoft Exchange Server MAPI komunikácie RPC protokolu. Filter ISA Server RPC je však nekompatibilné zmeny protokolu RPC 64-bitové verzie systému Windows XP a Windows Server 2003 SP1.
Riešenie
ISA Server 2004
Informácie o balíku Service Pack
Ak chcete vyriešiť tento problém, Získajte najnovší balík service pack pre Internet Security and Acceleration Server 2004. Ďalšie informácie získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
891024 ako získať najnovší balík service pack pre ISA Server 2004
Informácie o rýchlej oprave
Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v počítačoch s týmto konkrétnym problémom. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu. Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy. Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na webovej lokalite spoločnosti Microsoft:
http://support.microsoft.com/contactus/?ws=supportPoznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii. Tieto súbory sú k dispozícii na prevzatie z Microsoft Download Center: ISA 2004, Enterprise Edition
119591 Získanie podporných súborov zo služieb onlineSpoločnosť Microsoft preverila, či tento súbor neobsahuje vírusy. Spoločnosť Microsoft použila aktuálny antivírusový softvér, dostupný v deň zverejnenia tohto súboru. Súbor je uložený na zabezpečených serveroch, ktoré neumožňujú neoprávnené zmeny súborov. ISA 2004, Standard Edition
119591 Získanie podporných súborov zo služieb onlineSpoločnosť Microsoft preverila, či tento súbor neobsahuje vírusy. Spoločnosť Microsoft použila aktuálny antivírusový softvér, dostupný v deň zverejnenia tohto súboru. Súbor je uložený na zabezpečených serveroch, ktoré neumožňujú neoprávnené zmeny súborov.
Požiadavky
Ak chcete použiť túto rýchlu opravu, musíte mať jednu z nasledujúcich verzií programu ISA Server 2004 nainštalovaný:
-
ISA Server 2004, Standard Edition s balíkom Service Pack 1 (SP1)
-
ISA Server 2004 Enterprise Edition
Požiadavka na reštartovanie
Po použití tejto rýchlej opravy je nutné reštartovať počítač.
Informácie o nahradení rýchlej opravy
Táto rýchla oprava nenahrádza žiadne iné rýchle opravy.
Informácie o súboroch
Anglická verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu časové pásmo v nástroji dátum a čas v ovládacom paneli. Date Time Version Size File name Edition ------------------------------------------------------------------ 20-Apr-2005 21:28 4.0.2163.263 133,392 Rpcfltr.dll Standard 14-May-2005 19:46 4.0.3440.263 129,816 Rpcfltr.dll Enterprise
ISA Server 2000
Informácie o rýchlej oprave
Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v počítačoch s týmto konkrétnym problémom. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu. Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy. Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na webovej lokalite spoločnosti Microsoft:
http://support.microsoft.com/contactus/?ws=supportPoznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii. Je k dispozícii na prevzatie z Microsoft Download Center nasledujúci súbor:
119591 Získanie podporných súborov zo služieb onlineSpoločnosť Microsoft preverila, či tento súbor neobsahuje vírusy. Spoločnosť Microsoft použila aktuálny antivírusový softvér, dostupný v deň zverejnenia tohto súboru. Súbor je uložený na zabezpečených serveroch, ktoré neumožňujú neoprávnené zmeny súborov.
Požiadavky
Ak chcete použiť túto rýchlu opravu, musíte mať nainštalovaný balík ISA Server 2000 Service Pack 2 (SP2).
Požiadavka na reštartovanie
Po použití tejto rýchlej opravy je nutné reštartovať počítač.
Informácie o nahradení rýchlej opravy
Táto rýchla oprava nenahrádza žiadne iné rýchle opravy.
Informácie o súboroch
Anglická verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu časové pásmo v nástroji dátum a čas v ovládacom paneli. Date Time Version Size File name ----------------------------------------------------- 09-May-2005 16:15 3.0.1200.418 61,944 Rpcfltr.dll
Stav
Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti "Vzťahuje sa na".Tento problém bol opravený v Internet Security and Acceleration Server 2004 Service Pack 2.
Ďalšie informácie
Ďalšie informácie nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na príslušné číslo článku:
885957 ako nainštalovať ISA Server rýchlych opráv a aktualizáciíĎalšie informácie o pojmoch používaných na popísanie aktualizácií softvéru získate po kliknutí na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:
824684 Popis štandardnej terminológie použitej na popis aktualizácií softvéru od spoločnosti Microsoft