Príznaky
Predstavte si nasledujúcu situáciu. Pomocou nástroja Ktpass (Ktpass.exe) na vytvorenie súboru keytab Kerberos na Microsoft Windows Server 2003 Service Pack 1 (SP1)-založené počítača. Použijete Lightweight Directory Access Protocol (LDAP) cez Security Sockets Layer (SSL) pripojenie nástroja Ktpass nie nastavte heslo konta služby Active Directory. Keď použijete keytab súbory, ktoré boli vytvorené pomocou nástroja Ktpass, predbežné overenie chyby.
Príčina
Tento problém sa vyskytuje problém s nástrojom Ktpass, ktorý je súčasťou systému Windows Server 2003 SP1. Nástroj Ktpass nie hesla správne pomocou LDAP cez SSL.
Nástroj Ktpass soli heslo nesprávne, keď vytvára keytabs počítačové kontá. Nástroj Ktpass použije časť názov atribút servicePrincipalName namiesto samAccountName atribút stredisko distribúcie kľúčov (KDC) voči heslo. Nesprávne vytvorené keytab súbory, ktoré sú vytvorené pomocou nesprávne soli spôsobujú zlyhanie overenia.
Riešenie
Informácie o balíku Service Pack
Ak chcete odstrániť tento problém, Získajte najnovší balík service pack pre systém Windows Server 2003. Ďalšie informácie získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
ako získať najnovší balík service pack pre systém Windows Server 2003
Informácie o rýchlej oprave
Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v počítačoch s týmto konkrétnym problémom. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu.
Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy.
Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na webovej lokalite spoločnosti Microsoft:
Poznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, je preto rýchla oprava nie je pre tento jazyk k dispozícii.
Požiadavky
Počítač musí používať systém Windows Server 2003 SP1 nainštalovať túto rýchlu opravu.
Požiadavka na reštartovanie
Nemáte na reštartovanie počítača po použití tejto rýchlej opravy.
Informácie o nahradení rýchlej opravy
Táto rýchla oprava nenahrádza žiadne iné rýchle opravy.
Informácie o súboroch
Anglická verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu Time Zone (Časové pásmo) v položke Date and Time (Dátum a čas) v ovládacom paneli.