Sign in with Microsoft
New to Microsoft? Create an account.
Uporaba bralnika zaslona za razvrščanje ali filtriranje tabele v Excelu

Ta članek je za osebe z okvarami vida ali kognitivnimi okvarami, ki uporabljajo bralnik zaslona, kot je Pripovedovalec Microsoft, JAWS ali NVDA z izdelki Microsoft 365. Ta članek je del nabora vsebin podpornika bralnika zaslona v storitvi Microsoft 365, kjer lahko poiščete več informacij o pripomočkih za osebe s posebnimi potrebami v naših aplikacijah. Če želite splošno pomoč, obiščite domačo stran Microsoftove podpore ali Popravki ali rešitve za nedavne težave z Officeom.

Uporabite Excel tipkovnico in bralnikom zaslona za razvrščanje in filtriranje tabel. Preskusili smo ga s Pripovedovalcem, bralnikom JAWS in bralnikom NVDA, vendar lahko deluje z drugimi bralniki zaslona, če uporabljajo pogoste standarde in tehnike dostopnosti. Z razvrščanjem podatkov lažje organizirate in poiščete želene podatke in jih hitreje analizirate. S filtriranjem podatkov se osredotočite na določen nabor podatkov, kar je še posebej uporabno na velikih delovnih listih.

Decorative icon potrebujete navodila za razvrščanje ali filtriranje podatkov v Excel, ne pa tudi bralnika zaslona? Glejte Razvrščanje podatkov v tabeli ali Filtriranje podatkov v obsegu ali tabeli.

Opombe: 

V tej temi

Bližnjice na tipkovnici za razvrščanje in filtriranje

V tej tabeli so naveden bližnjice na tipkovnici za razvrščanje in filtriranje.

Dejanje

Tipke

Izklop spustnega menija »Samodejno filtriranje« v naslovu stolpca

Ctrl+Shift+L

Odpiranje spustnega menija za samodejno filtriranje v glavi stolpca

Alt+puščična tipka dol

Razvrščanje od najmanjše do največje vrednosti ali od A do Ž

Alt+A, S, A ali Alt+puščična tipka dol, S

Razvrščanje od največje do najmanjše vrednosti ali od Ž do A

Alt+A, S, D ali Alt+puščična tipka dol, O

Odpiranje pogovornega okna »Razvrščanje«

Alt+A, S, S ali Alt+H, S, U

Ponovna uporaba razvrščanja po spreminjanju podatkov

Ctrl+Alt+L ali Alt+A, Y, 3

Filtriranje po barvi

Alt+puščična tipka dol, I

Filtriranje po številki ali besedilu

Alt+puščična tipka dol, F

Odpiranje pogovornega okna »Oblikovanje celic«

Alt+H, O, I

Uporaba funkcije TRIM

Alt+M, T, nato pa se s puščično tipko dol premaknite do možnosti TRIM

Več informacij o razvrščanju v Excel

Podatke je mogoče razvrstiti po besedilu (od A do Ž ali od Ž do A), številih (od najmanjšega do največjega ali od največjega do najmanjšega), in datumih ali časih (od najbolj oddaljenega do najbližjega ali od najbližjega do najbolj oddaljenega) v enem ali več stolpcih. Podatke je mogoče razvrstiti tudi po seznamu po meri (na primer »Velik«, »Srednji« in »Majhen«) ali po obliki, med drugim barvi celice, barvi pisave ali naboru ikon. Večina postopkov razvrščanja vpliva na stolpce, vendar lahko tudi razvrščate po vrsticah.

Ko razvrščate tabelo, Excel, ki ste jih uporabili v delovnem zvezku, tako da jih lahko znova uporabite vsakič, ko odprete delovni zvezek. To je zlasti pomembno pri razvrščanju več stolpcev ali razvrščanju, ki ga ustvarjate dalj časa. Vendar pa je to mogoče uporabiti le za podatke v tabeli, ne pa zgolj za obseg celic. Če želite shraniti pogoje razvrščanja, tako da lahko znova uporabite razvrščanje vsakič, ko odprete delovni zvezek, priporočamo, da uporabite tabelo.

Opomba: Ko razvrstite podatke, ne morete obnoviti izvirnega vrstnega reda. Če po razvrščanju datoteke še niste shranili, se lahko nazaj razveljavite (Ctrl + Z).

Razvrščanje besedila v tabeli ali v obsegu

Razvrščanje besedila v tabeli

  1. S puščičnimi tipkami se premaknite v vrstico z glavo v tabeli. Ko ste v vrstici z glavo, zaslišite »Header item« (Element glave) za mestom celice.

  2. Pritisnite puščično tipko desno ali levo, da se premaknete v glavo stolpca za podatke, ki jih želite razvrstiti.

  3. Pritisnite Alt+puščična tipka dol, da odprete meni filtra, nato pa pritiskajte tabulatorko, dokler ne zaslišite: »Menu, Sort A to Z, unchecked menu item« (Meni, razvrsti od A do Ž, poči izbrani menijski element).

  4. Prikazane možnosti so odvisne od vrste podatkov v stolpcu. Številske podatke lahko na primer razvrščate od najmanjše do največje vrednosti ali od največje do najmanjše. Alfanumerične podatke lahko razvrstite od A do Ž ali od Ž do A. Razvrščate lahko tudi po barvi.

    S puščično tipko dol prebrskajte možnosti in pritisnite tipko Enter, da izberete možnost. Zaslišite »Sorted« (Razvrščeno) in nato izbrano možnost.

Razvrščanje besedila v obsegu

  1. S puščičnimi tipkami se premaknite v stolpec alfanumeričnih podatkov v obsegu celic ali do stolpca v tabeli, ki vsebuje alfanumerične podatke.

  2. Pritisnite kombinacijo tipk Alt+A. Odpre se zavihek Podatki in s Pripovedovalcem zaslišite: »Ribbon tabs, Selected, Data tab item« (Zavihki traku, izbrano, element zavihka »Podatki«). Če imate bralnik zaslona JAWS, zaslišite: »Zgornji trak, polje 'Skupina', zavihek »Podatki««. Če izberete NVDA, zaslišite: »Ribbon tabs tab control expanded, Data tab selected« (Razširjen kontrolnik zavihkov na traku, izbran zavihek »Podatki«).

  3. Naredite nekaj od tega:

    • Če želite razvrstiti podatke v naraščajočem alfanumeričnem vrstnem redu (Razvrsti od Ado Ž ), pritisnite S in nato A.

    • Če želite razvrstiti podatke v padajočem alfanumeričnem vrstnem redu(Razvrsti od Ždo A ), pritisnite S in nato D.

Razvrščanje z razlikovanjem med velikimi in malimi črkami

  1. S puščičnimi tipkami se premaknite v stolpec alfanumeričnih podatkov v obsegu celic ali do stolpca v tabeli, ki vsebuje alfanumerične podatke.

  2. Pritisnite Alt+H, S, U. Odpre se pogovorno okno Razvrščanje in v Pripovedovalcu zaslišite: »Sort, OK button« (Razvrščanje, gumb »V redu«). Če imate bralnik zaslona JAWS, zaslišite: »Pogovorno okno 'Razvrščanje', gumb 'V redu'«. Če imate bralnik zaslona NVDA, zaslišite: »Sort dialog, Sort window« (pogovorno okno »Razvrščanje«, okno »Razvrščanje«). 

  3. Pritisnite Alt+O, da odprete pogovorno okno Možnosti razvrščanja. Če imate Pripovedovalca, zaslišite: »Možnosti razvrščanja. Unchecked, Case sensitive checkbox« (Nepotrtrjeno, potrditveno polje »Case sensitive«). Če imate bralnik zaslona JAWS, zaslišite: »Sort options dialog, Case sensitive checkbox, not checked« (Pogovorno okno »Možnosti razvrščanja«, potrditveno polje »Case sensitive« (Pogovorno okno »Možnosti razvrščanja«, potrditveno polje »Case sensitive« ni potrjeno). Če imate bralnik zaslona NVDA, zaslišite: »Sort Options dialog orientation, Case sensitive checkbox, not checked« (Usmerjenost pogovornega okna »Možnosti razvrščanja«, potrditveno polje »Case sensitive« (Pogovorno okno »Možnosti razvrščanja«, potrditveno polje »Case sensitive« (Potrditveno polje »Case sensitive« ni potrjeno).

  4. Pritisnite preslednico, da potrdite potrditveno polje Case sensitive (Case sensitive).

  5. Pritisnite tipko Enter. Pogovorno okno Možnosti razvrščanja se zapre in v Pripovedovalcu zaslišite: »Sort, Options button« (Razvrščanje, gumb »Možnosti«). Če imate bralnik zaslona JAWS, zaslišite: »Pogovorno okno 'Razvrščanje'«. Če imate bralnik zaslona NVDA, zaslišite: »Sort dialog, Sort window« (pogovorno okno »Razvrščanje«, okno »Razvrščanje«). 

  6. Če želite zapreti pogovorno okno Razvrsti in uporabiti spremembe, pritiskajte tabulatorko, dokler ne zaslišite »OK button« (gumb »V redu«), nato pa pritisnite tipko Enter.

  7. Razvrstite besedilo, kot je opisano v razvrstiti besedilo v obsegu.

Namig: Če stolpec, v katerem razvrščate podatke, vsebuje števila in besedilo, jih boste morda morali vse oblikovati kot besedilo. Sicer Excel najprej razvrsti števila kot števila in nato razvrsti besedilo. Če želite oblikovati podatke, pritisnite Ctrl+preslednico, da izberete vse podatke v stolpcu, in nato pritisnite Alt+H, F, N. Pritiskajte puščično tipko levo, dokler ne zaslišite »Selected, Number tab item« (Izbrano, element zavihka »Številke«), enkrat pritisnite tabulatorko, nato pa pritiskajte puščično tipko dol, dokler ne zaslišite: »Text« (Besedilo). Enkrat pritisnite tabulatorko, da se premaknete na gumb V redu, nato pritisnite tipko Enter.

Namig: Ko uvažate ali kopirate podatke z druge lokacije, se pred podatke lahko vstavijo začetni presledki. Ime »Ija Irjav« je lahko na primer vneseno kot »(presledek)(presledek)Ija Irjav. Če uporabljate bralnik zaslona, morda presledkov ne opazite, ker bralnik JAWS ne bere presledkov v celicah. Če jih želite poiskati, Excel celice z vodilnimi presledki na vrh razvrščenega stolpca.

Razvrščanje števil

  1. S puščičnimi tipkami se premaknite do stolpca s številskimi podatki v obsegu celic ali do stolpca v tabeli, ki vsebuje številske podatke.

  2. Pritisnite kombinacijo tipk Alt+A. Odpre se zavihek Podatki in v Pripovedovalcu zaslišite: »Ribbon tabs, Selected, Data tab item« (Zavihki traku, izbrano, element zavihka »Podatki«). Če imate bralnik zaslona JAWS, zaslišite: »Zgornji trak, polje 'Skupina', zavihek »Podatki««. Če izberete NVDA, zaslišite: »Ribbon tabs tab control expanded, Data tab selected« (Razširjen kontrolnik zavihkov na traku, izbran zavihek »Podatki«).

  3. Naredite nekaj od tega:

    • Če želite razvrstiti podatke od najmanjšega do največjega, pritisnite S in nato A.

    • Če želite razvrstiti podatke od največjega do najmanjšega, pritisnite S in nato D.

Potrdite, da so števila shranjena kot številke

  1. S puščičnimi tipkami se premaknite do stolpca s številskimi podatki v obsegu celic ali do stolpca tabele, ki vsebuje številske podatke, nato pa pritisnite Ctrl+preslednico, da izberete vse podatke v stolpcu.

  2. Pritisnite Alt+H, F, N. Odpre se pogovorno okno Oblikovanje celic in zaslišite: »Oblikovanje celic«.

  3. Če se želite premakniti na zavihek Številke, uporabite puščično tipko levo (ali pritisnite Ctrl+Tab). V Pripovedovalcu boste slišali »Number tab item« (element zavihka »Številke«). Če imate bralnik zaslona JAWS, zaslišite: »Zavihek 'Številke'.« Če izberete NVDA, zaslišite: »Zavihek 'Številke', izbrano.«

  4. Pritisnite tabulatorko. Odpre se seznam Kategorija in zaslišite trenutno izbrano kategorijo, na primer »General« (Splošno) ali »Date« (Datum).

  5. Pritiskajte puščično tipko gor ali dol, dokler ne zaslišite: »Number« (Številka).

  6. Pritiskajte tabulatorko, dokler ne zaslišite »Decimal places« (Decimalna mesta), temu pa sledi število trenutno uporabljenih decimalnih mest. Če želite spremeniti to vrednost, vnesite novo število decimalnih mest. Če želite v celoti odstraniti decimalke, vnesite 0.

  7. Če želite zapreti pogovorno okno Oblikovanje celic in uporabiti spremembe, pritiskajte tabulatorko, dokler ne zaslišite »OK button« (gumb »V redu«), nato pa pritisnite tipko Enter.

Razvrščanje datumov in časov

  1. S puščičnimi tipkami se lahko pomaknete v stolpec z datumi ali časi v obsegu celic ali v stolpec tabele, ki vsebuje datume ali čase.

  2. Pritisnite kombinacijo tipk Alt+A. Odpre se zavihek Podatki in v Pripovedovalcu zaslišite: »Ribbon tabs, Selected, Data tab« (Zavihki traku, izbrano, zavihek »Podatki«). Če imate bralnik zaslona JAWS, zaslišite: »Zgornji trak, polje 'Skupina', zavihek »Podatki««. Če izberete NVDA, zaslišite: »Ribbon tabs tab control expanded, Data tab selected« (Razširjen kontrolnik zavihkov na traku, izbran zavihek »Podatki«).

  3. Naredite nekaj od tega:

    • Če želite razvrstiti od najstarejšega do najnovejšega, pritisnite S in nato A.

    • Če želite razvrstiti od najnovejšega do najstarejšega, pritisnite S in nato D.

    • Če želite znova uporabiti razvrščanje, potem ko ste spremenili podatke, izberite celico v obsegu ali tabelo in pritisnite kombinacijo tipk Ctrl+Alt+L.

Razvrščanje po več kot enem stolpcu

Morda želite razvrščati po več stolpcih ali vrsticah, če imate podatke, ki jih želite razvrstiti po isti vrednosti v enem stolpcu ali vrstici, in nato razvrstiti drug stolpec ali vrstico znotraj te skupine z enakimi vrednostmi. Če imate na primer stolpca »Oddelek« in »Zaposleni«, lahko podatke najprej razvrstite po stolpcu »Oddelek« (da združite vse zaposlene, ki delajo v istem oddelku), nato pa zaposlene razvrstite po imenu (da razvrstite imena zaposlenih za vsak oddelek po abecednem vrstnem redu). Razvrščate lahko po največ 64 stolpcih.

Opomba: Za najboljši rezultat mora imeti obseg celic za razvrščanje glave stolpcev. Če želite razvrščati po vrsticah, se prepričajte, da je potrditveno polje Moja tabela ima glave počiščeno v pogovornem oknu Razvrsti. Pritisnite Alt+H, S, odpre se pogovorno okno Razvrščanje in pritiskajte tabulatorko, dokler ne zaslišite »Checked, My data has headers checkbox« (Potrjeno, moji podatki imajo glave potrditveno polje) ali »Unchecked, My data has headers checkbox« (Nepotrjeno, Moji podatki imajo glave potrditveno polje). Če želite počistiti potrditveno polje, pritisnite preslednico, pritiskajte tabulatorko, dokler ne zaslišite »OK, button« (V redu, gumb), in pritisnite tipko Enter, da uporabite spremembo.

  1. S puščičnimi tipkami se premaknite v obseg celic z dvema ali več stolpci podatkov ali v tabelo z dvema ali več stolpci.

  2. Pritisnite Alt+A, S, S. Odpre se pogovorno okno Razvrščanje in v Pripovedovalcu zaslišite: »Sort, OK button« (Razvrščanje, gumb »V redu«). Če imate bralnik zaslona JAWS, zaslišite: »Pogovorno okno 'Razvrščanje', gumb 'V redu'«. Če imate bralnik zaslona NVDA, zaslišite: »Sort dialog, Sort window« (pogovorno okno »Razvrščanje«, okno »Razvrščanje«). 

  3. Pritiskajte tabulatorko, dokler ne najdete kombiniranega polja Stolpec: Razvrsti po. Zaslišite »Sort by« (Razvrsti po), nato pa še ime stolpca in nato »editable combo box« (kombinirano polje, ki ga je mogoče urejati). S puščičnima tipkama gor in dol izberite prvi stolpec, ki ga želite razvrstiti.

  4. Pritiskajte tabulatorko, dokler ne najdete kombiniranega polja Razvrsti v. Zaslišite: »Sort on, Cell Values, editable combo box« (Razvrsti po, Vrednosti celic, kombinirano polje, ki ga je mogoče urejati). Če ne slišite »Cell Values« (Vrednosti celic), pritiskajte puščični tipki gor in dol, dokler ne slišite tega.

  5. Če želite izbrati način razvrščanja vrednosti celic, pritiskajte tabulatorko, dokler ne najdete kombiniranega polja Vrstni red. Zaslišite »Order« (Vrstni red), temu pa bo sledila trenutno izbrana možnost, nato pa »editable combo box« (kombinirano polje, ki ga je mogoče urejati). S puščičnima tipkama gor in dol izberite od A do Ž,od Ž do A,od najmanjšega do največjega ali od največjega do najmanjšega.

  6. Če želite dodati še en stolpec za razvrščanje, se s tabulatorko premaknite do gumba Dodaj raven, pritisnite tipko Enter, nato pa ponovite korake od tri do pet.

    Opomba: Kombinirano polje Razvrsti po se imenuje Nato po za dodatne stolpce.

  7. Če želite znova uporabiti razvrščanje stolpca, potem ko ste spremenili podatke, izberite celico v obsegu ali tabelo in pritisnite kombinacijo tipk Ctrl+Alt+L.

    Opomba: S kombinacijo tipk Ctrl+Alt+L razvrščanja ne uporabite znova.

Namigi za težave z razvrščanjem

Če pri razvrščanju podatkov dobite nepričakovane rezultate:

  • Preverite, ali so se spremenile vrednosti, ki jih vrne formula. Če razvrščeni podatki vsebujejo eno ali več formul, se lahko vrnjene vrednosti teh formul spremenijo, ko je delovni list znova izračunan. V takem primeru znova uporabite razvrščanje, da dobite najnovejše rezultate.

  • Pred razvrščanjem razkrijte vrstice in stolpce. Skriti stolpci ne bodo premaknjeni pri razvrščanju stolpcev, skrite vrstice pa ne bodo premaknjene, ko razvrščate vrstice. Priporočamo vam, da pred razvrščanjem podatkov razkrijete skrite stolpce in vrstice.

  • Preverite območne nastavitve. Vrstni red razvrščanja je odvisen od območnih nastavitev. Prepričajte se, da so v območnih nastavitvah na Nastavitve območne in jezikovne možnosti na nadzorni plošči.

  • Vklopite ali izklopite vrstico z glavo. Običajno je najbolje, da imate vrstico z glavo, ko razvrščate stolpec, saj tako lažje razumete pomen podatkov. Vrednost v glavi privzeto ni vključena v razvrščanje. Občasno boste morda morali vklopiti ali izklopiti glavo, tako da vrednost v naslovu bo ali ne bo vključena v razvrščanje.

  • Če želite iz razvrščanja izključiti prvo vrstico s podatki, ker gre za glavo stolpca, pritisnite Alt+H, S, U. V pogovornem oknu Razvrščanje po meri potrdite polje Moji podatki imajo glave.

  • Če želite v razvrščanje vključiti prvo vrstico s podatki, ker ni glava stolpca, pritisnite Alt+H, S, U. V pogovornem oknu Razvrščanje po meri počistite potrditveno polje Moji podatki imajo glave.

Filtriranje podatkov v tabeli

Ko dodate podatke v tabelo, Excel samodejno doda spustni meni Samodejno filtriranje v vsako glavo stolpca. Ta meni lahko uporabite za hitro filtriranje. Če želite spustni meni Samodejno filtriranje odstraniti iz glave stolpca, izberite glavo in nato pritisnite Ctrl+Shift+L.

  1. V glavi tabele stolpca, ki ga želite filtrirati, pritisnite Alt+puščična tipka dol. Odpre se spustni meni Samodejno filtriranje in v Pripovedovalcu boste slišali: »Menu« (Meni). Če imate bralnik zaslona JAWS, zaslišite: »Priročni meni.« Če imate bralnik zaslona NVDA, zaslišite: »Unknown« (Neznano).

  2. Če so v meniju Samodejni filter številke, se s puščično tipko dol premaknite do možnosti Filtri za številke in pritisnite tipko Enter. Če so v stolpcu besedilni vnosi, se s puščično tipko dol premaknite do možnosti Filtri za besedilo in pritisnite tipko Enter. Odpre se podmeni in zaslišite: »Equals« (Je enako).

  3. Do želene možnosti filtriranja se lahko premaknete s puščičnimi tipkami, nato pa pritisnite tipko Enter. Odpre se pogovorno okno Samodejno filtriranje po meri in zaslišite: »Custom AutoFilter« (Samodejno filtriranje).

  4. Vnesite ali izberite pogoje filtriranja.

    Če želite na primer prikazati številke nad določenim zneskom, izberite Večje ali enako innato v kombinirano polje vnesite številko, ki jo imate v mislih.

    Če želite filtrirati z dvema pogojema, vnesite pogoje filtriranja v oba nabora kombiniranih polj za urejanje. Če želite, da bosta oba pogoja resnična, pritisnite Shift+A, da izberete pogoj And. Če želite, da bo kateri koli od pogojev resničen, pritisnite Shift+O, da izberete pogoj Or.

  5. Če želite zapreti pogovorno okno, pritiskajte tabulatorko, dokler ne zaslišite »OK button« (gumb »V redu«), nato pa pritisnite tipko Enter.

Filtriranje podatkov v obsegu

  1. Izberite celice, ki jih želite filtrirati. Premaknite se do celice, v kateri želite biti zgornja leva celica izbora, nato pa pridržite tipko Shift in s puščičnima tipkama desno in dol razširite izbrani obseg celic.

  2. Pritisnite Ctrl+Shift+L. Excel doda spustni meni Samodejno filtriranje v prvo celico vsakega stolpca v obsegu.

  3. V glavi tabele stolpca, ki ga želite filtrirati, pritisnite Alt+puščična tipka dol. Odpre se spustni meni Samodejno filtriranje in v Pripovedovalcu boste slišali: »Menu« (Meni). Če imate bralnik zaslona JAWS, zaslišite: »Priročni meni.« Če imate bralnik zaslona NVDA, zaslišite: »Unknown« (Neznano).

  4. Do želenih možnosti filtriranja se lahko premaknete s puščičnimi tipkami in tabulatorko. Uporabite preslednico, če želite počistiti ali izbrati potrditveno polje vrednosti filtra.

  5. Ko izberete, pritisnite tipko Enter, da uporabite filter.

Če želite počistiti filter in odstraniti spustne menije Samodejno filtriranje, izberite katero koli celico v obsegu in pritisnite Ctrl+Shift+L.

Glejte tudi

Uporaba bralnika zaslona za ustvarjanje naslova tabele v Excelu

Uporaba bralnika zaslona za dodajanje pripomb na Excelov delovni list

Uporaba bralnika zaslona za ustvarjanje glav stolpcev v tabeli v Excelu

Bližnjice na tipkovnici za Excel

Osnovna opravila z bralnikom zaslona v Excelu

Nastavitev naprave za delo s pripomočki za osebe s posebnimi potrebami v Microsoft 365

Uporaba bralnika zaslona za raziskovanje in pomikanje po Excelu

Novosti v okolju Microsoft 365

V programu Excel za Android lahko z orodjem TalkBack, vgrajenim bralnikom zaslona v sistemu Android, razvrščate in filtrirate tabele. Razvrščanje je koristno za organizacijo in analizo podatkov. Filtriranje podatkov je zlasti uporabno, če delovni listi vsebujejo velike količine podatkov.

Opombe: 

  • Nove funkcije storitve Microsoft 365 se za naročnike na Microsoft 365 izdajajo postopoma, zato vaša aplikacija teh funkcij morda še ne vključuje. Če želite izvedeti, kako lahko nove funkcije dobite hitreje, se pridružite programu Office Insider.

  • V tej temi je predvideno, da uporabljate bralnik zaslona TalkBack, ki je vgrajen v sistem Android. Več informacij o uporabi bralnika zaslona TalkBack najdete v članku Dostopnost v sistemu Android.

V tej temi

Razvrščanje podatkov v Excel

Na delovnem listu programa Excel lahko razvrstite besedilne in številske podatke, da jih razporedite v določenem vrstnem redu, na primer od A do Ž ali od Ž do A, številke od najmanjše do največje ali od največje do najmanjše, ter datume in čase od starejših do novejših ali od novejših do starejših.

Opomba: Ko razvrstite podatke, ne morete obnoviti izvirnega vrstnega reda.

  1. Tapnite kjer Excel list. Bralnik zaslona TalkBack napove izbrano celico.

  2. Podrsnite levo ali desno, da se pomaknete v stolpec, ki ga želite razvrstiti. Dvotapnite zaslon, da aktivirate izbor.

  3. Povlecite en prst blizu vrha zaslona, da zaslišite »More options, button« (gumb »Več možnosti«), in nato dvotapnite zaslon. Zaslišite »Meni zavihka«, temu pa sledi trenutno izbrani zavihek, na primer »Home, selected« (Osnovno, izbrano).

  4. Če niste na zavihku Osnovno, dvotapnite zaslon. Odpre se meni z zavihki. Podrsnite desno ali levo, da zaslišite »Zavihek 'Osnovno'« in dvotapnite zaslon.

  5. Na spodnjem delu zaslona z dvema prstoma večkrat podrsnite navzgor, dokler ne dosežete konca seznama. Bralnik zaslona TalkBack med podrsavanjem predvaja zvok, in utihne, ko dosežete konec seznama.

  6. Raziščite seznam, tako da z enim prstom povlečete na spodnjem delu zaslona, dokler ne zaslišite »Sort and Filter menu« (meni Razvrščanje in filtriranje), in nato dvotapnite zaslon.

  7. Naredite nekaj od tega:

    • Če želite alfanumerične podatke razvrstiti od A do Ž ali od najmanjšega do največjega ali če želite datume in čase razvrstiti od starejših do novejših, podrsnite desno, da zaslišite »Sort Ascending, switch« (Razvrsti naraščajoče, preklopni gumb), in nato dvotapnite zaslon.

    • Če želite alfanumerične podatke razvrstiti od Ž do A ali od največjega do najmanjšega, ali če želite datume in čase razvrstiti od novejših do starejših, podrsnite desno, da zaslišite »Sort Descending, switch« (Razvrsti padajoče, preklopni gumb), in nato dvotapnite zaslon.

  8. Če se želite vrniti na delovni list, podrsnite desno, da zaslišite »On, more options switch« (Vklopljeno, stikalo za več možnosti), in nato dvotapnite zaslon.

Razvrščanje obsega celic

Če v delovnem zvezku obstajajo prazne celice, lahko najprej izberete obseg in ga nato razvrstite.

  1. Povlecite en prst blizu vrha zaslona, da zaslišite »More options, button« (gumb »Več možnosti«), in nato dvotapnite zaslon. Zaslišite »Meni zavihka«, temu pa sledi trenutno izbrani zavihek, na primer »Home, selected« (Osnovno, izbrano).

  2. Če niste na zavihku Osnovno, dvotapnite zaslon. Odpre se meni z zavihki. Podrsnite desno ali levo, da zaslišite »Zavihek 'Osnovno'« in dvotapnite zaslon.

  3. Na spodnjem delu zaslona z dvema prstoma večkrat podrsnite navzgor, dokler ne dosežete konca seznama. Bralnik zaslona TalkBack med podrsavanjem predvaja zvok, in utihne, ko dosežete konec seznama.

  4. Raziščite seznam, tako da z enim prstom povlečete na spodnjem delu zaslona, dokler ne zaslišite »Izberite obseg«, nato dvotapnite zaslon.

  5. Odpre se pogovorno okno Izbira celice ali obsega in fokus je v polju obsega. Z zaslonsko tipkovnico vnesite obseg, ki ga želite izbrati, na primer A1:C15. Povlecite prst po spodnjem desnem kotu zaslona, da zaslišite »Done« (Dokončano), in dvotapnite zaslon. Obseg je zdaj izbran.

  6. Povlecite en prst blizu vrha zaslona, da zaslišite »More options, button« (gumb »Več možnosti«), in nato dvotapnite zaslon.

  7. Na spodnjem delu zaslona z dvema prstoma večkrat podrsnite navzgor, dokler ne dosežete konca seznama. Bralnik zaslona TalkBack med podrsavanjem predvaja zvok, in utihne, ko dosežete konec seznama.

  8. Raziščite seznam, tako da z enim prstom povlečete na spodnjem delu zaslona, dokler ne zaslišite »Sort and Filter menu« (meni Razvrščanje in filtriranje), in nato dvotapnite zaslon.

  9. Naredite nekaj od tega:

    • Če želite alfanumerične podatke razvrstiti od A do Ž ali od najmanjšega do največjega ali če želite datume in čase razvrstiti od starejših do novejših, podrsnite desno, da zaslišite »Sort Ascending, switch« (Razvrsti naraščajoče, preklopni gumb), in nato dvotapnite zaslon.

    • Če želite alfanumerične podatke razvrstiti od Ž do A ali od največjega do najmanjšega, ali če želite datume in čase razvrstiti od novejših do starejših, podrsnite desno, da zaslišite »Sort Descending, switch« (Razvrsti padajoče, preklopni gumb), in nato dvotapnite zaslon.

Oblikovanje podatkov

Včasih boste morali podatke preoblikovati, da dobite najboljše rezultate pri razvrščanju.

  1. Pomaknite se na celico ali stolpec, ki ga želite oblikovati. Dvotapnite zaslon, da aktivirate izbor.

  2. Povlecite en prst blizu vrha zaslona, da zaslišite »More options, button« (gumb »Več možnosti«), in nato dvotapnite zaslon. Zaslišite »Meni zavihka«, temu pa sledi trenutno izbrani zavihek, na primer »Home, selected« (Osnovno, izbrano).

  3. Če niste na zavihku Osnovno, dvotapnite zaslon. Odpre se meni z zavihki. Podrsnite desno ali levo, da zaslišite »Zavihek 'Osnovno'« in dvotapnite zaslon.

  4. Na spodnjem delu zaslona z dvema prstoma večkrat podrsnite navzgor, dokler ne dosežete konca seznama. Bralnik zaslona TalkBack med podrsavanjem predvaja zvok, in utihne, ko dosežete konec seznama.

  5. Podrsnite levo, da zaslišite »Meni 'Oblika zapisa števil'« in dvotapnite zaslon.

  6. Podrsnite desno, da zaslišite obliko zapisa, ki jo potrebujete, nato pa dvotapnite zaslon.

    Izbirate lahko med temi oblikami zapisa: Splošno, Številka, Valuta, Računovodsko, Datum, Ura, Odstotek, Ulomek, Znanstveno, Besedilo in Posebno.

Namigi za odpravljanje težav pri razvrščanju

Če pri razvrščanju podatkov dobite nepričakovane rezultate, preverite to:

  • Če razvrščeni podatki vsebujejo eno ali več formul, se lahko vrnjene vrednosti teh formul spremenijo, ko je delovni list znova izračunan. V takem primeru jih znova razvrstite, da dobite najnovejše rezultate.

  • Skriti stolpci ne bodo premaknjeni pri razvrščanju stolpcev, skrite vrstice pa ne bodo premaknjene, ko razvrščate vrstice. Priporočamo vam, da pred razvrščanjem podatkov razkrijete skrite stolpce in vrstice. Če ga želite Excel zvezku:

    1. Premaknite se v vrstico ali stolpec ob skritem stolpcu ali vrstici. TalkBack napove: »Adjacent to hidden cells« (Sosednje skritim celicam).

    2. Povlecite prst do glave stolpca ali levo do številke vrstice, nato pa dvotapnite zaslon, da izberete celoten stolpec ali vrstico. Odpre se priročni meni.

    3. Podrsnite desno, da zaslišite »Unhide, button« (gumb »Znova se prikaže«), in nato dvotapnite zaslon.

  • Preverite območne nastavitve v telefonu. Razvrščanje rezultatov se lahko razlikuje glede na območne nastavitve.

Filtriranje podatkov v tabeli

  1. V Excel, podrsajte s prstom po zaslonu, dokler ne zaslišite »Vnos tabele«, čemur sledijo podrobnosti tabele in celice.

  2. Podrsnite levo ali desno, da se pomaknete do stolpca, ki ga želite filtrirati, nato pa dvotapnite zaslon.

    Namig: Če slišite »Gumb 'Izreži'«, podrsnite navzdol in levo, da zaprete priročni meni. 

  3. Povlecite prst po spodnjem delu zaslona v opravilni vrstici, dokler ne zaslišite »Filter options button« (gumb Možnosti filtra), in dvotapnite zaslon.

  4. Odpre se meni Razvrščanje in filtriranje. Podrsnite desno, da zaslišite »Filter items button« (gumb »Filtriranje elementov«), in nato dvotapnite zaslon. Fokus je v polju Iskanje. Dvotapnite zaslon, da aktivirate polje Iskanje in prikažete tipkovnico.

  5. Vnesite pogoje za filtriranje.

  6. Ko držite prst na zgornjem delu zaslona, dokler ne zaslišite »Select All Results, button« (gumb »Izberi vse rezultate«), in naredite nekaj od tega:

    • Če želite izbrati vse rezultate iskanja, dvotapnite zaslon.

    • Če želite brskati po rezultatih iskanja, podrsnite desno, dokler ne zaslišite rezultata, ki ga želite, nato pa dvotapnite zaslon. Izberete lahko več rezultatov iskanja.

  7. Povlecite en prst v zgornjem desnem kotu zaslona, da zaslišite »Gumb 'Dokončano'« in dvotapnite zaslon.

    Meni Razvrščanje in filtriranje se zapre in vrnete se v tabelo z izbranimi pogoji filtra.

Glejte tudi

Uporaba bralnika zaslona za vstavljanje tabele na Excelov delovni list

Bližnjice na tipkovnici za Excel

Osnovna opravila z bralnikom zaslona v Excelu

Nastavitev naprave za delo s pripomočki za osebe s posebnimi potrebami v Microsoft 365

Uporaba bralnika zaslona za raziskovanje in pomikanje po Excelu

Novosti v okolju Microsoft 365

Uporabite Excel za splet tipkovnico in bralnikom zaslona za postavitev, razvrščanje in filtriranje podatkov v tabeli. S Pripovedovalcem smo ga preskusili v sistemih Microsoft Edge in JAWS in NVDA v brskalniku Chrome, vendar bo morda deloval z drugimi bralniki zaslona in spletnimi brskalniki, če uporabljajo pogoste standarde in tehnike dostopnosti. S filtriranjem podatkov se osredotočite na določen nabor podatkov, kar je še posebej uporabno na velikih delovnih listih.

Decorative icon potrebujete navodila za filtriranje podatkov v aplikaciji Excel, ne pa tudi bralnika zaslona? Glejte Filtriranje podatkov v obsegu ali tabeli.

Opombe: 

  • Nove funkcije storitve Microsoft 365 se za naročnike na Microsoft 365 izdajajo postopoma, zato vaša aplikacija teh funkcij morda še ne vključuje. Če želite izvedeti, kako lahko nove funkcije dobite hitreje, se pridružite programu Office Insider.

  • Če želite izvedeti več o bralnikih zaslona, preberite članek Delovanje bralnikov zaslona v Microsoft Officeu.

  • Če uporabljate Excel za splet, vam priporočamo, da za Microsoft Edge brskalnik uporabite te spletne brskalnike. Ker Excel za splet v spletnem brskalniku, so bližnjice na tipkovnici drugačne od bližnjic v namiznem programu. Za pomikanje med ukazi na primer uporabite tipki Ctrl+F6 namesto F6. Poleg tega veljajo pogoste bližnjice, kot sta F1 (Pomoč) in Ctrl + O (Odpri), za spletni brskalnik, ne pa Excel za splet.

V tej temi

Vstavljanje podatkov v tabelo

  1. Izberite podatke, ki jih želite filtrirati.

  2. Pritisnite Ctrl+L, da odprete pogovorno okno Ustvarjanje tabele. Zaslišite: »Create table« (Ustvari tabelo).

  3. Če v tabeli ni glav, pritisnite tipko Enter, ko odprete pogovorno okno Ustvarjanje tabele. 

    Namig: Če v tabeli ni glav, jih Excel za splet tako, da besedilo označb mesta vstavite v prvo vrstico. Privzeto besedilo označb mesta je Stolpec 1, Stolpec 2, Stolpec 3 itd. Ime besedila glave spremenite tako, da ga kliknete in vnesete ime, ki ga želite.

  4. Če so v tabeli glave, pritiskajte tabulatorko, dokler ne zaslišite: »Unchecked my table has headers checkbox« (Poči prikazano potrditveno polje Moja tabela ima glave). Pritisnite preslednico, da potrdite potrditveno polje, nato pa pritisnite Enter.

Razvrščanje besedila v tabeli

  1. S puščičnimi tipkami se premaknite v vrstico z glavo v tabeli. Ko ste v vrstici z glavo, zaslišite »Header item« (Element glave) za mestom celice.

  2. Pritisnite puščično tipko desno ali levo, da se premaknete v glavo stolpca za podatke, ki jih želite razvrstiti.

  3. Pritisnite Alt+puščična tipka dol, da odprete meni filtra, nato pa pritiskajte tabulatorko, dokler ne zaslišite: »Menu, Sort A to Z, unchecked menu item« (Meni, razvrsti od A do Ž, poči izbrani menijski element).

  4. Prikazane možnosti so odvisne od vrste podatkov v stolpcu. Številske podatke lahko na primer razvrščate od najmanjše do največje vrednosti ali od največje do najmanjše. Alfanumerične podatke lahko razvrstite od A do Ž ali od Ž do A. Razvrščate lahko tudi po barvi. S puščično tipko dol prebrskajte možnosti in pritisnite tipko Enter, da izberete možnost. Zaslišite »Sorted« (Razvrščeno) in nato izbrano možnost.

Razvrščanje besedila v obsegu

  1. S puščičnimi tipkami se premaknite v stolpec alfanumeričnih podatkov v obsegu celic ali do stolpca v tabeli, ki vsebuje alfanumerične podatke.

  2. Pritisnite Alt+Windows tipko z logotipom, A. Odpre se zavihek Podatki in s Pripovedovalcem zaslišite: »Ribbon tabs, Selected, Data tab item« (Zavihki traku, izbrano, element zavihka »Podatki«). Če imate bralnik zaslona JAWS, zaslišite: »Zgornji trak, polje 'Skupina', zavihek »Podatki««. Če izberete NVDA, zaslišite: »Ribbon tabs tab control expanded, Data tab selected« (Razširjen kontrolnik zavihkov na traku, izbran zavihek »Podatki«).

  3. Naredite nekaj od tega:

    • Če želite razvrstiti podatke v naraščajočem alfanumeričnem vrstnem redu (Razvrsti od Ado Ž ), pritisnite S in nato A.

    • Če želite razvrstiti podatke v padajočem alfanumeričnem vrstnem redu(Razvrsti od Ždo A ), pritisnite S in nato D.

Filtriranje podatkov v tabeli

  1. Izberite celico glave v stolpcu, ki ga želite filtrirati.

  2. Pritisnite Alt+puščična tipka dol, da odprete spustni meni Filtriranje in razvrščanje.

  3. Pritiskajte puščično tipko dol, dokler ne zaslišite »Text Filters« (Filtri za besedilo) ali »Number Filters« (Filtri za številke), nato pa pritisnite tipko Enter za dostop do podmenija. Če je v stolpcu le besedilo ali kombinacija besedila in številk, zaslišite »Text Filters« (Filtri za besedilo). Če so v stolpcu le številke, zaslišite »Number Filters« (Filtri za številke).

  4. V podmeniju pritiskajte puščično tipko dol, dokler ne zaslišite imena filtra, ki ga želite uporabiti za podatke, nato pritisnite tipko Enter. Za vsako možnost filtra se odpre pogovorno okno Filter po meri. Ko se odpre pogovorno okno, zaslišite »Dialog custom filter focus on editing« (Pogovorno okno Filter po meri, fokus na urejanju), in ko je dejanje dokončano, zaslišite: »Filter applied« (Filter je uporabljen).

    S tabulatorko se lahko premikate med polji v pogovornem oknu Filter po meri, vključno z izbirnimi gumbi And/Or.

  5. Uporabljeni filter odstranite tako, da najprej izberete celico glave v stolpcu, ki ga želite ponastaviti. Če na primer izberete celico A1, pritisnite Alt+puščična tipka dol, da razširite spustni meni, nato pa pritiskajte puščično tipko dol, dokler ne zaslišite: »Clear filter from Column 1« (Počisti filter iz stolpca 1). Pritisnite tipko Enter, da izberete to. Ko je dejanje dokončano, zaslišite: »No filter applied« (Ni uporabljen filter). Če ste besedilo v glavi celice A1 preimenovali, boste namesto imena »Column 1« (Stolpec 1) slišali ime glave.

Filtriranje podatkov v obsegu

  1. Izberite celice, ki jih želite filtrirati. Premaknite se do celice, v kateri želite biti zgornja leva celica izbora, nato pa pridržite tipko Shift in s puščičnima tipkama desno in dol razširite izbrani obseg celic.

  2. Pritisnite Ctrl+Shift+L. Excel doda spustni meni Samodejno filtriranje v prvo celico vsakega stolpca v obsegu.

  3. Izberite celico s spustnega menija Samodejno filtriranje. Pritisnite Alt+puščična tipka dol. Odpre se spustni meni Samodejno filtriranje in v Pripovedovalcu zaslišite: »Menu« (Meni). Če imate bralnik zaslona JAWS, zaslišite: »Priročni meni.« Če imate bralnik zaslona NVDA, zaslišite: »Unknown« (Neznano).

  4. Do želenih možnosti filtriranja se lahko premaknete s puščičnimi tipkami in tabulatorko. Uporabite preslednico, če želite počistiti ali izbrati potrditveno polje vrednosti filtra.

  5. Ko izberete, pritisnite tipko Enter, da uporabite filter.

  6. Če želite počistiti filter in odstraniti spustne menije Samodejno filtriranje, izberite katero koli celico v obsegu in pritisnite Ctrl+Shift+L.

Možnosti filtra za tabele

Možnosti filtrov za številke

  • Je enako – Filtrira stolpec tako, da prikaže številko, ki jo vnesete v pogovornem oknu Filter po meri.

  • Ni enako – Filtrira stolpec tako, da prikaže vse številke razen tiste, ki jo vnesete v pogovornem oknu Filter po meri.  

  • Večje kot – Filtrira stolpec tako, da prikaže vse številke, ki so večje od številke, vnesene v pogovornem oknu Filter po meri.  

  • Manjše kot – Filtrira stolpec tako, da prikaže vse številke, ki so manjše od številke, vnesene v pogovornem oknu Filter po meri

  • Med – Filtrira stolpec tako, da prikaže vse številke v določenem številskem obsegu. Obseg vnesite v polji, ki sta na voljo v pogovornem oknu Filter po meri

  • Prvih 10 – Filtrira stolpec tako, da prikaže številke z najvišjimi ali najnižjimi številskimi vrednostmi ali odstotki. Ko se odpre pogovorno okno, zaslišite ime aktivne celice in »Focus on editing 10« (Fokus na urejanju 10). V pogovornem oknu je privzeta možnost prvih 10 številk (imenovanih elementi), vendar lahko to vrednost poljubno spremenite. Če želite namesto številk filtrirati odstotke, pritiskajte tabulatorko, dokler ne zaslišite »Items« (Elementi), nato pa pritisnite Alt + puščično tipko dol. Pritiskajte puščično tipko dol, dokler ne zaslišite »Percentage« (Odstotek), nato pa pritisnite Enter. Če želite filtrirati spodnja števila ali odstotke, pritiskajte tabulatorko, dokler ne zaslišite: »Top editable combo box« (Kombinirano polje za urejanje na vrhu). Pritisnite Alt+puščična tipka dol. Nato pritisnite puščično tipko dol, da izberete »Spodaj«, nato pa pritisnite Tipko Enter.

  • Nad povprečjem – Filtrira stolpec tako, da prikaže števila, ki so nad povprečno vrednostjo vseh števil v stolpcu.

  • Pod povprečjem – Filtrira stolpec tako, da prikaže števila, ki so pod povprečno vrednostjo vseh števil v stolpcu.

  • Filter po meri – S to možnostjo lahko v spustnem meniju izberete filter, ki ga želite uporabiti za svoje številske podatke. Če želite uporabiti to možnost, v pogovorno okno najprej vnesite število, ki ga želite filtrirati. Nato pritiskajte tabulatorko, dokler ne zaslišite: »Editable combo box« (Kombinirano polje za urejanje). Pritisnite Alt+puščična tipka dol, da prikažete spustni meni. S puščično tipko dol izberite želeni filter in pritisnite tipko Enter. Ko je dejanje dokončano, zaslišite: »Filter applied« (Filter je uporabljen).

Možnosti filtrov za besedilo

  • Je enako – Filtrira stolpec tako, da prikaže besedilo, ki ga vnesete v pogovornem oknu Filter po meri.

  • Ni enako – Filtrira stolpec tako, da prikaže vse razen besedila, ki ga vnesete v pogovornem oknu Filter po meri.

  • Se začne z – Filtrira stolpec tako, da prikaže podatke, ki se začnejo z besedilom, ki ga vnesete v pogovornem oknu Filter po meri. Besedilo ima lahko poljuben konec.

  • Se konča z – Filtrira stolpec tako, da prikaže podatke, ki se končajo z besedilom, ki ga vnesete v pogovornem oknu Filter po meri. Besedilo ima lahko poljuben začetek.

  • Vsebuje – Filtrira stolpec tako, da prikaže podatke z besedilom, ki ga vnesete v pogovornem oknu Filter po meri.

  • Ne vsebuje – Filtrira stolpec tako, da prikaže podatke brez besedila, ki ga vnesete v pogovornem oknu Filter po meri.

  • Filter po meri – V spustnem meniju lahko izberete filter, ki ga želite uporabiti za svoje podatke. Če želite uporabiti to možnost, najprej vnesite besedilo, ki ga želite filtrirati. Nato pritiskajte tabulatorko, dokler ne zaslišite: »Editable combo box« (Kombinirano polje za urejanje). Pritisnite Alt+puščična tipka dol, da prikažete spustni meni. S puščično tipko dol izberite želeni filter in pritisnite tipko Enter. Ko je dejanje dokončano, zaslišite: »Filter applied« (Filter je uporabljen).

Glejte tudi

Uporaba bralnika zaslona za vstavljanje tabele na Excelov delovni list

Uporaba bralnika zaslona za ustvarjanje in izbiranje grafikona v Excelu

Uporaba bralnika zaslona za dodajanje pripomb na Excelov delovni list

Uporaba bralnika zaslona za iskanje in zamenjavo podatkov v Excelu

Bližnjice na tipkovnici za Excel

Osnovna opravila pri uporabi bralnika zaslona v Excelu

Uporaba bralnika zaslona za raziskovanje in pomikanje po Excelu

Tehnična podpora za stranke s posebnimi potrebami

Microsoft želi omogočiti najboljšo možno izkušnjo za vse svoje stranke. Če ste oseba s posebnimi potrebami ali imate vprašanja v zvezi s pripomočki za osebe s posebnimi potrebami, za tehnično pomoč obiščite spletno mesto Microsoft posebnimi potrebami. Skupina za podporo na spletnem mestu Disability Answer Desk je usposobljena za uporabo številnih programov za pomoč uporabnikom s posebnimi potrebami in vam lahko ponudi pomoč v angleškem, španskem, francoskem in ameriškem znakovnem jeziku. Če želite poiskati podatke za stik za svojo regijo, obiščite spletno mesto »Microsoft Disability Answer Desk«.

Če ste vladna ustanova, komercialni uporabnik ali uporabnik v podjetju, se obrnite na Disability Answer Desk za podjetja.

Ali potrebujete dodatno pomoč?

Pridružite se razpravi
Vprašajte skupnost
Dobite podporo
Stik z nami

Vam je bila informacija v pomoč?

Kako ste zadovoljni s kakovostjo jezika?
Kaj je vplivalo na vašo izkušnjo?

Zahvaljujemo se vam za povratne informacije.

×