Logga in med Microsoft
Logga in eller skapa ett konto.
Hej,
Välj ett annat konto.
Du har flera konton
Välj det konto som du vill logga in med.

I Excel finns en mängd olika metoder för att ta reda på medelvärdet för en uppsättning siffror. Du kan till exempel använda funktion för ett beräkna ett enkelt medelvärde, ett viktat medelvärde eller ett medelvärde som undantar specifika värden.

Använd medföljande exempeldata och följande procedurer för att lära dig hur du räknar ut medelvärden.

Kopiera exempeldata

För att bättre förstå stegen kopierar du följande exempeldata till cell A1 i ett tomt blad.

  1. Skapa en tom arbetsbok eller ett tomt blad.

  2. Markera följande exempeldata.

    Obs!: Markera inte rad- eller kolumnrubrikerna (1, 2, 3...  A, B, C...) när du kopierar exempeldata till ett tomt blad.

    Markera exempeldata i Hjälp

    Markera exempeldata

    Enhetskvalitet

    Pris per enhet

    Antal beställda enheter

    10

    35

    500

    7

    25

    750

    9

    30

    200

    10

    40

    300

    8

    27

    400

    5

    20

    200

    Genomsnittlig enhetskvalitet

    Genomsnittspris per enhet

    Genomsnittlig kvalitet för alla enheter med värden över 5

  3. Tryck på Kommandoknappen på macOS.+ C.

  4. I bladet markerar du cell A1 och trycker sedan på Kommandoknappen på macOS.+ V.

Beräkna enkelt medelvärde

  1. Markera celler A2 till A7 (värdena i kolumnen Enhetskvalitet).

  2. Klicka på pilen bredvid Autosumma Knappen Autosummapå fliken Formler och klicka sedan på Medel.

    Resultatet är 8,166666667.

Beräkna medelvärdet för icke angränsande celler

  1. Markera den cell där du vill att genomsnittet ska visas, som cell A8, som är cellen till vänster om cellen som innehåller texten ”Genomsnittlig enhetskvalitet” i dessa exempeldata.

  2. Klicka på pilen bredvid Autosumma Knappen Autosummapå fliken Formler, klicka på Medel och tryck sedan på RETUR.

  3. Klicka på cellen som innehåller medelvärdet du just skapade, i det här exemplet cell A8.

    Formeln visas i formelfältet, =MEDEL(A2:A7) om du använder exempeldata.

  4. Välj innehållet mellan parenteserna i formelfältet, vilket är A2:A7 om du använder exempeldata.

  5. Håll ned Kommandoknappen på macOS. och klicka på de celler som du vill beräkna medelvärde för och tryck sedan på RETUR. Markera till exempel A2, A4 och A7 och tryck sdan på RETUR.

    Excel ersätter den markerade områdesreferensen i funktionen MEDEL med cellreferenser för de celler du markerade. I det här exemplet är resultatet 8.

Beräkna ett viktat medelvärde

I det här exemplet beräknas det genomsnittliga priset för en enhet över alla beställningar, där varje beställning är för olika antal enheter till olika pris per enhet.

  1. Markera cell A9, som är cellen till vänster om cellen som innehåller texten ”Genomsnittligt pris per enhet”.

  2. På fliken Formler klickar du på Infoga funktion för att öppna fönstret Formelverktyg.

  3. I listan Formelverktyg går du ned och dubbelklickar på PRODUKTSUMMA.

    Tips: Hitta en funktion snabbt genom att klicka i rutan Sök efter funktion och börja skriva funktionsnamnet. Börja till exempel att skriva PRODUKTSUMMA.

  4. Klicka på rutan intill matris1 och markera sedan cellerna B2 till B7 på bladet (värdena i kolumnen Pris per enhet).

  5. Klicka på rutan intill matris2 och markera sedan cellerna C2 till C7 på bladet (värdena i kolumnen Antal beställda enheter).

  6. Klicka till höger om formelns avslutande parentes i formelfältet och skriv /

    Om du inte ser formelfältet klickar du på Formelfält i menyn Visa.

  7. I listan Formelverktyget dubbelklickar du på SUMMA.

  8. Markera området i rutan tal1, tryck DELETE och markera sedan cellerna C2 till C7 på bladet (värdena i kolumnen Antal enheter).

    Formelfältet ska nu innehålla följande formel: =PRODUKTSUMMA(B2:B7;C2:C7)/SUMMA(C2:C7).

  9. Tryck på RETUR

    Formeln dividerar den totala kostnaden för alla beställningar med det totala antalet beställda enheter vilket ger ett viktat genomsnittligt pris per enhet på 29,38297872.

Beräkna ett medelvärde som ignorerar specifika värden

Du kan skapa en formel som utesluter specifika värden. I det här exemplet skapar du en formel som beräknar den genomsnittliga enhetskvaliteten för alla enheter som har ett värde över 5.

  1. Markera cell A10, som är cellen till vänster om cellen som innehåller texten ”Genomsnittligt kvalitet för alla enheter med ett värde över 5”.

  2. På fliken Formler klickar du på Infoga funktion för att öppna fönstret Formelverktyg.

  3. I listan Formelverktyget dubbelklickar du på MEDEL.OM.

    Tips: Hitta en funktion snabbt genom att klicka i rutan Sök efter funktion och börja skriva funktionsnamnet. Börja till exempel att skriva MEDEL.OM.

  4. Klicka på rutan intill område och markera sedan cellerna A2 till A7 på bladet (värdena i kolumnen Pris per enhet).

  5. Klicka i rutan intill villkor och skriv sedan ”>5”.

  6. Tryck på RETUR

    Formeln undantar värdet i cell A7 från beräkningen och ger en genomsnittlig enhetskvalitet på 8,8.

    Tips: Använd funktionen MEDEL.OM för att beräkna ett medelvärde som undantar nollvärden i en lista med värden genom att skriva ”<>0” i rutan intill villkor.

Snabbreferens

Beräkna en löpande summa

Beräkna procent

Funktionen MEDEL

Behöver du mer hjälp?

Vill du ha fler alternativ?

Utforska prenumerationsförmåner, bläddra bland utbildningskurser, lär dig hur du skyddar din enhet med mera.

Communities hjälper dig att ställa och svara på frågor, ge feedback och få råd från experter med rika kunskaper.

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?
Genom att trycka på skicka, kommer din feedback att användas för att förbättra Microsofts produkter och tjänster. IT-administratören kan samla in denna data. Sekretesspolicy.

Tack för din feedback!

×