Hantera förhandsgranskning av data (Power Query)

Du kan hantera flera aspekter av förhandsgranskningen i Power Query-redigeraren genom att ange olika alternativ. Flera av de här alternativen har prestandakonsekvenser som är bra att känna till.   

Exempeldata som används för att förklara kommandot Slå samman

Du kan styra hur förhandsgranskningsdata laddas ned direkt eller i bakgrunden.

  1. Gör något av följande:

    • I Excel väljer du Data> Hämta data >Frågealternativ.

    • I Power Query-redigeraren väljer du Arkiv> Alternativinställningar > Frågealternativ.

  2. I det vänstra fönstret under GLOBALväljer du Databelastningoch sedan under Bakgrundsdataväljer du ett av följande alternativ:

    • Tillåt alltid att förhandsgranskningar laddas ned i bakgrunden

    • Tillåt att dataförhandsgranskningar laddas ned i bakgrunden enligt inställningen för respektive fil

    • Tillåt aldrig att förhandsgranskningar laddas ned i bakgrunden

  3. I det vänstra fönstret under AKTUELL ARBETSBOKväljer du Dataladdningoch sedan underBakgrundsdata markerar eller avmarkerar du Tillåt att förhandsgranskningar laddas ned i bakgrunden.

Du kan visa data i ett monoområdesteckensnitt eller visa specialtecken, till exempel nya linjer.

Ange alternativ för aktuell förhandsgranskning

  1. I Power Query-redigeraren väljer duVisa och sedan väljer eller avmarkerar du något av följande i gruppen Förhandsgranskning:

    • Monospaced    Visa förhandsgranskningsinnehåll med ett monoområdesteckensnitt.

    • Visa blanksteg    Visa blanksteg och tecken i nyrad.

Ange alternativ för alla dina arbetsböcker

  1. Välj Arkiv > Alternativ och Inställningar > Alternativ för> i Power Query-redigeraren > Dataförhandsgranskning.

  2. I den vänstra rutan under GLOBAL väljerdu Power Query-redigeraren.

  3. I det högra fönstret, under Förhandsgranskning,markerar eller avmarkerar du följande:

    • Visa förhandsgranskningsinnehåll med ett monoområdesteckensnitt

    • Visa blanksteg och nya tecken

Det finns tillfällen då du vill se hela datauppsättningen. Du behöver till exempel räkna alla rader. Men du får bättre prestanda om du markerar de första 1000 raderna, särskilt om datamängden är ganska stor.

  1. Om du vill öppna en fråga letar du upp en tidigare inläst från Power Query-redigeraren, markerar en cell i dina data och väljer sedan Fråga > Redigera. Mer information finns i Skapa, läsa in eller redigera en fråga i Excel.

  2. Välj ett av kommandona till höger om kolumnerna och radantalet längst ned till höger i Förhandsgranskning:

    • Kolumnprofilering baserad på de 1 000 översta raderna

    • Kolumnprofilering baserat på hela datauppsättningen

Se även

Hjälp om Power Query för Excel

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×