När du hanterar spillda matrisfunktioner, till exempel SEKVENS,är det möjligt att referera till hela spillområdet genom att placera en intervalloperator (#) efter intervallet. I följande exempel har vi =SEKVENS(10) i cell A2 som spiller till A2:A11. I cell C2 har vi formeln =SUMMA(A2#), som motsvarar =SUMMA(A2:A11), eftersom A2:A11 är spillområdet för formeln i A2. Detta returnerar 55, summan av alla värden i det spillda matrisområdet.

Om spillområdet växer eller blir kontrakt, till exempel genom att ändra formeln i A2 till =SEKVENS(20), återspeglar SUMMA-formeln automatiskt det. Om det var ett normalt område skulle vi behöva ange =SUMMA(A2:A11) och uppdatera det manuellt om spillområdet ändras. Ofta kanske du inte inser om ett intervall har ändrats, så det kan ta bort mycket gissningsarbete.

Områdesoperator för spill för att referera till hela spillda matrisområden med =SUMMA(A2#).

Här är ett annat exempel på hur du använder områdesoperatorn för spill i flera formler, där vi skapar en unik lista från en lista med namn, sorterar listan och filtrerar sedan efter namn som är längre än 3 tecken. Vi har =SORTERA(C2#) i cell E2 och =FILTER(C2#,LÄNGD(C2#)>3) i cell G2.

Intervalloperator (#) för att referera till ett helt spillmatrisområde med =FILTER(C2#;LÄNGD(C2#)>3)

Kända begränsningar

Operatorn för spillområde stöder inte referenser till stängda arbetsböcker. I stället returneras en #REF! felvärde. Problemet löses om du öppnar den refererade arbetsboken.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Se även

Funktionen FILTER

Funktionen SLUMPMATRIS

Funktionen SEKVENS

Funktionen SORTERA

Funktionen SORTERAEFTER

Funktionen UNIK

Felet #SPILL! i Excel

Dynamiska matriser och beteenden för matriser och spill

Implicit skärningspunktsoperator: @

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Gå med i Microsoft Office Insiders

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?

Tack för din feedback!

×