Skapa ett histogram

Ett histogram är ett stapeldiagram som visar frekvensdata.

Obs!: Det här avsnittet handlar bara om att skapa ett histogram. Information om paretodiagram (sorterat histogram) finns i Skapa ett paretodiagram.

  • Vilken version/produkt använder du?
  • Excel 2016 och nyare versioner
  • Excel 2007–2013
  • Outlook, PowerPoint, Word 2016

  1. Markera data.

    (Det här är ett typiskt exempel på data för ett histogram.)

    Data som används för att skapa exempelhistogrammet ovan
  2. Klicka på Infoga > Infoga statistikdiagram > Histogram.

    Kommando för histogram som nås via knappen Infoga statistiskt diagram

    Du kan också skapa ett histogram från fliken Alla diagram i Rekommenderade diagram.

Tips: 

  • Anpassa diagrammetsutseende på flikarna Design och Format.

  • Om flikarna inte visas kan du lägga till Diagramverktyg i menyfliksområdet genom att klicka var som helst i histogrammet.

Flikarna Design och Format för Diagramverktyg

  1. Högerklicka på diagrammets vågräta axel, klicka på Formatera axeloch sedan på Alternativ för axel.

    Kommandot Formatera axel på snabbmenyn
  2. Använd informationen i följande tabell för att avgöra vilka alternativ du vill ange i åtgärdsfönstret Formatera axel.

    Alternativ

    Beskrivning

    Efter kategori

    Välj det här alternativet om kategorierna (vågrät axel) är textbaserade i stället för numeriska. I histogrammet grupperas samma kategorier och värdena summeras på värdeaxeln.

    Tips: Om du vill räkna antalet förekomster för textsträngar lägger du till en kolumn och fyller den med värdet "1", och ritar sedan histogrammet och ställer in lagerplatserna på Efter kategori.

    Automatiskt

    Det här är standardinställningen för histogram. Lagerplatsbredden beräknas enligt Scotts normalreferensregel.

    Fackbredd

    Ange ett positivt decimaltal för antalet datapunkter i varje intervall.

    Antal lagerplatser

    Ange antalet lagerplatser för histogrammet (inklusive lagerplatserna för spill och underskott).

    Lagerplats för spill

    Markera den här kryssrutan om du vill skapa ett fack för alla värden över värdet i rutan till höger. Om du vill ändra värdet anger du ett annat decimaltal i rutan.

    Fack för värden under (underflow bin)

    Markera den här kryssrutan om du vill skapa ett fack för alla värden som ligger under eller lika med värdet i rutan till höger. Om du vill ändra värdet anger du ett annat decimaltal i rutan.

    Åtgärdsfönstret Formatera axlar

Tips: Mer information om histogrammet och hur det gör det lättare att visualisera statistiska data finns i det här blogginlägget om histogram, paretodiagram och låddiagram av Excel-gruppen. Du kanske även vill veta mer om andra nya diagramtyper som beskrivs i det här blogginlägget.

Automatiskt alternativ (Scotts normala referensregel)   

Formel för alternativet Automatisk

Scotts normalreferensregel försöker minimera snedvridningen i varians för histogrammet jämfört med datauppsättningen, samtidigt som normalfördelade data förutsätts.

Alternativet Lagerplats för spill   

Formel för alternativet Lagerplats för överskott

Alternativet Lagerplats för underflöde   

Formel för alternativet Lagerplats för underskott
  1. Kontrollera att du har läst in Analysis ToolPak. Mer information finns i Läsa in Analysis ToolPak i Excel.

  2. Skriv indata i en kolumn på kalkylbladet och lägg till en etikett i den första cellen om du vill.

    Se till att använda kvantitativa numeriska data, t.ex. artikelantal eller testpoäng. Histogramverktyget fungerar inte med kvalitativa numeriska data, t.ex. identifieringsnummer som angetts som text.

  3. I nästa kolumn skriver du lagerplatsnumren i stigande ordning och lägger till en etikett i den första cellen om du vill.

    Det är en bra idé att använda dina egna facknummer, eftersom de kan vara mer värdefulla för din analys. Om du inte anger några facknummer skapar histogramverktyget jämnt fördelade fackintervall genom att använda minimi- och maximivärdena i indataområdet som start- och slutpunkter.

  4. Klicka på Data > Dataanalys.

    Knappen Dataanalys i gruppen Dataanalys

  5. Klicka på Histogram > OK.

    Dialogrutan Dataanalys

  6. Under Indata gör du följande:

    1. I rutan Indataområde anger du cellreferensen för det dataområde som innehåller indatanumren.

    2. I rutan Fackintervall anger du cellreferensen för det område som har facknumren.

      Om du använde kolumnetiketter på kalkylbladet kan du ta med dem i cellreferenserna.

      Tips: I stället för att ange referenser manuellt kan Knappen Minimera att tillfälligt dölja dialogrutan för att markera områdena i kalkylbladet. Om du klickar på knappen igen expanderas dialogrutan.

  7. Om du tog med kolumnetiketter i cellreferenserna markerar du rutan Etiketter.

  8. Under Utdataalternativ väljer du en utdataplats.

    Du kan placera histogrammet i samma kalkylblad, ett nytt kalkylblad i samma arbetsbok eller i en ny arbetsbok.

  9. Markera en eller fler av följande rutor:

    Pareto (sorterat histogram) Visa data i fallande frekvensordning.

    Ackumulerad procent     Visar ackumulerad procent och lägger till en rad med ackumulerad procent i histogramdiagrammet.

    Diagramutdata     Visar ett inbäddat histogramdiagram.

  10. Klicka på OK.

    Om du vill anpassa ditt histogram kan du ändra textetiketter och klicka någonstans i histogramdiagrammet för att använda knapparna Diagramelement, Diagramformat och Diagramfilter till höger om diagrammet.

  1. Markera data.

    (Det här är ett typiskt exempel på data för ett histogram.)

    Data som används för att skapa exempelhistogrammet ovan
  2. Klicka Infoga > Diagram.

    Knappen Diagram i gruppen Illustrationer på fliken Infoga i Word
  3. I dialogrutan Infoga diagram, under Alla diagram, klickardu på Histogram och sedan på OK.

Tips: 

  • Anpassa diagrammetsutseende på flikarna Design och Format i menyfliksområdet.

  • Om flikarna inte visas kan du lägga till Diagramverktyg i menyfliksområdet genom att klicka var som helst i histogrammet.

Flikarna Design och Format för Diagramverktyg

  1. Högerklicka på diagrammets vågräta axel, klicka på Formatera axeloch sedan på Alternativ för axel.

    Kommandot Formatera axel på snabbmenyn
  2. Använd informationen i följande tabell för att avgöra vilka alternativ du vill ange i åtgärdsfönstret Formatera axel.

    Alternativ

    Beskrivning

    Efter kategori

    Välj det här alternativet om kategorierna (vågrät axel) är textbaserade i stället för numeriska. I histogrammet grupperas samma kategorier och värdena summeras på värdeaxeln.

    Tips: Om du vill räkna antalet förekomster för textsträngar lägger du till en kolumn och fyller den med värdet "1", och ritar sedan histogrammet och ställer in lagerplatserna på Efter kategori.

    Automatiskt

    Det här är standardinställningen för histogram.

    Fackbredd

    Ange ett positivt decimaltal för antalet datapunkter i varje intervall.

    Antal lagerplatser

    Ange antalet lagerplatser för histogrammet (inklusive lagerplatserna för spill och underskott).

    Lagerplats för spill

    Markera den här kryssrutan om du vill skapa ett fack för alla värden över värdet i rutan till höger. Om du vill ändra värdet anger du ett annat decimaltal i rutan.

    Fack för värden under (underflow bin)

    Markera den här kryssrutan om du vill skapa ett fack för alla värden som ligger under eller lika med värdet i rutan till höger. Om du vill ändra värdet anger du ett annat decimaltal i rutan.

    Åtgärdsfönstret Formatera axlar

Följ dessa steg om du vill skapa ett histogram i Excel för Mac:

  1. Välj data.

    (Det här är ett typiskt exempel på data för ett histogram.)

    Data som används för att skapa exempelhistogrammet ovan
  2. I menyfliksområdet klickar du fliken Infoga och sedan på Ikonen Statistikdiagram ( Statistikikon) och under Histogramväljer du Histogram.

Tips: 

  • Anpassa diagrammets utseende flikarna Diagramdesign och Format.

  • Om flikarna Diagramdesign och Format inte visas kan du lägga till dem i menyfliksområdet genom att klicka var som helst i histogrammet.

Om du vill skapa ett histogram i Excel 2011 för Mac måste du ladda ned ett tillägg från tredje part. Mer information finns i: Jag hittar inte Analysis Toolpak i Excel 2011 för Mac.

I Excel Online kan du visa ett histogram (ett stapeldiagram som visar frekvensdata), men du kan inte skapa det eftersom Analysis ToolPak är ett Excel-tillägg som inte stöds i Excel på webben.

Om du har Excel-programmet kan du använda knappen Redigera i Excel för att öppna Excel på skrivbordet och skapa histogrammet.

Knappen Redigera i Excel

  1. Tryck för att markera dina data.

    Data som används för att skapa exempelhistogrammet ovan
  2. Om du använder en telefon trycker du på redigeringsikonen för Ikonen Redigera att visa menyfliksområdet. och trycker sedan på Start.

  3. Tryck > Diagram > Histogram.

    Om det behövs kan du anpassa elementen i diagrammet.

    Obs!: Den här funktionen är endast tillgänglig om du har en Microsoft 365-prenumeration. Om du har en Microsoft 365-prenumeration bör du kontrollera att du har den senaste versionen av Office.

  1. Tryck för att markera dina data.

    Data som används för att skapa exempelhistogrammet ovan
  2. Om du använder en telefon trycker du på redigeringsikonen för Ikonen Redigera att visa menyfliksområdet och trycker sedan på Start.

  3. Tryck > Diagram > Histogram.

Om du vill skapa ett histogram i Excel anger du två typer av data – de data du vill analysera och facknumren som representerar de intervall för vilka du vill mäta frekvensen. Du måste ordna data i två kolumner i kalkylbladet. Kolumnerna måste innehålla följande data:

  • Indata    Det här är de data som du vill analysera med histogramverktyget.

  • Facknummer    De här talen representerar intervallen som du vill att histogramverktyget ska använda för att mäta indata i dataanalysen.

När du använder histogramverktyget Excel antalet datapunkter i varje datafack. En datapunkt tas med i ett visst fack om talet är större än den lägsta gränsen och är lika med eller mindre än den största bundna gränsen för datafack. Om du utelämnar fackområdet skapas Excel en uppsättning jämnt fördelade fack mellan minimi- och maxvärdena för indata.

Resultatet av histogramanalysen visas i ett nytt kalkylblad (eller i en ny arbetsbok) och visar ett histogram och ett stapeldiagram som återspeglar data i histogramtabellen.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Se även

Skapa ett vattenfallsdiagram

Skapa ett paretodiagram

Skapa ett soldiagram i Office

Skapa ett låddiagram

Skapa ett treemap-diagram i Office

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×