Testa om villkor är sanna eller falska och det är vanligt med många uppgifter att göra logiska jämförelser mellan uttryck. Du kan använda funktionerna OCH, ELLER, ICKE och OM för att skapa villkorsstyrda formler.

Funktionen OM använder till exempel följande argument:

formel med funktionen OM

Formel som använder funktionen OM

Bild av knapp logical_test: Det villkor som du vill kontrollera.

Bild av knapp value_if_true: Värdet som ska returneras om villkoret är Sant.

Knappbild value_if_false: Värdet som ska returneras om villkoret är Falskt.

Mer information om hur du skapar formler finns i Skapa eller ta bort en formel.

Vad vill du göra?

Skapa en villkorsstyrd formel som resulterar i ett logiskt värde (SANT eller FALSKT)

Om du vill utföra den här uppgiften använder du funktionerna OCH, ELLER och ICKE , enligt följande exempel.

Exempel

Detta blir enklare att förstå om du kopierar exemplet till ett kalkylblad.

Hur kopierar jag ett exempel?

  1. Markera exemplet i den här artikeln.

    välja ett exempel från hjälpen i Excel 2013 för Windows

    Markera ett exempel i hjälpen

  2. Tryck på Ctrl+C.

  3. Skapa en tom arbetsbok eller ett tomt kalkylblad i Excel.

  4. Markera cell A1 i kalkylbladet och tryck på Ctrl+V.

Viktigt!: För att exemplet ska fungera måste du klistra in det i cell A1 i kalkylbladet.

  1. Om du vill växla mellan att visa resultatet och de formler som returnerar resultatet trycker du på Ctrl+§. Du kan också gå till fliken Formler och klicka på Visa formler i gruppen Formelgranskning.

När du har kopierat exemplet till ett tomt kalkylblad kan du anpassa det efter dina behov.

Data

15

9

8

Kedjehjul

Widgets

Formel

Beskrivning (Resultat)

=OCH(A2>A3; A2<A4)

Avgör om värdet i cell A2 är större än värdet i A3 och även om värdet i A2 är mindre än värdet i A4. (FALSKT)

=ELLER(A2>A3; A2<A4)

Avgör om värdet i cell A2 är större än värdet i A3 eller om värdet i A2 är mindre än värdet i A4. (SANT)

=ICKE(A2+A3=24)

Avgör om summan av värdena i cellerna A2 och A3 inte är lika med 24. (FALSKT)

=ICKE(A5="Sprockets")

Avgör om värdet i cell A5 inte är lika med "Sprockets". (FALSKT)

=ELLER(A5<>"Sprockets",A6 = "Widgetar")

Avgör om värdet i cell A5 inte är lika med "Sprockets" eller om värdet i A6 är lika med "Widgetar". (SANT)

Mer information om hur du använder de här funktionerna finns i Funktionen OCH, FUNKTIONEN ELLER och FUNKTIONEN ICKE.

Överst på sidan

Skapa en villkorsstyrd formel som resulterar i en annan beräkning eller i andra värden än SANT eller FALSKT

Om du vill utföra den här uppgiften använder du funktionerna OM, OCH och ELLER och operatorer som visas i följande exempel.

Exempel

Detta blir enklare att förstå om du kopierar exemplet till ett kalkylblad.

Hur kopierar jag ett exempel?

  1. Markera exemplet i den här artikeln.

    Viktigt!: Markera inte rad- eller kolumnrubrikerna.

    välja ett exempel från hjälpen i Excel 2013 för Windows

    Markera ett exempel i hjälpen

  2. Tryck på Ctrl+C.

  3. Skapa en tom arbetsbok eller ett tomt kalkylblad i Excel.

  4. Markera cell A1 i kalkylbladet och tryck på Ctrl+V.

Viktigt!: För att exemplet ska fungera måste du klistra in det i cell A1 i kalkylbladet.

  1. Om du vill växla mellan att visa resultatet och de formler som returnerar resultatet trycker du på Ctrl+§. Du kan också gå till fliken Formler och klicka på Visa formler i gruppen Formelgranskning.

När du har kopierat exemplet till ett tomt kalkylblad kan du anpassa det efter dina behov.

Data

15

9

8

Kedjehjul

Widgets

Formel

Beskrivning (Resultat)

=OM(A2=15; "OK", "Inte OK")

Om värdet i cell A2 är lika med 15 returnerar du "OK". Annars returnerar du "Inte OK". (OK)

=OM(A2<>15; "OK", "Inte OK")

Om värdet i cell A2 inte är lika med 15 returnerar du "OK". Annars returnerar du "Inte OK". (Inte OK)

=OM(ICKE(A2<=15), "OK", "Inte OK")

Om värdet i cell A2 inte är mindre än eller lika med 15 returnerar du "OK". Annars returnerar du "Inte OK". (Inte OK)

=OM(A5<>"SPROCKETS", "OK", "Inte OK")

Om värdet i cell A5 inte är lika med "SPROCKETS" returnerar du "OK". Annars returnerar du "Inte OK". (Inte OK)

=OM(OCH(A2>A3, A2<A4), "OK", "Inte OK")

Om värdet i cell A2 är större än värdet i A3 och värdet i A2 också är mindre än värdet i A4, returnerar du "OK". Annars returnerar du "Inte OK". (Inte OK)

=OM(OCH(A2<>A3, A2<>A4), "OK", "Inte OK")

Om värdet i cell A2 inte är lika med A3 och värdet i A2 inte är lika med värdet i A4, returnerar du "OK". Annars returnerar du "Inte OK". (OK)

=OM(ELLER(A2>A3, A2<A4), "OK", "Inte OK")

Om värdet i cell A2 är större än värdet i A3 eller om värdet i A2 är mindre än värdet i A4, returnerar du "OK". Annars returnerar du "Inte OK". (OK)

=OM(ELLER(A5<>"Sprockets", A6<>"Widgets"), "OK", "Inte OK")

Om värdet i cell A5 inte är lika med "Sprockets" eller om värdet i A6 inte är lika med "Widgetar" returnerar du "OK". Annars returnerar du "Inte OK". (Inte OK)

=OM(ELLER(A2<>A3, A2<>A4), "OK", "Inte OK")

Om värdet i cell A2 inte är lika med värdet i A3 eller om värdet i A2 inte är lika med värdet i A4, returnerar du "OK". Annars returnerar du "Inte OK". (OK)

Mer information om hur du använder de här funktionerna finns i Funktionen OM, FUNKTIONEN OCH och FUNKTIONEN ELLER.

Överst på sidan

Behöver du mer hjälp?

Utöka dina kunskaper

UTFORSKA UTBILDNING >

Få nya funktioner först

ANSLUT TILL MICROSOFT INSIDERS >

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?

Tack för din feedback!

×