Logga in med Microsoft
Logga in eller skapa ett konto.
Hej,
Välj ett annat konto.
Du har flera konton
Välj det konto som du vill logga in med.

Sammanfattning

När du försöker starta en dator med Windows XP kan det hända att ett felmeddelande om att operativsystemet inte kan hittas.

Symptom

När du startar en dator med Windows XP visas något av följande felmeddelanden.

Felmeddelande 1

Operativsystemet hittades inte.

Felmeddelande 2

Operativsystem saknas

När du startar datorn till Återställningskonsolen för att återställa funktionerna, kan det hända att ett felmeddelande som liknar följande felmeddelande:

Installationsprogrammet kunde inte hitta några hårddiskar installerade på datorn.

Orsak

Det här problemet kan uppstå om en eller flera av följande villkor är uppfyllda:

  • Basic input/output system (BIOS) identifierar inte hårddisken.

  • Hårddisken är skadad.

  • Sektor 0 på den fysiska hårddisken har en felaktig eller felaktigt master boot record (MBR).

    Obs! Vissa program från tredje part eller skadade disken kan skada en MBR.

  • En inkompatibel partition markerad som aktiv.

  • En partition som innehåller MBR är inte längre aktiv.

Lösning

Lös problemet med någon av följande metoder.

Kontakta maskinvarutillverkaren

Det bästa alternativet kan vara att kontakta tillverkaren av datorn eller hårddisken. Tillverkaren kan ha ett verktyg som du kan använda för att utföra en mer detaljerad sökning efter skadade områden på disken och att kontrollera att BIOS-inställningarna. Men tänk på att skador på hårddisken kan vara allvarliga. Ibland innebär detta att den enda lösningen är att byta ut hårddisken.

Om en korrigeringsfil eller lösning inte är tillgänglig, kan du använda avsnittet "Avancerad felsökning" att lösa problemet.

Avancerad felsökning

Det här avsnittet är avsett för avancerade datoranvändare. Om du inte själv kan genomföra avancerad felsökning kan du be någon om hjälp eller kontakta support. Information om hur du kontaktar Microsoft support finns på följande Microsoft-webbplats:

http://support.microsoft.com/contactus/

Metod 1: Kontrollera BIOS-inställningarna

Kontrollera datorns BIOS-inställningar för att kontrollera att BIOS visar och känner igen hårddisken. Finns i datordokumentationen till eller kontakta maskinvarutillverkaren för information om hur du kontrollerar BIOS-inställningarna.


När du har kontrollerat att hårddisken identifieras datorns BIOS startar du om datorn och provar om problemet är borta. Om problemet inte är löst eller om datorns BIOS kan identifiera hårddisken kan du ha problem med maskinvaran. Kontakta maskinvarutillverkaren om du vill veta mer om hur du löser det här problemet. Du kan behöva byta ut hårddisken.

Information om hur du kontaktar maskinvarutillverkare klickar du på lämpligt artikelnummer i följande lista och läser artikeln i Microsoft Knowledge Base:

65416 kontaktlista för andra maskin- och programvaruleverantörer kontaktinformation, A-K

60781 maskin- och programvaruleverantörer kontaktinformation, L-P

60782 maskinvara och programvara leverantörens kontaktinformation, Q-Z

Metod 2: Använd Återställningskonsolen

Använda kommandot fixmbr i Återställningskonsolen i Windows XP för att reparera MBR till startpartitionen.

Varning Detta kommando kan skada partitionstabellen om det finns virus eller maskinvaruproblem. Om du använder det här kommandot kan du skapa tillgängliga partitioner. Vi rekommenderar att du kör ett antivirusprogram innan du använder detta kommando. Vi rekommenderar att du säkerhetskopierar dina data innan du använder detta kommando. Om du använder kommandot fixmbr identifieras en ogiltig eller icke-standardiserade, efterfrågas kommandot fixmbr tillstånd innan MBR. Kommandot fixmbr stöds endast på datorer med x86.

Mer information om Återställningskonsolen klickar du på följande artikelnummer och läser artiklarna i Microsoft Knowledge Base:

314058 beskrivning av Återställningskonsolen för Windows XP

307654 installera och använda Återställningskonsolen i Windows XP

Mer Information

Mer information om felsökning av startproblem i Windows XP klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:

308041 resurser för felsökning av startproblem i Windows XP

Behöver du mer hjälp?

Vill du ha fler alternativ?

Utforska prenumerationsförmåner, bläddra bland utbildningskurser, lär dig hur du skyddar din enhet med mera.

Communities hjälper dig att ställa och svara på frågor, ge feedback och få råd från experter med rika kunskaper.

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?
Genom att trycka på skicka, kommer din feedback att användas för att förbättra Microsofts produkter och tjänster. IT-administratören kan samla in denna data. Sekretesspolicy.

Tack för din feedback!

×