Symptom
Du försöker använda Distributionshanteraren för att importera en organisation till Microsoft Dynamics CRM 4.0. Det tar dock lång tid att importera organisationen med guiden Importera organisation.
Orsak
Det här problemet uppstår eftersom det finns många systemanvändarreferenser som måste uppdateras.
Lösning
Viktigt: Det här avsnittet, metoden eller uppgiften innehåller steg som visar hur du ändrar registret. Men om du ändrar registret på fel sätt kan det orsaka allvarliga problem. Se därför till att du följer de här stegen noggrant. För ytterligare skydd bör du backa upp registret innan du ändrar det. Du kan sedan återställa registret om det uppstår problem. Om du vill ha mer information om hur du ska backa upp och återställa registret klickar du på följande artikelnummer för att visa artikeln i Microsoft Knowledge Base:
322756 Hur du återställer registret i WindowsThis-problemet är åtgärdat i den senaste kumulativa uppdateringsuppdateringen för Microsoft Dynamics CRM 4.0.
Om du vill ha mer information klickar du på följande artikelnummer för att visa artikeln i Microsoft Knowledge Base:
949256 Uppdateringar och snabbkorrigeringar för Microsoft Dynamics CRM 4.0 När du har installerat den här snabbkorrigeringen kan vi lägga till
OptimizeOrgImport REG_DWORD-registerposten åt dig genom att gå till avsnittet "Åtgärda det åt
mig". Om du föredrar att lägga till OptimizeOrgImport REG_DWORD postposten själv går du till avsnittet "Jagkan lösa det på egenhand".
Lös det åt mig
Om du vill lägga till OptimizeOrgImport REG_DWORD posten automatiskt klickar du på Knappen Åtgärda det eller länken. Klicka sedan på Kör i dialogrutan Filhämtning och följ stegen i Fix it-guiden.
Anteckningar
-
Den här guiden är kanske enbart på engelska. Den automatiska korrigeringsfilen fungerar dock även för andra språkversioner av Windows.
-
Om du inte är på den dator där problemet finns sparar du Fix it-lösningen på ett flashminne eller en CD-skiva och kör den sedan på den dator där problemet uppstår.
Gå sedan till avsnittet"Löste det här problemet?".
Jag löser det själv
När du har installerat den här snabbkorrigeringen måste du lägga till registerposten OptimizeOrgImport REG_DWORD på Microsoft Dynamics CRM 4.0-servern. Gör så här:
-
Klicka på Start,klicka påKör, skriv regedit och klicka sedan på OK.
-
Leta upp och klicka på följande registerundernyckel:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
-
Högerklicka på MSCRM,peka på
Nyttoch klicka sedan på DWORD-värde. -
Namnge det här DWORD-värdet som "OptimizeOrgImport"
-
Högerklicka på OptimizeOrgImport ochklicka sedan på Ändra.
-
Skriv 1 i rutan
Värdedata och klicka sedan på OK. -
Klicka på Avsluta på
Arkiv-menyn.
Obs! Om du vill inaktivera den här snabbkorrigeringen anger du värdet för registerposten OptimizeOrgImport till 0.
Löste det här problemet?
-
Kontrollera om problemet är åtgärdat. Om problemet är åtgärdat är du klar med det här avsnittet. Om problemet inte är åtgärdat kan du kontakta support.
-
Vi skulle uppskatta din feedback. Lämna en kommentar på bloggen"Åtgärdadet åt mig" eller skicka ett e-postmeddelande till oss om du vill ge feedback eller rapportera problem med den här lösningen.
Mer information
När du använder registerposten OptimizeOrgImport och har värdet 1 för den här posten kan du inte importera samma organisationsdatabas mer än en gång. Om du vill importera samma organisationsdatabas flera gång måste du göra något av följande:
-
Ställ in OptimizeOrgImport = 0 och använd den vanliga importprocessen.
-
Ta bort organisationen och importera sedan organisationen igen.
Status
Microsoft har bekräftat att det är ett problem i de Microsoft-produkter som listas i avsnittet "Gäller för".