Logga in med Microsoft
Logga in eller skapa ett konto.
Hej,
Välj ett annat konto.
Du har flera konton
Välj det konto som du vill logga in med.

Den här artikeln gäller för Microsoft Dynamics NAV för alla länder och språkversioner.

Symptom

När du godkänner ett kreditkort i Microsoft Dynamics NAV 2009 R2 grundläggande verifiering information skickas till Microsoft Dynamics NAV Online-tjänsten och sedan vidarebefordras till betalningsförmedlaren. I detta fall om otillräcklig validering betalningsinformation skickas för auktoriseringsprocessen visas ett felmeddelande som inte säger att all information som ingår i transaktionen.
Till exempel kan du få följande felmeddelande:

Tillståndet transaktionen med mängden # misslyckades.
Felkod = 22062;
Meddelande = transaktionen har avböjt betalningsförmedlaren.


Orsak

Det här problemet uppstår eftersom valideringsinformation som har skickats för godkännande av kreditkortet är otillräcklig. Du måste konfigurera Microsoft Dynamics Online-lösning med av ytterligare valideringsinformation för vissa betalningsförmedlare. Till exempel måste betalningsförmedlare i USA du ange kreditkort innehavaren tillstånd.

Mer Information

När ett kreditkort är auktoriserad i Microsoft Dynamics NAV 2009 R2, grundläggande verifiering information skickas till Microsoft Dynamics Online-tjänsten och sedan vidarebefordras till motsvarande betalningsförmedlare. Den grundläggande informationen som inkluderar kreditkort Kortinnehavarens namn, adress, land och postnummer. Dock valideringskrav skiljer sig åt beroende på betalningsförmedlaren, typ av kreditkortet och krav för kreditkort – utfärdande bank.
Innan du kör auktoriseringsprocessen kreditkort, kontrollera att den grundläggande informationen som namn, adress, postnummer och så vidare anges på kontaktkortet för kortinnehavaren. Du bör konfigurera Microsoft Dynamics Online-lösning med av ytterligare valideringsinformation för vissa betalningsförmedlare. Till exempel måste du ange kort innehavaren tillstånd för betalningsförmedlare i USA.

Lösning

Information om snabbkorrigeringen

En snabbkorrigering är nu tillgänglig från Microsoft. Den är endast avsedd att åtgärda det problem som beskrivs i denna artikel. Använd den bara på datorer där detta problem uppstår. Snabbkorrigeringen kan komma att testas igen. Om inte störs alltför mycket av detta problem rekommenderar vi att du väntar på Nästa service pack-versionen för Microsoft Dynamics NAV eller nästa Microsoft Dynamics NAV-version som innehåller den här snabbkorrigeringen.

Obs! I särskilda fall, de avgifter som är normalt för support vara avgiftsfri om en supporttekniker för Microsoft Dynamics och relaterade produkter som bestämmer att en särskild uppdatering kan lösa ditt problem. De vanliga supportkostnaderna gäller för övriga supportfrågor och problem som inte berör den särskilda uppdateringen.



Installationsinformation

Microsoft tillhandahåller programmeringsexempel endast utan garanti varken uttryckliga eller underförstådda. Detta inkluderar men är inte begränsat till, underförstådda garantier om säljbarhet eller lämplighet för ett särskilt ändamål. Den här artikeln förutsätter att du är bekant med det programmeringsspråk som demonstreras och de verktyg som används för att skapa och felsöka procedurer. Microsofts supporttekniker kan hjälpa till med att förklara funktionen hos en viss procedur, men kan inte ändra dessa exempel för att ge ytterligare funktioner eller skapa procedurer som motsvarar dina speciella behov.

Obs! Innan du installerar den här snabbkorrigeringen måste du kontrollera att alla användare av Microsoft Navision-klient har loggat ut. Detta inkluderar Microsoft Navision Application Services (NAS) klientanvändare. Du ska endast klientanvändare som är inloggad när du implementerar den här snabbkorrigeringen.

Om du vill genomföra den här snabbkorrigeringen måste du ha en utvecklarlicens.

Vi rekommenderar att tilldelas användarkontot i fönstret Windows-inloggningar eller i fönstret databasinloggningar "SUPER" roll-ID. Om användarkontot inte kan tilldelas "SUPER" roll-ID måste du kontrollera att användarkontot har följande behörigheter:

  • Ändra behörighet för objektet ändras.

  • Körbehörighet för systemet objektet ID 5210 objektet och objektet System objektet ID 9015 .



Obs! Du har inte behörighet för datalager inte data reparation.

Kod ändras

Obs! Alltid åtgärdas testa koden i en kontrollerad miljö innan du installerar korrigeringar för produktionsdatorer.
Lös problemet så här:

  1. Kontrollera att fältet region (92) som finns i tabellen Kontakt (5050) och formuläret kontaktkort (5050).

  2. Ändra koden i funktionen CreateCreditCardObject i kodmodulen gör betalning Integration Mgt. (826) enligt följande:
    Befintlig kod

    ...CreditCardInfo.StreetAddress := Contact.Address;
    CreditCardInfo.PostalCode := Contact."Post Code";
    CreditCardInfo.City := Contact.City;
    CreditCardInfo.CountryOrRegion := Contact."Country/Region Code";
    ...

    Ersättningskod

    ...CreditCardInfo.StreetAddress := Contact.Address;
    CreditCardInfo.PostalCode := Contact."Post Code";
    CreditCardInfo.City := Contact.City;
    CreditCardInfo.CountryOrRegion := Contact."Country/Region Code";

    // Add the following line.
    CreditCardInfo.StateOrProvince := Contact.County;
    ...

Förutsättningar

Du måste ha Microsoft Dynamics NAV 2009 R2 installerat för att kunna installera den här snabbkorrigeringen.

Information om borttagning

Du kan inte ta bort den här snabbkorrigeringen.

Status

Microsoft har bekräftat att detta är ett problem i Microsoft-produkterna som nämns i avsnittet "Gäller".

Obs! Detta är en "SNABBPUBLICERING"-artikel skapad direkt från Microsoft support-organisationen. Informationen häri tillhandahålls i befintligt skick som svar på nya problem. Till följd av hastigheten för att göra det tillgängligt kan materialet innehålla typografiska fel och kan ändras när som helst utan föregående meddelande. Se Villkoren för användning för andra överväganden.

Behöver du mer hjälp?

Vill du ha fler alternativ?

Utforska prenumerationsförmåner, bläddra bland utbildningskurser, lär dig hur du skyddar din enhet med mera.

Communities hjälper dig att ställa och svara på frågor, ge feedback och få råd från experter med rika kunskaper.

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?
Genom att trycka på skicka, kommer din feedback att användas för att förbättra Microsofts produkter och tjänster. IT-administratören kan samla in denna data. Sekretesspolicy.

Tack för din feedback!

×