Symptom
Tänk dig följande situation:
-
Du har en Microsoft SharePoint Server-webbplatssamling som är konfigurerad för att använda SAML(Security Assertions Markup Language) för anspråk på autentisering.
-
Användarna använder aktivt webbplatssamlingen.
-
Du ändrarSTS-certifikatet (Security Token Service).
I det här fallet omdirigeras alla användare som för närvarande är inloggade till SharePoint Server-webbplatssamlingen till autentisera. När användare försöker logga in på webbplatssamlingen får de dessutom ett felmeddelande som liknar följande:
Ett fel uppstod. Kontakta administratören om du vill ha mer information.
Aktivitets-ID: 00000000-0000-0000-0d00-00800000001
Förlitande part: RelyingParty2013
Feltid: Mån, 13 okt 2014 14:58:28 GMT
Cookie: aktiverad
Användaragentsträng: Mozilla/5.0 (kompatibel; MSIE 10.0; Windows NT 6.3; WOW64; Trident/7.0; . NET4.0E; . NET4.0C; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729)
I SharePoint ULS-loggarna visas följande felmeddelande:
<mm/dd/ååååå-> <hh:min:sec.msec> w3wp.exe (0x0EC0) 0x1624 Ad5sl-autentisering för SharePoint Foundation misslyckades med att verifiera signaturen. 0ca3bf9c-5b4b-c077-8bc4-e01fcbaf1e55
Orsak
Det här problemet uppstår eftersom autentiseringstoken inte rensas automatiskt och STS inte längre kan läsa token för att kontrollera att den är inom dess giltighetsperiod.
Lösning
Du måste rensa cookies i webbläsaren för att lösa problemet.
Gå till exempel till Inställningar > Sekretesssökning och tjänster i Microsoft Edge, och för alternativet Radera webbdata nu i avsnittet Ta bort webbdata väljer du knappen Välj vad du vill radera . Välj alternativet Cookies och andra webbplatsdata, ändra inställningen för tidsintervall till All tid och välj sedan knappen Rensa nu .