KB3213703-åtgärd: en alltid på en sekundär replik övergår i läget koppla från

Symptom

När du använder SQL Server alltid på tillgänglighets grupper kan alltid den sekundära repliken gå in i frånkopplat skick. Dessutom loggas följande fel meddelande i SQL Server-felloggen:

En tids gräns för anslutning har uppstått vid försök att upprätta en anslutning till tillgänglighets replik availability_replica_name med ID availability_replica_id. Det finns ett nätverks-eller brand Väggs problem eller slut punktens adress för repliken.

När du försöker återupprätta anslutningen kan du få följande fel meddelande:

Denna sekundära replik är inte ansluten till den primära repliken. Statusen ansluten är FRÅNKOPPLAd.

När detta inträffar är problemet inte åtgärdat förrän du startar om SQL Server-tjänsterna på den sekundära repliken. I sällsynta fall kanske du måste starta om SQL Server-tjänsterna på den primära repliken för att fortsätta alltid på data trafik.Obs! Det här problemet kan bara uppstå på väldigt kraftfulla datorer och när SQL Server är mycket upptaget. Det här problemet uppstod till exempel i ett mycket upptaget system med 24 kärnor.

Orsak

Problemet uppstår på grund av ett internt konkurrens tillstånd.

Lösning

Det här problemet har åtgärd ATS i följande kumulativa uppdateringar av SQL Server.

Varje ny kumulativ uppdatering för SQL Server innehåller alla snabb korrigeringar och alla säkerhets korrigeringar som ingick i den föregående kumulativa uppdateringen. Kolla in de senaste kumulativa uppdateringarna för SQL Server: Senaste kumulativa uppdateringen för SQL server 2016densenaste kumulativa uppdateringen för SQL Server 2014densenaste kumulativa uppdateringen för SQL Server 2012 SP3

Status

Microsoft har bekräftat att det här är ett problem i Microsoft-produkterna som nämns i "gäller".

Referenser

Lär dig mer om terminologin som används av Microsoft för att beskriva program varu uppdateringar.

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×