Symptom
Anta att du använder ett program för datasäkerhet, till exempel IBM InfoSphere Guardium som utför följande uppgifter:
-
Övervakar alla databasanslutningar i nätverket
-
Relevant information lagras
-
Skapar rapporter om den lagrade informationen för BizTalk Server-program
I det här fallet avgör datasäkerhet programmet konsekvent att varje anslutning innebär ett nytt program. Slutligen blir överväldigande mängd lagrad information och medför att programmet kraschar.
Obs! Datasäkerhet-programmet lagrar information per program baserat på "Namn"-värdet som har angetts i anslutningssträngen.
Orsak
Det här problemet uppstår eftersom BizTalk-servern använder ett unikt GUID för "Namn" i varje anslutning för vissa samtal så att antalet registrerade "Programnamn" element växer oändligt och utlöser konflikter med övervakning av programmet.
Lösning
Information om Kumulativ uppdatering
Det här problemet korrigerades först i följande kumulativa uppdateringar för BizTalk Server:
Status
Microsoft har bekräftat att detta är ett problem i Microsoft-produkterna som nämns i avsnittet "Gäller".
Referenser
Information om servicepack och kumulativ uppdatering lista för BizTalk Server finns KB 2555976: Service pack och kumulativ uppdatering lista för BizTalk Server.
Läs mer om snabbkorrigeringar för BizTalk Server KB 2003907: Information om BizTalk-snabbkorrigeringar och kumulativ uppdatering support.