Symptom
Tänk dig följande situation:
-
I Microsoft Commerce Server Catalog Manager 2009 kan skapa du en variant produkt genom att lägga till en variant-egenskapen för en produkt. Listpriset för variant produkten skiljer sig från det ursprungliga listan priset på produkten.
-
Du kan använda formatet Full exporttyp för att exportera katalogen till en XML-fil.
-
Du kan importera den exporterade XML-filen till katalogen med Ersätt typ -format.
-
Du kan ändra kategori associering av produkten. Gör att du lägger till och välj sedan en kategori på fliken Associationer .
I det här fallet återställs listpriset för produkten som lagts variant till ursprungliga listpriset för produkten. Obs! Problemet uppstår även om du använder Commerce Server API: er för att utföra dessa åtgärder.
Orsak
Problemet uppstår eftersom variant exportvaran katalog XML-filen inte innehåller de ursprungliga egenskaperna för pris och listpris. När du importerar XML-katalogfil med formatet ersätta typ används produktens ursprungliga pris egenskaper för att fylla i saknade egenskaper i produkten variant.
Lösning
Information om snabbkorrigeringen
En snabbkorrigering är tillgänglig från Microsoft. Den här snabbkorrigeringen är emellertid avsedd att åtgärda det problem som beskrivs i denna artikel. Använd den här snabbkorrigeringen endast på datorer som har problemet som beskrivs i denna artikel. Snabbkorrigeringen kan komma att testas igen. Om du inte störs alltför mycket av detta problem rekommenderar vi att du väntar på nästa programuppdatering som innehåller den här snabbkorrigeringen. Om snabbkorrigeringen är tillgänglig för hämtning finns ett avsnitt för ”snabbkorrigeringen är tillgänglig” överst i den här Knowledge Base-artikeln. Om den sektionen saknas, kontakta Microsofts support för att få tag på hotfixen. Obs! Om det uppstår ytterligare problem eller krävs felsökning, kan du behöva skapa en serviceförfrågan. De vanliga supportkostnaderna gäller för övriga supportfrågor och problem som inte uppfyller kraven för den här snabbkorrigeringen. En fullständig lista över telefonnummer för Microsofts kundtjänst och Support eller skapa en serviceförfrågan finns på följande Microsoft-webbplats:
http://support.microsoft.com/contactus/?ws=supportObs! ”Snabbkorrigeringen tillgänglig”-formuläret visar de språk som snabbkorrigeringen är tillgänglig. Om ditt språk inte visas beror det på att ingen snabbkorrigering är tillgänglig för språket.
Installationsinformation
Om du använder Commerce Server 2009 Template Pack för SharePoint 2010 kan du hämta och installera paketet med etiketten ”CS2009TP_KB2532193”. Om du använder Microsoft Commerce Server 2009 RTM, hämta och installera paketet med etiketten ”CS2009RTM_KB2532193”.
Förutsättningar
Följande lista innehåller förutsättningarna för snabbkorrigeringspaketet:
-
Microsoft Commerce Server 2009
Krav på omstart
Du behöver inte starta om datorn när du har installerat den här snabbkorrigeringen. Men du måste starta om Internet Information Services (IIS) och Commerce Server Catalog Import värd COM +-programmet när du har installerat den här snabbkorrigeringen. Om du vill starta om IIS, öppna Kommandotolken skriver du följande kommando och tryck sedan på RETUR:
IISRESET/RESTART. Obs! Den här proceduren stoppas och startas sedan om alla IIS-tjänster som körs.
Information om ersättning
Den här snabbkorrigeringen ersätter inte någon tidigare utgiven snabbkorrigering.
Filinformation
Den globala versionen av den här snabbkorrigeringen används ett Microsoft Windows Installer-paket för att installera snabbkorrigeringen. Datum och tider för dessa filer anges i UTC-tid (UTC) i följande tabell. När du visar filinformationen konverteras datumet till lokal tid. Använd fliken tidszon i datum och tid på Kontrollpanelen om du vill se skillnaden mellan UTC-tid och lokal tid.
För Microsoft Commerce Server 2009 Template Pack för SharePoint 2010
Filnamn |
Filversion |
Storlek |
Datum |
Tid |
Plattform |
---|---|---|---|---|---|
Cspatchhelper.exe |
6.0.4171.513 |
16,224 |
12-Apr-2011 |
14:22 |
x86 |
Microsoft.catalogserver.dll |
6.0.4171.513 |
763,760 |
12-Apr-2011 |
14:22 |
x86 |
Microsoft.commerceserver.runtime.dll |
6.0.4171.513 |
849,792 |
12-Apr-2011 |
14:22 |
x86 |
Microsoft.commerceserver.catalog.dll |
6.0.4171.513 |
960,384 |
12-Apr-2011 |
13:58 |
x86 |
För Commerce Server 2009
Filnamn |
Filversion |
Storlek |
Datum |
Tid |
Plattform |
---|---|---|---|---|---|
Cs2009hotfixhelper.exe |
6.0.4171.46 |
12,136 |
06-Apr-2011 |
12:03 |
x86 |
Microsoft.catalogserver.dll |
6.0.4171.46 |
763,760 |
06-Apr-2011 |
12:03 |
x86 |
Microsoft.commerceserver.runtime.dll |
6.0.4171.46 |
849,792 |
06-Apr-2011 |
12:03 |
x86 |
Microsoft.commerceserver.catalog.dll |
6.0.4171.46 |
960,384 |
06-Apr-2011 |
11:42 |
x86 |
Status
Microsoft har bekräftat att detta är ett problem i Microsoft-produkterna som nämns i avsnittet ”gäller”.