Symptom
I Microsoft Office 365 dedikerad/ITAR, kan en användare få något av följande problem i Microsoft Lync/Skype för Business client:
-
Funktioner som fungerar inte som förväntat:
-
Spara tidigare konversationer
-
Förekomsten uppdateras baserat på information i kalendern
-
Från Office-meddelanden som visas i användarens kontaktkort
-
-
Användaren ombeds upprepade gånger att ange ett användarnamn och ett lösenord för att ansluta till Exchange.
Dessutom kan användaren få ett av följande felmeddelanden:
Lync kan inte ansluta till Exchange-servern. Lync försöker att försöka ansluta igen. Historik, voice mail och Outlook-relaterade funktioner inaktiveras.
Det går inte att ansluta till Exchange Web Services för att hämta kalender och Out of Office Information.
Lync är i färd att fastställa platsen för Exchange Web Services. Den här processen kan ta några minuter.
Lync har anslutningsproblem med Exchange-servern. Lync försöker reparera anslutningen förrän det har återställts. Historik, voice mail och Outlook-relaterade funktionerna kan vara otillgänglig eller inaktuell tills anslutningen har återupprättats.
Orsak
Det här problemet uppstår om en eller flera av följande villkor är uppfyllda:
-
Integration med Microsoft Exchange Server eller Outlook inaktiveras.
-
Exchange är felaktigt.
-
Tjänsten Exchange Web Services (EWS) inte är aktiverat.
-
Brandvägg eller proxyserver blockerar trafik som behövs.
-
Lync-klienten inte kan identifiera rätt autodiscover-information.
Lösning
Lös problemet så här:
-
Kontrollera att Lync-klienten har den senaste uppdateringen. Om du vill göra detta finns i Skype för Business hämtar och uppdaterar.
-
Kontrollera att Lync-klienten är konfigurerad för Exchange- eller Outlook-integration:
-
Leta upp Lync klienten > Alternativ > personlig.
-
Kontrollera att Microsoft Exchange eller Microsoft Outlook är markerad med önskade funktioner under Personlig informationshanterare:
Obs! Om dessa alternativ inte är tillgängliga kan de vara begränsad av en grupprincip-inställningen eller Klientprincipen som tillämpas på Lync-användare.
-
-
Validera Exchange autentiseringsuppgifter genom att logga in på Outlook Web Access.
-
Kontrollera att EWS är aktiverat för användaren. Genom för att köra följande kommando i Exchange med hjälp av Remote PowerShell:Get-casmailbox <smtp> | fl EWSEnabled Om värdet för attributet EWSEnabled anges till FALSE, misslyckas Lync/Skye för Business integration.
-
Kontrollera att det finns ingen proxyserver eller brandvägg som blockerar trafik. Portar 443 för Exchange-miljön måste vara öppen i brandväggen och proxyservrar att Exchange-trafik passerar fritt.
-
Identifiera eventuella problem i EWS som upplevs i Outlook (ledig/upptagen eller frånvarande).
-
Kontrollera att URL EWS Lync-klienten är korrekt. Gör så här:
-
Håll ned Ctrl, högerklicka på ikonen Lync i meddelandefält och klicka sedan på Konfigurationsinformation. Leta efter inställningen EWS i EWS externa URL -fältet.
-
Ändra det värde som du hittade i EWS extern URL -inställningen så att den slutar med "Exchange.asmx". Till exempel:
Standard EWS extern URL: https://mail.outlook.com/EWS/Exchange.asmx/WSSecurity
Ändrade EWS extern URL: https://mail.outlook.com/EWS/Exchange.asmx
Obs! Om det inte finns något värde i EWS intern eller extern EWS-URL, gå till steg 8. -
Ange ändrade EWS externa URL-adressen i en webbläsare och ange Exchange autentiseringsuppgifter om du uppmanas att göra detta. Du bör få ett XML-svar (i Exchange Server 2010) eller en sida (i Exchange Server 2013).
Om sidan inte visas är troligen ett nätverk eller DNS-problem som förhindrar att upplösning av URL och nätverk team bör vara ilagt.
-
-
Om EWS extern URL och EWS Intern URL är tomt, är det troligt att processen automatisk upptäckt inte fungerar.
Lync/Skype för Business-klienter använda inte tjänsten anslutning punkt (SCP) för att bestämma autodiscover URL. I stället använder de DNS-poster. De basera denna åtgärd på användarens domänsuffix för attributet WindowsEmailAddress eller e-post i Active Directory.
Minst en av följande DNS-poster måste fastställas i Exchange-miljö:-
https://<SMTP-Domain>/autodiscover/autodiscover.xml
-
https://autodiscover.<SMTP-Domain>/autodiscover/autodiscover.xml
-
http://autodiscover.<SMTP-Domain>/autodiscover/autodiscover.xml
-
_autodiscover._tcp. <SMTP-domän> (SRV-posten)
Testa om användarens dator kan åtgärda dessa URL: er med försöker en ping eller hitta URL i en webbläsare. En lyckad svar ska visa ett XML-svar med felkod 600.
Om URL: er inte är fortfarande visas när du gör detta, detta är troligen ett nätverksproblem med och nätverk team bör användas för att undersöka. -
-
Samla in Lync-loggar, spåra Fiddler och konfigurationen information utdata från steg 7A och följ eskalering instruktionerna i följande artikel i Knowledge Base om problemet kvarstår:
2649420 felsökning av grunderna för Lync Online i Office 365 dedikerad