Logga in med Microsoft
Logga in eller skapa ett konto.
Hej,
Välj ett annat konto.
Du har flera konton
Välj det konto som du vill logga in med.

Microsoft Business Solutions-Navision 4.0 och Microsoft Navision 4.0 ingår nu i Microsoft Dynamics NAV 4.0. Alla hänvisningar till Microsoft Business Solutions-Navision eller Microsoft Navision 4.0 gäller Microsoft Dynamics NAV.

Den här artikeln gäller för Microsoft Dynamics NAV för alla länder och språkversioner.

Symptom

Totalsummor för Index fältet teknik (SIFT) som visas i FlowFields beräknas felaktigt när du tar bort SIFT-posterna i Microsoft SQL Server Option for Microsoft Dynamics NAV 4.0.

Obs! Exempel på FlowFields är fältet lager i dialogrutan Artikelkortet och fältet NettoförändringKontoplan i dialogrutan.När problemet uppstår visas FlowFields felaktigt belopp. Om du klickar på listpilen i fälten visas rätt belopp i de underliggande transaktionerna.

Orsak

Det här problemet kan uppstå om du tar bort en tom SIFT-post eller om du tar bort flera tom SIFT-poster. En tom SIFT-post är en post där alla belopp är lika med noll. Uppdateringen avbryts när Microsoft Dynamics NAV senare försök att uppdatera en SIFT-post har tagits bort. Därför blir SIFT-totalt felaktigt.

Lösning

Information om snabbkorrigeringen

En snabbkorrigering är nu tillgänglig från Microsoft. Snabbkorrigeringen korrigerar det problem som beskrivs i denna artikel. Använd den bara för system där just detta problem.

Om du vill lösa problemet omedelbart kontaktar du teknisk Support för Microsoft Dynamics och relaterade produkter för att få snabbkorrigeringen. Du kan logga in på Microsoft Dynamics-webbplatsen och skapa en ny supportbegäran. Besök följande Microsoft-webbplats om du vill göra detta :

https://mbs.microsoft.com/support/newstart.aspxDu kan även kontakta teknisk Support för Microsoft Dynamics och relaterade produkter på telefon (888) 477-7877.

Obs! I särskilda fall, de avgifter som är normalt för support vara avgiftsfri om en supporttekniker för Microsoft Dynamics och relaterade produkter som bestämmer att en särskild uppdatering kan lösa ditt problem. De vanliga supportkostnaderna gäller för eventuella ytterligare supportfrågor och problem som inte berör den särskilda uppdateringen.



Hur du hämtar snabbkorrigeringen Microsoft Dynamics NAV eller uppdatera filer

När du begär en snabbkorrigering för Microsoft Dynamics NAV eller en uppdateringsfil från teknisk Support för Microsoft Dynamics kommer en hyperlänk att skickas till dig i ett e-postmeddelande.


E-postmeddelandet innehåller en hyperlänk och ett lösenord. Du kan använda hyperlänken för att hämta snabbkorrigeringen Microsoft Dynamics NAV eller uppdateringsfilerna. När du klickar på hyperlänken öppnas dialogrutan Filhämtning – säkerhetsvarning . Du uppmanas sedan att köra, spara eller avbryta hämtningen.


Om du klickar på Körbörjar filerna hämtning och extrahering av. Du måste ange en mapp för de nya filerna och ange lösenordet.


Om du klickar på Sparamåste du ange en sökväg för att spara den komprimerade filen. När du öppnar den fil som du sparade, uppmanas att ange en sökväg för filerna. Sedan måste du ange det lösenord som anges i e-postmeddelandet.


Om du klickar på Avbrytavbryts hämtningen.

Hur du installerar en snabbkorrigering för Microsoft Dynamics NAV eller en uppdateringsfil

Snabbkorrigeringar för Microsoft Dynamics NAV och uppdateringar görs tillgängliga som enskilda filer. Om du vill installera en snabbkorrigering för Microsoft Dynamics NAV eller uppdatering, använda snabbkorrigeringen eller uppdateringsfilerna för att ersätta de befintliga filerna i Microsoft Dynamics NAV-installation. Gör så här:

  1. Använda snabbkorrigeringen eller uppdateringsfilerna för att ersätta följande filer i Microsoft Dynamics NAV-klientinstallationen.

    Filnamn

    Filversion

    Storlek

    Datum

    Tid

    Plattform

    Dbm.dll

    4.0.3.24843

    345,552

    01-Jul-2007

    21:32

    x86

    Fin.exe

    4.0.3.24843

    8,119,760

    01-Jul-2007

    21:32

    x86

    Fin.exe.manifest

    Ej tillämplig

    711

    01-Jul-2007

    10:24

    Ej tillämplig

    Finhlink.exe

    4.0.3.24843

    120,272

    01-Jul-2007

    21:32

    x86

    Finsql.exe

    4.0.3.24843

    8,168,912

    01-Jul-2007

    21:32

    x86

    Finsql.exe.manifest

    Ej tillämplig

    714

    14-Dec-2006

    16:41

    Ej tillämplig

    Nc_netb.dll

    4.0.3.24843

    79,312

    01-Jul-2007

    21:31

    x86

    Nc_tcp.dll

    4.0.3.24843

    83,408

    01-Jul-2007

    21:31

    x86

    Nc_tcps.dll

    4.0.3.24843

    91,600

    01-Jul-2007

    21:32

    x86

    Ndbcs.dll

    4.0.3.24843

    1,086,928

    01-Jul-2007

    21:32

    x86

    Slave.exe

    4.0.3.24843

    95,696

    01-Jul-2007

    21:32

    x86

    Obs! Microsoft Dynamics NAV-klienten installeras normalt i följande mapp:

    C:\Program Files\Microsoft Business Solutions-Navision\Client\Gör så här om du vill ersätta de befintliga filerna:

    1. Stäng Microsoft Dynamics NAV.

    2. Leta upp installationsmappen för Microsoft Dynamics NAV-klienten.

    3. Kopiera de filer som du har hämtat.

    4. Klistra in som du hämtade filer i installationsmappen för Microsoft Dynamics NAV-klienten.

    5. I dialogrutan Bekräfta ersättning av fil klickar du på Ja om du vill skriva över filer i installationsmappen.

    6. Om snabbkorrigeringen eller uppdateringen innehåller översatta versioner av filen fin.stx eller fin.etx-fil, måste du ersätta filen fin.stx eller filen fin.etx som finns i mapparna specifikt språk i installationsmappen.

      Så här byter du ut filen fin.stx eller fin.etx-fil.

      Obs! I följande exempel refererar till en tysk installation.

      1. Kopiera alla W1 fin.stx fil eller filen fin.etx till följande mapp:

        C:\Program Files\Microsoft Business Solutions-Navision\Client\

      2. Kopiera alla filen fin.stx eller filen fin.etx i mappen SVE i följande mapp:

        C:\Program Files\Microsoft Business Solutions-Navision\Client\ENU\

      3. Kopiera alla filen fin.stx eller filen fin.etx från mappen DEU till följande mapp:

        C:\Program Files\Microsoft Business Solutions-Navision\Client\DEU\I vissa fall konvertera de nya klienten körbara filerna i databasformat. Därför måste du uppdatera alla klienter. Du måste uppdatera serverinstallationen för egna alternativ.

  2. Om du har Microsoft Dynamics NAV Application Server Ersätt följande filer i Microsoft Dynamics NAV Application Server-installationen.

    Filnamn

    Filversion

    Storlek

    Datum

    Tid

    Plattform

    Dbm.dll

    4.0.3.24843

    345,552

    01-Jul-2007

    21:32

    x86

    Nas.exe

    4.0.3.24843

    1,422,800

    01-Jul-2007

    21:32

    x86

    Nassql.exe

    4.0.3.24843

    1,463,760

    01-Jul-2007

    21:32

    x86

    Ndbcs.dll

    4.0.3.24843

    1,086,928

    01-Jul-2007

    21:32

    x86

    Slave.exe

    4.0.3.24843

    95,696

    01-Jul-2007

    21:32

    x86

    Gör så här om du vill ersätta de befintliga filerna:

    1. Stoppa Microsoft Dynamics NAV Application Server.

    2. Leta reda på Microsoft Dynamics NAV Application Server installationsmapp. Microsoft Dynamics NAV Application Server installeras normalt i följande mapp:

      C:\Program Files\Microsoft Business Solutions Navision\Application Server\

    3. Kopiera de filer som du har hämtat.

    4. Klistra in filerna som du har hämtat i installationskatalogen för Microsoft Dynamics NAV Application Server.

    5. Klicka på Ja om du vill skriva över filer i katalogen.

    6. Starta Microsoft Dynamics NAV Application Server.

  3. Om du har Microsoft Dynamics NAV ODBC-drivrutin installerad Ersätt följande filer i Microsoft Dynamics NAV ODBC-drivrutinsinstallationen.

    Filnamn

    Filversion

    Storlek

    Datum

    Tid

    Plattform

    Cfront.dll

    4.0.3.24843

    873,936

    01-Jul-2007

    21:32

    x86

    Dbm.dll

    4.0.3.24843

    345,552

    01-Jul-2007

    21:32

    x86

    Nc_netb.dll

    4.0.3.24843

    79,312

    01-Jul-2007

    21:31

    x86

    Nc_tcp.dll

    4.0.3.24843

    83,408

    01-Jul-2007

    21:31

    x86

    Nc_tcps.dll

    4.0.3.24843

    91,600

    01-Jul-2007

    21:32

    x86

    Nodbc.dll

    4.0.3.24843

    1,227,728

    01-Jul-2007

    21:32

    x86

    Nodbccfg.cfg

    4.0.3.24843

    446,464

    01-Jul-2007

    11:25

    Ej tillämplig

    Nodbccfg.hlp

    Ej tillämplig

    12,940

    14-Dec-2006

    16:42

    Ej tillämplig

    Nodbccfg.xml

    Ej tillämplig

    2,360

    14-Dec-2006

    16:42

    Ej tillämplig

    Slave.exe

    4.0.3.24843

    95,696

    01-Jul-2007

    21:32

    x86

    Gör så här om du vill ersätta de befintliga filerna:

    1. Hitta installationskatalogen för Microsoft Dynamics NAV ODBC-drivrutinen. Microsoft Dynamics NAV ODBC-drivrutinen installeras normalt i följande mapp:

      C:\Program Files\Common Files\Navision\NODBC\

    2. Kopiera de filer som du har hämtat.

    3. Klistra in filerna som du har hämtat i installationskatalogen för Microsoft Dynamics NAV ODBC-drivrutinen.

    4. Klicka på Ja om du vill skriva över filer i katalogen.

Temporär lösning

Undvik det här problemet genom att inaktivera egenskapen MaintainSIFTIndex för nycklar i tabellen påverkas. Aktivera sedan egenskapen MaintainSIFTIndex för nycklarna. SIFT-tabell kommer nu att återskapas med hjälp av rätt belopp.

Status

Microsoft har bekräftat att detta är ett programfel i Microsoft-produkterna som nämns i avsnittet "Gäller".

Mer Information

Använd någon av följande metoder om du vill ta bort tom SIFT-poster.

Metod 1

  1. Peka på databasArkiv -menyn i Microsoft SQL Server Option for Microsoft Dynamics NAV och klicka sedan på Information.

  2. Klicka på tabeller. Klicka på Optimera.

Metod 2

Använd externa SQL-skript.

Referenser

För mer information klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:

824684 beskrivning av standardterminologin som används för att beskriva Microsoft-programuppdateringar

Behöver du mer hjälp?

Vill du ha fler alternativ?

Utforska prenumerationsförmåner, bläddra bland utbildningskurser, lär dig hur du skyddar din enhet med mera.

Communities hjälper dig att ställa och svara på frågor, ge feedback och få råd från experter med rika kunskaper.

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?
Genom att trycka på skicka, kommer din feedback att användas för att förbättra Microsofts produkter och tjänster. IT-administratören kan samla in denna data. Sekretesspolicy.

Tack för din feedback!

×