Увійти за допомогою облікового запису Microsoft
Увійдіть або створіть обліковий запис.
Привіт,
Select a different account.
У вас кілька облікових записів
Виберіть обліковий запис, за допомогою якого потрібно ввійти.

Ви створили список контактів та інших даних, які потрібно використовувати для злиття у Word. Якщо джерелом даних слугує наявна електронна таблиця Excel, вам достатньо просто підготувати дані до злиття. Але якщо джерело даних – це файл даних із роздільником табуляції (.txt) або файл даних із роздільником-комами (.csv), спочатку потрібно імпортувати дані до Excel, а потім підготувати їх до злиття.

Крок 1. Настроювання джерела даних в Excel

Якщо електронна таблиця використовується Excel як джерело даних для злиття в Word, пропустіть цей крок. Якщо джерело даних – це файл .txt або .csv,скористайтеся майстром імпорту тексту, щоб налаштувати дані в Excel.

Імпортувавши TXT- або CSV-файл, перейдіть до кроку 2.

  1. Відкрийте програму Excel.

  2. Виберіть дані >з тексту/CSV.

    Selecting Text/CSV from the Data tab

  3. Виберіть .txt або .csv файл, а потім натисніть кнопку Імпортувати.

  4. У вікні попереднього перегляду виберіть Перетворення даних.

  5. Виберіть стовпець ZIP, Postal Code (Поштовий індекс) або інший стовпець, який потрібно відформатувати.

  6. У меню Перетворення > тип даних: і виберіть Текст.

    Вікно Power Query з вибраним пунктом "Текст"

  7. Виберіть Замінити поточне.

  8. За потреби повторіть кроки 5–7.

  9. Натисніть кнопку Закрити & завантажити.

  10. На вкладці > Зберегти як і збережіть файл з іншим іменем.

  1. Відкрийте програму Excel.

  2. Excel 2016    На вкладці Дані > Отримати зовнішні дані > з тексту.

    На вкладці "Дані" виділено параметр "З тексту"

  3. Виберіть .txt або .csv файл, а потім натисніть кнопку Імпортувати.

  4. У майстрі імпорту тексту в області Формат вихідних даних виберіть параметр з роздільниками.

    Отримання зовнішніх даних із тексту в Excel, майстер імпорту тексту, крок 1 із 3.

  5. Установіть прапорець Дані із заголовками над областю попереднього перегляду, якщо файл містить заголовки, а потім натисніть кнопку Далі.

  6. В області Роздільники встановіть прапорець, який відповідає роздільнику у даних (наприклад, "Табуляції" або "Кома"), і натисніть кнопку Далі.

    У майстрі імпорту тексту виділено розділ "Роздільники".

  7. В області Зразок аналізу даних виберіть стовпець, що містить поштові індекси, а потім у списку Формат даних стовпця виберіть параметр текстовий.

    У майстрі імпорту тексту в розділі "Формат даних стовпця" виділено параметр "текстовий".

    Примітка.: Щоразу, коли ви застосовуєте до стовпця формат ("загальний", "текстовий" або "дата"), у його заголовку відображається назва формату.

  8. За потреби повторіть крок 7, вибравши стовпець, який необхідно змінити, і потрібний формат даних.

  9. Натисніть кнопку Готово.

  10. У діалоговому вікні Імпорт даних прийміть стандартне значення (Наявний аркуш) і координати клітинки, а потім натисніть кнопку OK.

    У діалоговому вікні "Імпорт даних" виберіть, куди слід помістити дані – на наявний аркуш (за замовчуванням) чи на новий.

    Увага!: У діалоговому вікні Імпорт даних указано координати поточної виділеної клітинки. Дані імпортуються, починаючи з неї.

  11. Збережіть електронну таблицю з новим ім’ям файлу.

Крок 2. Підготовка джерела даних

У джерелі даних Excel, яке потрібно використовувати як список розсилки для злиття у Word, перевірте правильність форматування стовпців із числовими даними. Застосуйте до стовпців із числами відповідний формат, наприклад "грошовий".

Пам’ятайте: якщо вибрати відсотковий формат, значення клітинок помножиться на 100. Щоб уникнути цього, відформатуйте стовпець із відсотковими значеннями як текст.

Щоб зберегти дані під час злиття, потрібно відформатувати поштові індекси як текст. Якщо не зроблено під час імпорту, відформатуйте його зараз. Початкові нулі, наприклад в індексі 00399, зникнуть під час злиття, якщо значення не відформатовано як текст.

  1. Виберіть стовпець, який містить поштові індекси, поштові індекси або інші дані, які потрібно відформатувати.

  2. Перейдіть на вкладку Основне, у групі Число клацніть стрілку розкривного списку Числовий формат і виберіть потрібний параметр у списку (наприклад, Текст).

    У програмі Excel на вкладці "Основне" в групі "Число" клацніть стрілку вниз у списку з надписом "Загальний" і виберіть числовий формат.

Не забудьте додати відповідний символ перед полем злиття або після нього. Ось так, наприклад, виглядатимуть грошові й відсоткові значення, якщо не додати символи:

Результат злиття: "ваш внесок у розмірі 50,00" і "запропонувати вам знижку в розмірі 20".

Якщо додати символи, значення чисел стануть зрозумілішими.

Результат злиття: "ваш внесок у розмірі $50,00" і "запропонувати вам знижку в розмірі 20 %".

У документі злиття можна додати символи до та після поля злиття таким чином:

Зразок документа злиття, у якому полю "Пожертва" передує знак долара, а за полем "Відсоток" слідує знак відсотка.

Див. також

Щоб виконати злиття Word, потрібно настроїти й підготувати джерело даних. Ви можете використовувати наявне джерело Excel або створити нове, імпортувавчи файл даних із роздільником-комами (.txt) або файл даних із роздільником-комами (.csv). Після настроювання та підготовки джерела даних злиття можна виконати за допомогою Динамічний обмін даними (DDE) за допомогою майстра злиття покрокових інструкцій або за допомогою методу злиття вручну.

Якщо для злиття не використовується наявне джерело Excel даних, можна використати список контактів або адресну книгу у файлі .txt або.csv. Майстер імпорту тексту допоможе отримати дані, збережені у файлі .txt або .csv, Excel.

  1. Відкрийте програму Excel.

  2. На вкладці Дані натисніть кнопку З текстового файлу або файлу CSV.

  3. Виберіть .txt або .csv файл, а потім натисніть кнопку Імпортувати.

  4. У майстрі імпорту тексту в області Формат вихідних даних виберіть параметр з роздільниками.

    Отримання зовнішніх даних із тексту в Excel, майстер імпорту тексту, крок 1 із 3.

  5. Установіть прапорець Мої дані із заголовками над областю Попередній перегляд, якщо імпортований файл містить заголовки, і натисніть кнопку Далі.

  6. В області Роздільники встановіть прапорець, що відповідає роздільнику у ваших даних (наприклад, "знак табуляції" або "кома"), і натисніть кнопку Далі.

    У майстрі імпорту тексту виділено розділ "Роздільники".

    Порада.: В області Зразок аналізу даних показано, як виглядатимуть результати в таблиці.

  7. В області Зразок аналізу даних виберіть стовпець, що містить поштові індекси, а потім у списку Формат даних стовпця виберіть параметр текстовий.

    У майстрі імпорту тексту в розділі "Формат даних стовпця" виділено параметр "текстовий".

    Примітки.: 

    • Доступні формати: Загальний, Тексті Дата. Щоразу, коли до стовпця застосовано формат даних, у його заголовку відображатиметься ім'я формату.

    • Наприклад, стовпець із числовими даними, наприклад відсотком або значенням грошової одиниці, можна відформатувати лише після імпорту файлу. Докладні відомості див. в підрозділі Excel "Format numerical data in #x0" (Формат числових даних у наступному розділі).

  8. За потреби повторіть крок 7, вибравши стовпець, який необхідно змінити, і потрібний формат даних.

  9. Натисніть кнопку Готово.

  10. У діалоговому вікні Імпорт даних прийміть стандартне значення (Наявний аркуш) і координати клітинки, а потім натисніть кнопку OK.

    У діалоговому вікні "Імпорт даних" виберіть, куди слід помістити дані – на наявний аркуш (за замовчуванням) чи на новий.

    Увага!: У діалоговому вікні Імпорт даних указано координати поточної виділеної клітинки. Дані імпортуються, починаючи з неї.

  11. Завершивши, збережіть джерело даних із новим іменем файлу.

Форматування числових даних у Excel

Відформатуйте всі числові дані, як-от відсотки або грошові значення, у будь-якому новому або наявному джерелі даних Excel які використовуватимуться під час Word злиття. Щоб зберегти числові дані, відформатовані як відсоток або грошові одиниці під час злиття, дотримуйтеся вказівок у розділі "Крок 2. Використання динамічних даних Exchange (DDE) для злиття".

У джерелі даних Excel, яке потрібно використовувати як список розсилки для злиття у Word, перевірте правильність форматування стовпців із числовими даними. Застосуйте до стовпців із числами відповідний формат, наприклад "грошовий".

  1. Відкрийте джерело Excel даних.

  2. Виберіть стовпець, який потрібно відформатувати.

  3. На вкладці Основне в групі Число клацніть стрілку вниз у списку Числовий формат (у ньому відображається пункт "Загальний") і виберіть потрібний формат.

    У програмі Excel на вкладці "Основне" в групі "Число" клацніть стрілку вниз у списку з надписом "Загальний" і виберіть числовий формат.

  4. За потреби повторіть кроки 2 та 3.

  5. Коли все буде готово, натисніть кнопку Зберегти.

Якщо джерело даних Excel містить форматовані числа, наприклад відсотки та грошові значення, деякі числові дані можуть не зберегти форматування під час злиття. Ви отримаєте потрібні результати злиття та зможете зберегти формат числових даних у Excel за допомогою DDE.

Excel у форматі даних порівняно з полем об'єднання за допомогою динамічних даних Exchange

Примітка.: Якщо ви вирішите не використовувати DDE, дотримуйтеся вказівок у цій статтях.

  1. Відкрийте Word виберіть Файл > Параметри > Додатково.

  2. У розділіЗагальні встановіть прапорець Підтверджувати перетворення формату файлу під час відкриття.

    Параметр ''Підтверджувати перетворення формату файлу під час відкриття''

  3. Натисніть OK.

  4. На вкладці Розсилки натисніть кнопку Розпочати злиття > майстер злиття поетапно.

    У програмі Word на вкладці "Розсилки" натисніть кнопку "Розпочати злиття", а потім виберіть "Майстер злиття з кроками"

  5. В області Злиття в розділі Вибір одержувачів виберітьпункт Використовувати наявний список.

    У програмі Word область завдань Злиття, яка відкривається, якщо вибрати майстер злиття покрокових інструкцій у групі Злиття

  6. У розділі Використання наявногосписку натисніть кнопкуОгляд і відкрийте форматовану електронну таблицю.

  7. У діалоговому вікні Підтвердження джерела даних установіть прапорець Показати все та виберіть MS Excel аркушах за допомогою DDE (*.xls) > OK.

    Діалогове вікно підтвердження джерела даних

  8. У діалоговому Microsoft Excel натисніть кнопку Уся електронна таблиця >OK.

    Діалогове вікно ''Microsoft Excel'' у програмі Word

  9. Коли відкриється діалогове вікно Одержувачі злиття, натисніть кнопку OK.

    Діалогове вікно "Одержувачі злиття", у Excel електронної таблиці, яка використовується як джерело даних для списку розсилки

  10. Продовжуйте об'єднаннялиста,повідомлення електронної пошти, етикетки або конверта.

Порада.: Ви можете запобігти появи Word щоразу під час відкриття файлу даних. Підключившись до списку розсилки, перейдіть до вкладки Параметри > >Додатково. У розділіЗагальні зніміть прапорець Підтверджувати перетворення формату файлу під час відкриття.

Якщо список контактів створено в електронній таблиці Excel, важливо відформатувати поштові індекси як текст, щоб не втратити дані. Якщо ви імпортуєте контакти з текстового файлу (.txt) або файлу даних із роздільником-комами (.csv), майстер імпорту тексту може допомогти вам імпортувати й відформатувати дані.

Крок 1. Настроювання джерела даних у Excel

Якщо електронна таблиця Excel як джерело даних для злиття у Word, перейдіть до кроку 2 в цій статті. Якщо джерело даних – це файл .txt або файл .csv, який містить контакти Gmail, наприклад, скористайтеся майстром імпорту тексту, щоб налаштувати дані вExcel.

  1. Відкрийте Excel і на вкладці Дані натисніть кнопку З тексту.

    On the Data tab, select From Text

  2. Виберіть .csv або .txt та натисніть кнопку Отримати дані.

  3. У майстрі імпорту текстунатисніть кнопку Далі.

  4. У розділі Роздільникивстановіть прапорець, який відповідає роздільнику для кожного елемента даних (наприклад, табуляції або коми). Потім натисніть кнопку Далі.

    Порада.: В області Попередній перегляд вибраних даних можна переглянути результат у форматі таблиці.


    Step 2 of the Text Import Wizard
     

  5. У поданні Попередній перегляд вибранихданих виберіть стовпець, який містить поштові індекси. Потім у розділі Column (Формат даних C)виберіть пункт Text (Текст).

    Text Import Wizard step 3
     

  6. За потреби повторіть крок 5, вибравши стовпець, який потрібно змінити, і формат даних, які потрібно застосувати.

    Примітка.: Щоразу, коли до стовпця застосовано формат даних, у його заголовку відображатиметься ім'я формату.

  7. Натисніть кнопку Готово.

  8. У діалоговому вікні Імпорт даних укажіть, куди Excel дані, а потім натисніть кнопку OK.

    Примітка.: Збережіть електронну таблицю з новим ім’ям файлу.

Крок 2. Форматування числових даних в електронній Excel таблиці

Щоб переконатися, що поштовий індекс пройшов злиття, не втрачаючи нуль, відформатуйте стовпець, який містить ці коди, як текст.

  1. Відкрийте електронну таблицю та виберіть стовпець, який містить поштові індекси.

  2. На вкладці Основне в полі Формат натисніть кнопку Текст.

    On the Home tab, in the Format box, select Text

Тепер ці дані можна використовувати для злиття.

Потрібна додаткова довідка?

Отримуйте нові функції раніше за інших
Приєднатися до оцінювачів Microsoft Office

Ця інформація корисна?

Наскільки ви задоволені якістю мови?
Що вплинуло на ваші враження?

Дякуємо за відгук!

×