Bỏ qua để tới nội dung chính
Đăng nhập với Microsoft
Đăng nhập hoặc tạo một tài khoản.
Xin chào,
Chọn một tài khoản khác.
Bạn có nhiều tài khoản
Chọn tài khoản bạn muốn đăng nhập.

Triệu chứng

Khi bạn cố gắng truy cập vào Web site Windows Update hoặc Web site Microsoft Update, bạn có thể nhận được thông báo lỗi tương tự như sau:

Số lỗi: 0x8DDD0002To cài đặt mục từ Windows Update, bạn phải đăng nhập như quản trị viên hoặc thành viên của nhóm quản trị viên. Nếu máy tính của bạn được kết nối mạng, cài đặt chính sách mạng cũng có thể ngăn bạn hoàn thành quy trình này.

Bạn nhận được thông báo này ngay cả khi bạn đã đăng nhập là quản trị viên hoặc thành viên của nhóm quản trị viên. Lưu ý Để biết thêm thông tin về các trang web Windows Update và trang web Microsoft Update, hãy xem phần "Thông tin".

Nguyên nhân

Hiện tượng này có thể xảy ra vì bất kỳ lý do sau:

  1. Bạn không được đăng nhập như là một người thuộc nhóm quản trị viên cục bộ.

  2. Bạn không có quyền cho khoá đăng ký cụ thể hoặc thư mục.

  3. Hệ điều hành không thể đọc dữ liệu trong thư mục %Systemroot%\System32\Catroot2.

Giải pháp

Quan trọng Phần, phương pháp hoặc tác vụ này chứa các bước chỉ dẫn bạn cách sửa đổi sổ đăng ký. Tuy nhiên, sự cố nghiêm trọng có thể xảy ra nếu bạn sửa đổi sổ đăng ký không đúng. Vì vậy, hãy đảm bảo bạn làm theo các bước sau đây một cách cẩn thận. Để bảo vệ tốt hơn, sao lưu sổ đăng ký trước khi bạn sửa đổi. Sau đó, bạn có thể khôi phục sổ đăng ký nếu xảy ra sự cố. Để biết thêm thông tin về cách sao lưu và khôi phục sổ đăng ký, hãy bấm vào số bài viết sau để xem bài viết trong Cơ sở Kiến thức Microsoft:

322756 Cách sao lưu và khôi phục sổ đăng ký trong WindowsĐể giải quyết vấn đề này, sử dụng một trong các phương pháp sau. Nếu phương pháp 1 không giải quyết sự cố, hãy sử dụng phương pháp 2.

  • Phương pháp 1Xác minh rằng bạn được đăng nhập như là một người thuộc nhóm quản trị viên cục bộ. Để thực hiện việc này, bấm bắt đầu, bấm chạy, loạinusrmgr.cplvà sau đó bấm OK để mở cửa sổ tài khoản người dùng . Nếu bạn là một phần của miền trong mạng, hãy làm theo các bước sau:

    1. Trong cửa sổ Tài khoản người dùng , bấm để chọn tài khoản của bạn từ danh sách, và sau đó bấm thuộc tính.

    2. Trên tab Nhóm thành viên , xác minh rằng bạn đang ở trong nhóm quản trị viên.

    Nếu bạn không phải là một phần của mạng vùng, cửa sổ Tài khoản người dùng , bấm vào tài khoản của bạn và sau đó kiểm tra Quản trị viên máy tính sẽ xuất hiện dưới tên tài khoản. Sau khi bạn đăng nhập là quản trị viên, cố gắng truy cập vào Web site Windows Update hoặc Microsoft Update Web site một lần nữa. Nếu vấn đề được giải quyết, tiếp tục khắc phục sự cố.

  • Phương pháp 2Xoá tệp Internet tạm thời. Để thực hiện việc này, hãy làm theo các bước sau:

    1. Mở cửa sổ Internet Explorer, bấm vào Công cụ và sau đó bấm Tùy chọn Internet.

    2. Trong cửa sổ Internet Options , bấm vào tab chung , trong tệp Internet tạm thời, bấm Xoá tệp, và sau đó bấm OK.

    Cố gắng truy cập vào Web site Windows Update hoặc Microsoft Update Web site một lần nữa. Nếu vấn đề được giải quyết, tiếp tục khắc phục sự cố.

  • Phương thức 3Kiểm tra quyền trên các khoá đăng ký được sử dụng máy khách Windows Update và Microsoft Update cha.

    1. Bấm Bắt đầu, bấm Chạy, nhập regedit, rồi bấm OK.

    2. Định vị và chọn khoá đăng ký sau:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate

    3. Trên menu Chỉnh sửa, bấm Quyền, bấm Thêm, sau đó gõ tất cả mọi người trong hộp thoại xuất hiện.

    4. Nhấp Kiểm tra tên, và sau đó bấm OK.

    5. Chọn tất cả mọi người trong danh sách nhóm hoặc tên người dùng .

    6. Dưới quyền cho mọi người, bấm để chọn hộp kiểm Kiểm soát hoàn toàn trong cột cho phép . Lưu ý rằng hộp kiểm cho phép cột đọc bây giờ cũng chọn.

    7. Chọn mỗi người dùng, trong nhóm hoặc tên người dùng và sau đó kiểm tra xem hộp kiểm không được chọn trong cột từ chối . Bấm để bỏ chọn hộp kiểm bất kỳ được chọn trong cột từ chối .

    8. Bấm nâng cao, bấm để chọn hộp kiểm thay thế các mục cấp quyền trên tất cả các đối tượng con , và sau đó bấm OK.

    9. Bấm nếu bạn được nhắc xác nhận, rồi bấm OK để đóng hộp thoại.

    Cố gắng truy cập vào Web site Windows Update hoặc Microsoft Update Web site một lần nữa. Nếu vấn đề được giải quyết, tiếp tục khắc phục sự cố.

  • Phương thức 4Kiểm tra quyền cho bạn về cấu trúc thư mục được sử dụng bởi máy khách Windows Update hoặc Microsoft Update cha.

    1. Bấm bắt đầu, bấm chạy, gõ explorer, và sau đó bấm OK.

    2. Mở rộng máy tính của tôi, mở rộng Ổ đĩa hệ thống, và sau đó mở rộng WINDOWS.

    3. Bấm chuột phải vào phân phối phần mềm, và sau đó bấm thuộc tính.

    4. Trong cửa sổ Thuộc tính phân phối phần mềm , nhấp vào tab bảo mật , và sau đó kiểm tra xem liệu bạn có trong danh sách nhóm hoặc tên người dùng .

    5. Trong danh sách nhóm hoặc tên người dùng , hãy chọn tất cả mọi người. Dưới quyền cho mọi người, bấm để chọn hộp kiểm Kiểm soát hoàn toàn trong cột cho phép . Lưu ý rằng hộp kiểm cho phép cột đọc bây giờ cũng chọn.

    Cố gắng truy cập vào Web site Windows Update hoặc Microsoft Update Web site một lần nữa. Nếu vấn đề được giải quyết, tiếp tục khắc phục sự cố.

  • Phương thức 5Đổi tên cặp Catroot2. Để thực hiện việc này, gõ lệnh sau tại dấu nhắc lệnh, nhấn ENTER sau mỗi dòng:

    net stop cryptsvcren %systemroot%\system32\catroot2 oldcatroot2net start cryptsvcSau đó, cố gắng truy cập Web site Windows Update hoặc Microsoft Update Web site một lần nữa. Nếu vấn đề được giải quyết, tiếp tục khắc phục sự cố.

  • Phương thức 6Đổi tên cặp phân phối phần mềm. Để thực hiện việc này, hãy làm theo các bước sau.

    1. Khởi động lại máy tính ở chế độ an toàn.

    2. Định vị và sau đó đổi tên ổ đĩa: \Windows\SoftwareDistribution thư mục SoftwareDistribution.old. Lưu ýLà trình giữ chỗ cho ổ đĩa hệ thống.

    3. Khởi động lại máy tính ở chế độ Bình thường.

Thông tin Bổ sung

Bạn phải là quản trị viên cục bộ để truy cập Web site Windows Update hoặc Microsoft Update Web site. Khi bạn đăng nhập như người quản trị không, bạn không thể truy cập vào trang Web ngay cả khi bạn sử dụng chạy để khởi động Internet Explorer trong một tài khoản quản trị viên. Sự cố này xảy ra vì các dịch vụ hệ thống có liên quan trong quá trình. Để biết thêm chi tiết, bấm vào số bài viết sau để xem bài viết trong cơ sở kiến thức Microsoft:

326686 bạn nhận được một hoặc nhiều thông báo lỗi khi quản trị viên hệ thống vô hiệu hoá Windows Update hoặc Microsoft Update

Bạn cần thêm trợ giúp?

Bạn muốn xem các tùy chọn khác?

Khám phá các lợi ích của gói đăng ký, xem qua các khóa đào tạo, tìm hiểu cách bảo mật thiết bị của bạn và hơn thế nữa.

Cộng đồng giúp bạn đặt và trả lời các câu hỏi, cung cấp phản hồi và lắng nghe ý kiến từ các chuyên gia có kiến thức phong phú.

Thông tin này có hữu ích không?

Bạn hài lòng đến đâu với chất lượng dịch thuật?
Điều gì ảnh hưởng đến trải nghiệm của bạn?
Khi nhấn gửi, phản hồi của bạn sẽ được sử dụng để cải thiện các sản phẩm và dịch vụ của Microsoft. Người quản trị CNTT của bạn sẽ có thể thu thập dữ liệu này. Điều khoản về quyền riêng tư.

Cảm ơn phản hồi của bạn!

×