Access 桌面数据库中的基本任务

应用对象
Microsoft 365 专属 Access Access 2024 Access 2021 Access 2019 Access 2016

Access 数据库可帮助存储和跟踪几乎所有类型的信息,例如库存、联系人或业务流程。 让我们演练如何创建 Access 桌面数据库,向其添加数据,然后了解自定义和使用新数据库的后续步骤。

本文内容

选择模板

Access 模板具有内置的表、查询、窗体和报表可供随时使用。 模板是启动 Access 时首先看到的内容之一,你可以联机搜索更多模板。

Access 中启动屏幕上的模板视图

  1. 在 Access 中,选择“新建文件>”。
  2. 选择桌面数据库模板,然后在“ 文件名”下输入数据库名称。 如果没有看到适合你的模板,请使用 “搜索联机模板” 框。
  3. 可以使用 Access 在 “文件名 ”框下方显示的默认位置,或选择文件夹图标以选择其中一个位置。
  4. 选择“创建”。

从模板创建 Access 桌面数据库

根据模板,可能需要执行以下操作之一才能开始:

  • 如果 Access 显示用户列表为空的 “登录 ”对话框:

    1. 选择 “新建用户”。
    2. 填写 “用户详细信息” 表单。
    3. 选择“保存并关闭”。
    4. 选择刚刚输入的用户名,然后选择“ 登录”。
  • 如果 Access 在消息栏中显示 安全警告 消息,并且你信任模板的来源,请选择“ 启用内容”。 如果数据库需要登录,请重新登录。

有关详细信息,请参阅 从模板创建 Access 桌面数据库。

从头开始创建数据库

如果没有模板满足你的需求,你可以从空白桌面数据库开始。

  1. 在 Access 中,选择 “新建>空白桌面数据库”。
  2. 在“ 文件名 ”框中键入数据库名称。
  3. 可以使用 Access 在 “文件名 ”框下方显示的默认位置,或选择文件夹图标以选择其中一个位置。
  4. 选择“创建”。

添加表格

在数据库中,您的信息存储在多个相关表中。 要创建表,请执行以下操作:

  1. 首次打开数据库时,会在“数据表”视图中看到一个可在其中添加数据的空白表。 要添加另一个表,请选择 “创建>表”。 可以在单元格) (空字段开始输入数据,也可以粘贴其他源(如 Excel 工作簿)中的数据。

  2. 若要重命名列 (字段) ,请双击列标题,然后键入新名称。

    提示

    有意义的名称可帮助您在不查看其内容的情况下了解每个字段包含的内容。

  3. 选择“ 文件>保存”。

  • 要添加更多字段,请在 “单击以添加” 列中键入。
  • 若要移动列,请单击列标题将其选中,然后将其拖动到所需的位置。 您还可以选择相邻的列并将它们一起拖动到新位置。

有关详细信息,请参阅表简介。

复制并粘贴数据

可以将数据从其他程序(如 Excel 或 Word)复制并粘贴到 Access 表中。 当数据分隔为几列时,这种方法最有效。 如果数据位于 Word 等文字处理程序中,请在复制数据之前使用标签分隔列或将数据转换为表格格式。

  1. 如果数据需要编辑,例如将全名分隔为名字和姓氏,请先在源程序中执行此操作。

  2. 按 Ctrl+C 打开源并复制数据。

  3. 在数据表视图中打开要向其添加数据的 Access 表,然后按 Ctrl+V 粘贴该表。

  4. 双击每个列标题,然后键入有意义的名称。

  5. 选择“ 文件>保存”,然后为新表命名。

    注意

    Access 根据粘贴到每列第一行的信息设置每个字段的数据类型,因此请确保以下行中的信息与第一行匹配。

可以从其他源导入数据,也可以链接到 Access 中的数据,而无需将信息从存储位置移动。 如果多个用户更新数据并且您希望确保看到的是最新版本,或者如果您想节省存储空间,则链接可能是一个不错的选择。 对于大多数格式,可以选择是链接到数据还是导入数据。 有关详细信息,请参阅 导入或链接其他 Access 数据库中的数据。

根据数据源的不同,该过程略有不同,但以下说明将帮助您入门:

  1. 在 “外部数据 ”选项卡的“ 导入 & 链接 ”组中,选择 “新数据源”,然后从列出的子菜单选项中选择要从中导入或链接到的数据格式。

    注意

    如果仍然找不到正确的格式,可能需要先将数据导出为 Access 支持的文件格式,例如分隔的文本文件。

  2. 按照 “获取外部数据 ”对话框中的说明进行操作。

链接时,某些格式以只读形式提供。 以下是可从中导入数据或链接到的外部源:

源 导入 链接
Excel 是 是, (只读)
Access 是 是
ODBC 数据库,如 SQL Server 是 是
文本或逗号分隔值 (CSV) 文件 是 是,仅 (添加新记录)
SharePoint 列表 是 是
XML 是
数据服务 是, (只读)
HTML 文档 是 是
Outlook 文件夹 是 是

有关详细信息,请参阅 导入或链接其他 Access 数据库中的数据。

使用表分析器组织数据

可以使用表分析器向导快速标识冗余数据。 然后,该向导提供了一种将数据组织到单独的表中的简单方法。 Access 会将原始表保留为备份。

  1. 打开包含要分析的表的 Access 数据库。
  2. 选择“数据库工具>”“分析表”。 该向导的前两页包含一个带有示例的简短教程。 如果看到标记为 显示简介页 的检查框,请选中它,然后选择 返回 两次以查看简介。 如果不想再次看到介绍性页面,请清除“ 显示介绍性页面?”。

有关详细信息,请参阅 使用表分析器规范化数据。

返回页首

后续步骤

设计过程的其余部分因要执行的操作而异,但您可能需要考虑创建查询、窗体、报表和宏。 这些文章可以帮助:

返回页首