使用 Excel 表格中的计算列

计算表中的Excel是高效输入公式的出色工具。 它们允许您在一个单元格中输入单个公式,然后该公式将自动自动展开到列的其余部分。 无需使用"填充"或"复制"命令。 这非常节省时间,尤其是当你有许多行时。 更改公式时也会发生同样的情况;更改也会展开到计算列的其余部分。

注意: 本文的屏幕截图取自 Excel 2016。 如果使用其他版本,视图可能会略有不同,但功能相同,除非另有说明。

创建计算列

  1. 创建表格。 如果不熟悉表Excel,可在以下页了解Excel概述

  2. 在表中插入新列。 为此,可立即在表格右侧列中键入,Excel自动扩展表格。 本示例在单元格 D1 中键入"总计",创建了一个新列。

    通过直接在现有表右侧空列中键入内容来添加新表列

    提示: 

    • 还可以从"开始"选项卡添加 表格 列。 只需单击"插入"箭头>"在左侧插入表格列"。

    • 若要从"开始"选项卡添加表格列,请单击"插入"箭头>"在左侧插入表格列"。

  3. 键入想要使用的公式,然后按Enter。

    在将自动完成以创建计算列的表格单元格中添加单个公式

    在这种情况下,我们输入 =sum (,然后选择第 1 季度和第 2 季度 列。 因此,我们Excel公式:=SUM (Table1[@[Qtr 1]:[Qtr 2]]]) 。 这称为结构化引用公式,对于表Excel唯一。 结构化引用格式允许表对每行使用相同的公式。 此Excel的常规公式是=SUM (B2:C2) ,然后需要复制或向下填充列的其余部分

    若要详细了解结构化引用,请参阅:对表使用结构化Excel引用。

  4. 按 Enter 时,该公式会自动填充到列的所有单元格中, 位于输入公式的单元格上方和下方。 每行的公式相同,但由于它是结构化引用,因此Excel内部知道哪一行。

    自动填充以在表中创建计算列的公式示例

注意: 

  • 将公式复制或填充至一个空表格列的所有单元格中也会创建计算列。

  • 如果在已包含数据的表列中键入或移动公式,则不会自动创建计算列。 但是, 将显示"自动更正选项 "按钮,提供覆盖数据的选项,以便创建计算列。

    当一个公式与其余公式不同时覆盖计算列中现有公式的选项

  • 如果输入的新公式不同于计算列中的现有公式,该列将自动更新为新公式。 可以选择撤消更新,仅保留"自动更正选项"按钮中的单个 公式。 但通常不建议这样做,因为它可能会阻止列在将来自动更新,因为它不知道在添加新行时要扩展的公式。

    输入公式后撤消计算列的选项

  • 如果在空白列的单元格中键入或复制了公式,但不想保留新的计算列,请单击"撤消 “撤消”按钮 两次。 也可以按 Ctrl + Z 两次

计算列可以包含公式与其余列不同的单元格。 这会创建一个将在表中明确标记的异常。 这样,可以轻松检测到并解决无意中不一致的问题。

表内公式错误通知不Excel一致

注意: 执行下列任一操作时,将导致计算列异常:

  • 在计算列单元格中键入数据而不是公式。

  • 在计算列单元格中键入公式,然后单击"快速访问工具栏" “撤消”按钮 "撤消编辑"。

  • 在已经包含一个或多个异常的计算列中键入一个新公式。

  • 将数据复制到与计算列公式不匹配的计算列中。

    注意: 如果复制的数据包含公式,此公式将覆盖计算列中的数据。

  • 从计算列中的一个或多个单元格中删除公式。

    注意: 未标记此异常。

  • 移动或删除计算列中某一行引用的另一个工作表区域中的某个单元格。

只有在启用了后台错误检查选项时,才显示错误通知。 如果看不到错误,请转到"文件">选项>">"启用后台错误"复选框。

  • 如果使用 2007 Excel,请单击"Office按钮 Office 2007 按钮,Excel"选项>公式"。

  • 如果使用的是 Mac,请转到菜单栏上的"Excel",然后单击"首选项">"&列表>检查"。

默认情况下,自动填充公式以在表Excel计算列的选项为打开状态。 如果不希望在表Excel公式时创建计算列,可以关闭填充公式的选项。 如果不想关闭此选项,但不想在表中操作时始终创建计算列,可以停止自动创建计算列。

  • 打开或关闭计算列

    1. “文件”选项卡上,单击“选项”

      如果使用 2007 Excel,请单击"Office按钮 Office 2007 按钮,然后单击Excel选项"。

    2. 单击“校对”。

    3. "自动更正选项"下,单击"自动更正选项"。

    4. 单击“键入时自动套用格式”选项卡。

    5. "自动工作"下,选中或清除"在表格中填充公式以创建计算列"复选框以打开或关闭此选项。

      从"文件">"选项">"校对工具>自动更正选项"中关闭计算表列>取消选中"在表格中填充公式以创建计算列"。

      提示: 输入 公式后, 还可以单击表列中显示的"自动更正选项"按钮。 单击"控件自动更正选项",然后清除"在表中填充公式以创建计算列"复选框以关闭此选项。

    如果你使用的是 Mac,请在主菜单上Excel",然后"首选项">">"表"&">自动填充公式"。

  • 停止自动创建计算列

    在表列中输入第一个公式后,单击显示的"自动更正选项"按钮,然后单击"停止自动创建计算列"。

您还可以使用数据透视表创建自定义计算字段,您可以在其中创建一个公式Excel然后将它应用到整个列。 详细了解如何 计算数据透视表中的值

需要更多帮助吗?

你始终可以在 Excel 技术社区中咨询专家或在 Answers 社区获取

另请参阅

Excel 表格概述

设置 Excel 表的格式

通过添加或删除行和列来调整表格的大小

汇总 Excel 表格中的数据

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Office Insiders

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?

Thank you for your feedback!

×