在 Power Query Excel (创建、加载或)

Power Query 提供多种创建 Power 查询和将 Power 查询加载到工作簿中的方法。 还可以在"查询选项"窗口中设置 默认查询加载 设置。   

提示      若要判断工作表中的数据是否由 Power Query 形成,请选择一个数据单元格,如果显示"查询上下文功能区"选项卡,则从 Power Query 加载数据。 

选择查询中的单元格以显示"查询"选项卡

了解你环境 Power Query 已很好地集成到 Excel 用户界面中,尤其是在导入数据、处理连接和编辑数据透视表、Excel表和命名区域时。 为了避免混淆,必须随时了解你当前处于哪个环境,Excel Power Query。

熟悉的Excel工作表、功能区和网格

Power Query 编辑器功能区和数据预览 

典型的Excel工作表 典型的 Power Query 编辑器视图

例如,在工作表中处理数据Excel与 Power Query 基本不同。 此外,在工作表中看到的已连接Excel,可能(也可能不是)让 Power Query 在后台工作以塑造数据。 只有当从 Power Query 将数据加载到工作表或数据模型时,才发生这种情况。

重命名工作表标签    建议以有意义的方式重命名工作表标签,尤其是当您有许多工作表标签时。 阐明数据工作表与从 Power Query 编辑器加载的工作表之间的差异尤为重要。 即使只有两个工作表,一个工作表包含名为Sheet1的 Excel 表,另一个工作表是导入该 Excel 表(称为Table1)创建的查询,也很容易感到困惑。 将工作表标签的默认名称更改为更有意义的名称始终是一种很好的做法。 例如,将Sheet1重命名为DataTable,将 Table1重命名为QueryTable。 现在,可以清楚地了解哪个选项卡包含数据,哪个选项卡包含查询。

可以从导入的数据创建查询,也可以创建空白查询。

基于导入的数据创建查询

这是创建查询的最常见方法。

  1. 导入一些数据。 有关详细信息,请参阅 从外部数据源导入数据

  2. 在数据中选择一个单元格,然后选择"查询>编辑"。

创建空白查询

你可能希望从头开始。 可通过两种方法执行此操作。

  • 选择"数据">"从其他>获取数据">"空白查询"。

  • 选择"数据>获取数据>启动 Power Query 编辑器"。

此时,如果了解 Power Query M 公式语言,可以手动 添加步骤和公式

或者,可以选择" 开始 ",然后在"新建查询" 组中选择一个 命令。 执行下列操作之一。

  • 选择 "新建 源"以添加数据源。 此命令与"数据"功能>"获取数据"命令Excel一样。

  • 选择 "最近 使用的来源",从你一直在使用数据源中选择。 此命令与"最近>"功能区中的"数据源"Excel一样。

  • 选择 "输入数据 "以手动输入数据。 可以选择此命令来试用独立于外部数据源的 Power Query 编辑器。

假设查询有效且没有错误,可以将它加载回工作表或数据模型。

从 Power Query 编辑器加载查询

在 Power Query 编辑器中,执行下列操作之一:

  • 若要加载到工作表,请选择"开始">"关闭"&">关闭&加载"。

  • 若要加载到数据模型,请选择"主页">"关闭"&">"关闭&"加载到"。

    在"导入数据"对话框中,选择"将此数据添加到数据模型"。

提示   有时 ,"加载到 "命令灰显或禁用。 首次在工作簿中创建查询时,可能会发生这种情况。 如果发生这种情况,请选择"关闭&加载",在新的工作表中,选择"数据> 查询 &连接> 查询"选项卡,右键单击查询,然后选择"加载到"。 或者,在"Power Query 编辑器"功能区上,选择"查询>加载到"。

从"查询和连接"窗格加载查询 

在Excel中,可能需要将查询加载到另一个工作表或数据模型中。

  1. 在Excel中,选择">查询&连接",然后选择"查询"选项卡。

  2. 在查询列表中,找到查询,右键单击查询,然后选择"加载到"。 将显示"导入数据 "对话框。

  3. 确定要如何导入数据,然后选择"确定"。 有关使用此对话框的详细信息,请选择问号 (?) 。

有几种方法可编辑加载到工作表的查询。

从工作表中的数据编辑Excel查询

  • 若要编辑查询,请找到以前从 Power Query 编辑器加载的查询,选择数据中的单元格,然后选择"查询>编辑"。

从"查询和连接"&查询

在一个工作簿 中& 查询时,您可能会发现"查询和连接"窗格更方便使用。

  1. 在Excel中,选择">查询&连接",然后选择"查询"选项卡。

  2. 在查询列表中,找到查询,右键单击查询,然后选择"编辑"。

从"查询属性"对话框编辑查询

  • 在 Excel 中,选择"数据">"& 连接">"查询"选项卡,右键单击查询并选择"属性",在"属性"对话框中选择"定义"选项卡,然后选择"编辑查询"。

提示    如果工作表中包含查询,请选择"数据">属性",在"属性"对话框中选择"定义"选项卡,然后选择"编辑查询"。 

数据模型通常包含多个按关系排列的表。 使用"加载到"命令显示"导入数据"对话框,然后选择"将此数据添加到数据模式l"复选框,将查询加载到数据模型。 有关数据模型的信息,请参阅了解工作簿数据模型中使用哪些数据源、在 Excel 中创建数据模型和使用多个表创建数据透视表

  1. 若要打开数据模型,请选择"Power Pivot">"管理"。

  2. 在 Power Pivot 窗口底部,选择表格的工作表选项卡。

    确认显示正确的表。 数据模型可以有许多表。

  3. 记下表的名称。

  4. 若要关闭 Power Pivot 窗口,请选择"文件">关闭"。 回收内存可能需要几秒钟。

  5. 选择">连接"&"属性>"查询"选项卡,右键单击查询,然后选择"编辑"。

  6. 在 Power Query 编辑器中完成更改后,选择"文件">"关闭&加载"。

结果

工作表中的查询和数据模型中的表会更新。

如果发现将查询加载到数据模型所花的时间比加载到工作表长得多,请检查 Power Query 步骤,查看是使用 Contains 运算符筛选文本列还是列表结构化列。 此操作会导致Excel每行的整个数据集再次枚举。 此外,Excel无法有效地使用多线程执行。 解决方法是尝试使用其他运算符,例如"等于"或"以开头"。

Microsoft 已意识到此问题,正在调查中。

可以加载 Power Query:

  • 到工作表。 在 Power Query 编辑器中,选择"主页>关闭&加载>关闭&加载"。

  • 到数据模型。 在 Power Query 编辑器中,选择"开始">"关闭&">"&"加载到"。 

    默认情况下,Power Query 在加载单个查询时将查询加载到新工作表,同时将多个查询加载到数据模型。  您可以更改所有工作簿或当前工作簿的默认行为。 设置这些选项时,Power Query 不会更改工作表或数据模型数据和注释中的查询结果。

    也可使用"导入"对话框动态替代查询的默认设置,该对话框在选择"关闭"或"加载&显示 

应用于所有工作簿的全局设置

  1. 在 Power Query 编辑器中,选择"文件">"选项和设置>"查询选项"。

  2. 在"查询选项"对话框左侧的"全局"部分下,  选择"数据加载"。

  3. 在"默认查询加载设置部分中,执行以下操作:

    • 选择"使用标准负载设置"。 

    • 选择"指定自定义默认加载设置",然后选择或清除"加载到  工作表"或"加载到数据模型"。

提示    在对话框底部,可以选择 "还原默认值 "以方便地返回到默认设置。

仅适用于当前工作簿的工作簿设置

  1. 在"查询选项"对话框左侧的"当前工作簿"部分下,选择"数据加载"。

  2. 执行下列一项或多项操作:

    • "类型检测"下,选择或清除"检测非结构化源的列类型和标头"。

      默认行为是检测它们。 如果希望自己塑造数据,请清除此选项。

    • "关系"下,选择或清除"首次添加到数据模型时创建表之间的关系"。

      在加载到数据模型之前,默认行为是查找表之间的现有关系,例如表中的外键关系数据库并随数据导入它们。 如果希望自己执行此操作,请清除此选项。

    • "关系"下,选择或清除"刷新加载到数据模型的查询时更新关系"。

      默认行为是不更新关系。 刷新已加载到数据模型的查询时,Power Query 会查找表中的现有关系,例如表中的外键关系数据库更新它们。 这可能会删除导入数据后手动创建的关系或引入新关系。 但是,如果要这样做,请选择选项。

    • "后台数据"下,选择或清除"允许在后台下载数据预览"。

      默认行为是在后台下载数据预览。 如果想马上查看所有数据,请清除此选项。

另请参阅

Microsoft Power Query for Excel 帮助

管理查询Excel

Excel Web 的 Power Query (也称为"&转换) 技术,在使用导入的数据源时提供更高的功能。 可以在"查询"任务窗格中查看查询和相关详细信息。

注意: 观看有关改进 Web Excel Power Query 集成的更多公告。

查看"查询"任务窗格 

  1. 确保你当前在"编辑"视图中, ("查看>编辑) "。

  2. 选择"数据>查询"。

结果

Excel显示"查询"任务窗格和当前工作簿中所有查询以及查询详细信息,例如行计数、上次刷新日期、位置和加载状态。 如果将查询加载到数据模型而不是网格,则Excel"仅连接"。

查询视图和"查询"任务窗格

另请参阅

Microsoft Power Query for Excel 帮助

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

你对翻译质量的满意程度如何?
哪些因素影响了你的体验?

谢谢您的反馈意见!

×