您可以更改外部数据区域的属性,以控制通过连接到外部数据源(例如数据库、Web 查询或文本文件)导入工作表中的数据。

外部数据区域是定义的名称或表名称,用于定义放入工作表的数据的位置。 连接到外部数据时,Excel自动创建外部数据区域。 唯一例外是连接到数据源的数据透视表 - 数据透视表不使用外部数据区域。 在Excel中,您可以设置外部数据区域的格式和布局,或在计算中使用它,就像处理任何其他数据一样。

外部数据范围属性

外部数据区域具有 (属性,不能与可用于控制数据的查询或) 属性混淆,例如保留单元格格式和列宽。 可以通过在"数据"选项卡上的"连接"组中单击"属性"来更改这些外部数据区域属性。 然后执行下列操作进行更改:

  • 对于从 Microsoft Query 和数据连接向导创建的外部数据范围,请使用" 外部数据属性" 对话框。

  • 对于从导入的文本文件或检索 HTML 数据的 Web 查询创建的外部数据范围,请使用" 外部数据范围 属性"对话框。

  • 对于从检索 XML 数据的 Web 查询创建的外部数据范围,请使用 "XML 映射属性" 对话框。

  1. 选择要在工作表中搜索搜索 外部数据区域 。

  2. 在 编辑栏 ,单击"名称框"旁边的 箭头,然后单击需要的外部数据区域的名称。

  1. 选择"公式>名称管理器"。

  2. 在"名称管理器"对话框中,单击外部数据区域的名称,然后单击"编辑"。 也可以双击该名称。

  3. "编辑名称 "对话框中,在"名称"框中键入引用 的新 名称。

注意: " 关闭 "按钮仅关闭 "名称管理器" 对话框。 不必单击"关闭 " 即可提交已所做的更改。

可以更改从 Microsoft Query、导入的文本文件、Web 查询或数据连接向导创建的外部数据区域的基础查询。

  1. 单击要更改其基础查询的外部数据区域中的单元格。

  2. 选择"数据>属性"。

  3. 在"外部数据属性"对话框中,单击"连接属性 属性 "。

  4. 在"连接属性"对话框中,单击"定义"选项卡,然后单击"编辑查询"。

有关在 Microsoft Query 中构造和编辑查询的信息,请参阅 Microsoft Query 帮助。

  1. 单击要更改其基础查询的外部数据区域中的单元格。

  2. 选择">连接&">""连接"选项卡,右键单击想要的连接,然后选择"属性"。

  3. 在"连接属性"对话框中,单击"定义"选项卡,然后单击"编辑查询"。

  4. 在"导入文本文件"对话框中,单击"导入"。

  5. 在"文本导入向导"中对导入的文本文件进行更改,然后单击"完成"。

    有关导入文本文件的信息,请参阅 导入或导出文本文件

  1. 单击要更改其基础查询的外部数据区域中的单元格。

  2. 选择"数据>属性"。

  3. 选择">连接&">""连接"选项卡,右键单击想要的连接,然后选择"属性"。

  4. 在"连接属性"对话框中,单击"定义"选项卡,然后单击"编辑查询"。

  5. 在"编辑 Web 查询"对话框中对Web查询进行更改,然后单击"完成"。

有关创建和编辑 Web 查询的信息,请参阅连接网页

  1. 单击要更改其基础查询的外部数据区域中的单元格。   

  2. 选择"数据>属性"。

  3. 在"外部数据属性"对话框中,单击"连接属性 属性 "。

  4. 在" 连接属性" 对话框中,单击"定义 " 选项卡。

  5. 执行下列操作之一:

    • 在"命令类型"框中,单击"表",然后在"命令"文本框中,将值更改为相应表、视图或查询的名称。

    • 在"命令类型"框中,SQL或"默认",然后在"命令"文本框中编辑SQL语句。

      注意: 根据连接的定义方式,"命令类型"框可能不可用 (显示为灰色) 。

  1. 在编辑栏上,单击"名称框"旁边的箭头,然后选择要复制的外部数据区域的名称。

    对于Excel,请选择区域的名称,然后按 Ctrl+A 选择表标题。

    如果要包含非外部数据区域一部分的列标签或公式,请选择包含要复制的列标签或公式的单元格。 单击编辑栏上"名称 "旁边的箭头,然后单击要复制的外部数据区域的名称。

  2. 选择"主页>复制"。

  3. 切换到要粘贴外部数据范围的工作簿。

  4. 单击该单元格的左上角 粘贴区域 。

    若要确保 外部数据 不替换现有数据,请确保工作表在单击的单元格下面或右侧没有数据。

  5. “开始”选项卡上的“剪贴板”组中,单击“粘贴”

注意: 如果仅复制外部数据范围的一部分,则基础 查询 不会复制,并且无法刷新复制的数据。

可以控制如何处理在刷新数据时返回给Excel数据集。

  1. 选择"数据>属性"。

  2. 在" 外部数据区域属性 "对话框中的"如果刷新时数据区域中的行数发生更改" 下,单击下列操作之一:

    • 插入新数据的单元格,删除未使用的单元格

      注意: 

      • 在数据源中添加一行或多行时,直接位于外部数据区域下的单元格将向下移动,但外部数据区域右边的单元格不会移动。

      • 在数据源中删除一个或多个行时,直接位于外部数据区域下的单元格将向上移动,但外部数据区域右边的单元格不会移动。

    • 插入整行的新数据,清除未使用的单元格

      注意: 

      • 在数据源中添加一行或多行时,外部数据区域正下面和右边的单元格将向下移动。

      • 在数据源中删除一个或多个行时,外部数据区域正对下的单元格不会移动。

    • 使用新数据覆盖现有单元格,清除未使用的单元格

      注意: 

      • 在数据源中添加一个或多个行时,将覆盖外部数据区域正下的单元格,但外部数据区域右边的单元格不会移动。

      • 在数据源中删除一个或多个行时,外部数据区域正对下的单元格不会移动。

  1. 选择"数据>属性"。

  2. "数据格式和布局"下,执行以下一项或多个操作:

    • 若要将字段名称包含为第一行,请选中" 包括字段名称 "复选框。

      注意: 此复选框仅适用于从 Microsoft Office 2003 程序转换的外部数据区域,或以编程方式创建的外部数据区域。

    • 若要添加一列行号,请选中" 包括行号 "复选框。

      注意: 此复选框不适用于导入的文本文件、XML 文件或 Web 查询。

    • 若要保留所应用单元格格式,请选中"保留 单元格格式" 复选框。

      注意: 对于 Web 查询,在"选项"对话框中选择"完整 HTML 格式 "时 ,此选项 会自动 清除。 从"编辑 查询 "对话框中访问 "选项" 对话框。

    • 若要保留设置的列宽,请选中" 调整列宽 "复选框。

    • 若要保留所应用列的排序、筛选和布局,请选中"保留列排序 /筛选/布局 "复选框。

      注意: 此复选框不适用于 Web 查询。

    • 若要保留所应用列筛选,请选中"保留 列筛选器 "复选框。

      注意: 此复选框仅适用于基于 XML 数据的 Web 查询。

注意: 以下过程仅适用于从 Microsoft Office 2003 程序转换的外部数据范围,或以编程方式创建的外部数据范围。 使用用户界面创建的所有外部数据范围将创建为Excel表。 添加新行时,这些表会自动扩展,并向下填充计算列。

  1. 在与外部数据区域的第一行数据相邻的单元格中输入公式。

    注意: 第一行数据可能是外部数据区域的第一行或第二行,具体取决于第一行是否包含标题。

  2. 选择单元格,然后双击 填充柄 将公式复制到外部数据区域的所有行。

  3. 单击外部数据区域中的某个单元格。

  4. 选择"数据>属性"。

  5. 在" 外部数据区域属性 "对话框中,选中"在数据相邻的列中 向下填充公式 "复选框。

    注意: 如果外部数据区域在打开时 刷新 ,Excel仅复制紧邻外部数据区域或外部数据范围内的公式。

冻结外部数据范围会保留数据,但不保留其基础查询,因此无法刷新冻结的外部数据范围。

  1. 单击包含要从中删除Excel连接的表的工作表。

  2. 在编辑栏上,单击"名称框"旁边的箭头,然后单击要从中删除数据连接的外部数据区域的名称。 然后选择数据区域。

  3. 在"工具"选项卡上的"外部表数据"组中,单击"取消链接"。 数据范围保持不变,仍保留同一名称,但连接会被删除。

注意: 以下过程仅适用于从 Microsoft Office 2003 程序转换的外部数据范围,或以编程方式创建的外部数据范围。 使用用户界面创建的所有外部数据范围将创建为Excel表。 添加新行时,这些表会自动扩展,并向下填充计算列。

  1. 选择"数据>属性"。

  2. "查询定义"下,清除" 保存查询定义 "复选框。

注意: 保存工作簿时,基础查询将从工作簿中删除。 但是,不会删除 (.dqy 或 .odc) 保存的数据库查询文件。 如果在查询向导或 Microsoft Query 中创建查询时保存了查询,则查询文件将保存在计算机上,可以再次使用该查询检索外部数据。 有关详细信息,请参阅 Microsoft Query 帮助。

注意: 以下过程仅适用于使用数据连接向导或 Microsoft Query (创建的外部数据区域,而适用于导入的文本文件或 Web 查询) 、从 Microsoft Office 2003 程序转换的外部数据范围或以编程方式创建的外部数据区域。 使用用户界面创建的所有外部数据范围将创建为Excel表。

  1. 执行下列操作之一,在外部数据区域上方插入空白行:

    • 选择要在上方插入新行的单元格。 然后,在"开始"选项卡上的"单元格"组中,单击"插入"旁边的箭头,然后单击"插入工作表行"。 由于已选择一个单元格,因此在当前行上方插入了一个新行。

    • 单击要插入新行的行上方的行选择器。 然后,在"开始"选项卡上的"单元格"组中,单击"插入"。 由于已选择整行,因此在所选行上方插入一个新行。

  2. 在空白行的单元格中键入需要的标签。

  3. 单击外部数据区域中的某个单元格。

  4. 选择"数据>属性"。

  5. 在"外部数据区域属性"对话框中的"数据格式和布局"下,清除"包括字段名称"复选框,然后单击"确定"。

  6. 若要删除现有字段名称并刷新外部数据区域,请单击外部数据区域中的单元格,然后单击"刷新数据 按钮图像"。

注意: 从数据库检索数据时,Microsoft Query 中对列名的任何更改都保留在外部数据范围内。 有关更改查询中的列名的信息,请参阅 Microsoft Query 帮助。

  1. 单击包含要删除的外部数据范围的工作表。

  2. 在编辑栏上,单击"名称框"旁边的 箭头,然后单击要删除的外部数据区域的名称。

    如果外部数据区域是Excel,请按 Ctrl+A 选择整个表。

  3. 若要删除外部数据区域,请按 DELETE。

  4. 若要删除基础查询,请在系统提示Excel"是"。

另请参阅

Microsoft Power Query for Excel 帮助

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

你对翻译质量的满意程度如何?

哪些因素影响了你的体验?

是否还有其他反馈?(可选)

谢谢您的反馈意见!

×