导入或导出文本(.txt 或 .csv)文件

应用对象
Microsoft 365 专属 Excel Excel 2024 Excel 2021 Excel 2019 Excel 2016

可通过两种方法使用 Excel 从文本文件导入数据:可以在 Excel 中打开它,也可以将其作为外部数据区域导入。 要将数据从 Excel 导出到文本文件,请使用 “另存为” 命令并从下拉菜单中更改文件类型。

常用的文本文件格式有两种:

  • 带分隔符的文本文件 (.txt) ,其中 TAB 字符 (ASCII 字符代码 009 通常分隔每个文本字段) 。
  • 逗号分隔值文本文件 (.csv) ,其中逗号字符 (,) 通常分隔每个文本字段。

可以更改分隔文本文件和 .csv 文本文件中使用的分隔符。 这可能是确保导入或导出操作按所需方式工作所必需的。

注意

最多可以导入或导出 1,048,576 行和 16,384 列。

通过在 Excel 中打开文本文件来导入该文本文件

可以使用“ 打开 ”命令将在其他程序中创建的文本文件作为 Excel 工作簿打开。 在 Excel 中打开文本文件不会更改文件的格式 - 你可以在 Excel 标题栏中看到这一点,其中文件名保留文本文件扩展名 (例如 .txt 或 .csv) 。

  1. 转到“ 文件>打开” 并浏览到包含文本文件的位置。

  2. 选择 Text Files 在“打开”对话框的文件类型下拉列表中。

  3. 找到并双击您想要打开的文本文件。

    • 如果文件是文本文件 (.txt) ,Excel 将启动“导入文本向导”。 完成这些步骤后 ,单击 完成 完成导入操作。 有关分隔符和高级选项的更多信息,请参阅 文本导入向导 。

    • 如果文件是 .csv 文件,Excel 将自动打开该文本文件,并在新工作簿中显示该数据。

      注意

      当 Excel 打开 .csv 文件时,它使用当前默认数据格式设置来解释如何导入每列数据。 如果希望更灵活地将列转换为不同的数据格式,可以使用“导入文本向导”。 例如,.csv 文件中数据列的格式可能是 MDY,但 Excel 的默认数据格式是 YMD,或者您想将包含前导零的数字列转换为文本,以便保留前导零。 若要强制 Excel 运行导入文本向导,可以在打开文件之前将文件扩展名从 .csv 更改为 .txt,也可以通过连接到文本文件来导入文本文件 (有关详细信息,请参阅以下部分) 。

通过连接到文本文件导入文本文件

可以将数据从文本文件导入现有工作表中。

  1. 单击要将文本文件中的数据放入的单元格。

  2. 在 “数据 ”选项卡的“ 获取 & 转换数据 ”组中,单击 “从文本/CSV”。

  3. 在“ 导入数据 ”对话框中,找到并双击要导入的文本文件,然后单击 “导入”。
    按照 文本导入向导中的说明进行操作。 单击文本导入向导任意页面上的“帮助”按钮图像,了解有关使用向导的更多信息。 完成向导中的步骤后,单击 “完成” 以完成导入操作。

  4. 选择表后,选择加载加载到,>以指定要将数据放置到的位置。 在“ 导入数据 ”对话框中,执行下列操作:

    1. 在“ 导入数据 ”对话框中选择一个选项。
    2. 单击“确定”。
      Excel 将外部数据区域放在指定的位置。

如果 Excel 未将数据列转换为所需格式,可在导入数据后转换数据。 有关详细信息,请参阅 将存为文本的数字转换为数字 和将存 为文本的日期转换为日期。

通过保存数据导出到文本文件

可以使用“ 另存为 ”命令将 Excel 工作表转换为文本文件。

  1. 转到 “文件>”“另存为”。

  2. 将显示“另存为”对话框。

  3. 在 “保存类型 ”框中,选择工作表的文本文件格式。

    • 例如,单击“ 文本 (制表符分隔) ”或“ CSV” (逗号分隔) 。
    • 注意

      不同的格式支持不同的功能集。 有关不同文本文件格式支持的功能集的详细信息,请参阅 Excel 中支持的文件格式。

  4. 通过浏览找到要保存新文本文件的位置,然后单击 “保存”。

  5. 将出现一个对话框,提醒你只有当前工作表将保存到新文件中。 如果确定当前工作表就是要另存为文本文件的工作表,请单击 “确定”。 通过对每个工作表重复此过程,可以将其他工作表另存为单独的文本文件。

  6. 还会出现一个对话框,提醒你工作表可能包含文本文件格式不支持的功能。 如果只想将工作表数据保存到新的文本文件中,请单击 “是”。 如果不确定并想要详细了解文本文件格式不支持哪些 Excel 功能,请单击“ 帮助 ”以获取详细信息。

有关将文件保存为其他格式的详细信息,请参阅 将工作簿另存为其他文件格式。

更改导入文本文件时使用的分隔符

导入时更改分隔符的方式因导入文本方式而异。

  • 如果使用“从文本/CSV 获取 & 转换数据>”,则在选择文本文件并单击“导入”后,从分隔符下的列表中选择要使用的字符。 您可以在数据预览中立即看到新选择的效果,因此您可以确保在继续之前做出所需的选择。
  • 如果使用“文本导入向导”导入文本文件,则可以在“文本导入向导”的第 2 步中更改用于导入操作的分隔符。 在此步骤中,还可以更改处理连续分隔符(如连续引号)的方式。
    有关分隔符和高级选项的更多信息,请参阅 文本导入向导 。

更改默认列表分隔符,以便在 Excel 中将文件另存为文本 (.csv)

如果要在“另存为 .csv”时使用分号作为默认列表分隔符,但需要限制更改为 Excel,请考虑将默认小数分隔符更改为逗号 - 这会强制 Excel 将分号用于列表分隔符。 显然,这也将改变十进制数的显示方式,因此还要考虑更改千位分隔符以限制任何混淆。

  1. 清除 Excel 选项>高级>编辑选项>使用系统分隔符。
  2. 设置 “小数分隔符” 以 , (逗号) 。
  3. 设置 千位分隔符以. (句点) 。

更改新文本文件的默认列表分隔符 (会影响所有程序)

将工作簿另存为 .csv 文件时,默认列表分隔符 (分隔符) 为逗号。 可以使用 Windows 区域设置将其更改为另一个分隔符。 

警告

更改 Windows 设置会导致计算机发生全局更改,从而影响所有应用程序。 若要仅更改 Excel 的分隔符,请参阅 更改默认列表分隔符,以便在 Excel 中将文件另存为文本 (.csv) 。

  1. 在 Microsoft Windows 11 中,选择搜索栏并键入“区域设置”。
  2. 选择 管理语言设置。
  3. 在 “格式 ”选项卡下,选择 “其他设置”。
  4. 在“ 自定义格式 ”对话框中的 “数字 ”选项卡上,在 “列表分隔符 ”框中键入要用作新分隔符的字符。
  5. 选择“ 确定” 两次。

注意

 更改计算机的列表分隔符后,所有程序都使用该新字符作为列表分隔符。 您可以按照相同的步骤将字符更改回默认字符。

需要更多帮助吗?

你随时可以在 Excel 技术社区 中咨询专家,或在 社区中获取支持。

另请参阅

从外部数据源 (Power Query) 导入数据