使用 Excel 表格中的計算結果欄

表格中的計算Excel資料行是一個絕佳的工具,能有效率地輸入公式。 它們允許您在一個儲存格中輸入單一公式,然後該公式會自動自行展開至資料行的其餘部分。 不需要使用填滿或複製命令。 這可節省許多時間,尤其是當您有許多列時。 當您變更公式時,會發生同樣的情況;變更也會展開至計算結果欄的其餘部分。

附註: 本文中的螢幕擷取畫面是使用 Excel 2016 進行示範。 如果您使用不同版本,看到的畫面可能會稍有不同;除非另有說明,不然功能都是一樣的。

建立計算結果欄

  1. 建立表格。 如果您不熟悉資料表Excel,可以深入瞭解:表格Excel概觀

  2. 在表格中插入新欄。 您可以直接在表格右邊的欄中輸入,Excel會自動延伸表格。 在此範例中,我們在儲存格 D1 中輸入「總計」以建立新欄。

    在現有資料表右邊的空白欄中輸入,以新增表格欄

    提示: 

    • 您也可以從首頁索引鍵 新增表格欄 。 只要按一下 [插入資料>將表格欄插入左側的箭鍵即可。

    • 若要從 [首頁」 索引鍵新增表格欄,請按一下 [插入>欄到左側的箭鍵。

  3. 輸入您想要使用的公式,然後按Enter。

    在表格儲存格中新增單一公式,自動完成以建立計算結果欄

    在此案例中,我們輸入 =sum (,然後選取 了 Qtr 1Qtr 2 欄。 因此,我們Excel公式:=SUM (Table1[@[Qtr 1]:[Qtr 2]]) 。 這稱為結構化參照公式,這是資料表Excel公式。 結構化參照格式可讓表格針對每一列使用相同的公式。 此Excel的一般公式為=SUM (B2:C2) ,然後您需要複製或填滿欄中的其他儲存格

    若要深入瞭解結構化參照,請參閱:將結構化參照與Excel使用。

  4. 當您按 Enter 時,公式會自動填入欄的所有儲存格 ,包括您輸入公式的儲存格上方和下方。 每個資料列的公式都相同,但由於它是結構化參照,因此Excel知道哪一列是哪個列。

    已自動填上以在表格中建立計算資料行的公式範例

附註: 

  • 將公式複製或填入空白表格欄的所有儲存格時,也會建立計算結果欄。

  • 如果您在已經包含資料的表格欄中輸入或移動公式,系統不會自動建立計算結果欄。 不過, 系統會顯示自動校正選項 按鈕,為您提供覆寫資料的選項,以便建立計算結果欄。

    當一個公式與其余公式不同時,可覆寫計算資料行中的現有公式的選項

  • 如果您輸入的新公式與計算欄中現有的公式不同,該欄會以新的公式自動更新。 您可以選擇復原更新,只保留來自自動校正選項按鈕 的單 一新公式。 不過,通常不建議這樣做,因為這會防止您的欄日後自動更新,因為新增新列時,它不知道要延伸哪個公式。

    輸入公式後復原計算結果欄的選項

  • 如果您將公式輸入或複製到空白欄的儲存格中,但不想保留新的計算結果欄,請按一下 [復原 [復原] 按鈕 兩次。 您也可以按 Ctrl + Z 兩次

計算結果欄可以包含公式與其餘數據不同的儲存格。 這會建立一個例外,在資料表中會清楚標示。 如此一來,很容易偵測並解決不慎的不一致。

資料表中不一致的公式錯誤Excel通知

附註: 執行下列任一動作會造成計算結果欄例外狀況:

  • 在計算結果欄儲存格中輸入公式以外的資料。

  • 在計算結果欄儲存格中輸入公式,然後按一下 [快速 [復原] 按鈕 工具列上的 [復原 資料表

  • 在已包含一或多個例外狀況的計算結果欄中,輸入新的公式。

  • 將資料複製到不符合計算結果欄公式的計算結果欄。

    附註: 如果複製的資料包含公式,此公式會覆寫計算欄中的資料。

  • 刪除計算結果欄中一個或多個儲存格中的公式。

    附註: 此例外並未標示。

  • 移動或刪除另一個工作表範圍上由計算結果欄其中一列所參照的儲存格。

只有在已啟用背景錯誤檢查選項時,才會出現錯誤通知。 如果您沒看到錯誤,請前往檔案>選項>公式>確認已勾選啟用背景錯誤核取方塊。

  • 如果您使用的是 2007 Excel,請按一下 [Office 按鈕Office 2007 按鈕,Excel [>公式> 。

  • 如果您使用的是 Mac,請前往功能表Excel上的[偏好設定> [公式&清單>錯誤檢查

自動填入公式以在資料表中建立計算Excel選項預設為啟用。 如果您不想在表格欄Excel建立計算結果欄,您可以關閉填滿公式的選項。 如果您不想關閉選項,但不想在表格處理時一直想要建立計算結果欄,您可以停止自動建立計算結果欄。

  • 開啟或關閉計算結果欄

    1. 按一下 [檔案] 索引標籤上的 [選項]。

      如果您使用的是 2007 Excel,請按一下 [Office 按鈕 Office 2007 按鈕,Excel選項

    2. 按一下 [校訂]

    3. [自動校正選項>下,按一下 [自動校正選項> 。

    4. 按一下 [輸入時自動套用格式] 索引標籤。

    5. 自動處理時,選取或清除表格中的填滿公式以建立計算結果欄核取方塊,以開啟或關閉此選項。

      關閉從檔案和>選項>校訂工具>自動校正選項>取消勾選「填入表格中的公式以建立計算結果欄」。

      提示: 您也可以在 輸入公式後 ,按一下資料表欄中顯示的 [自動校正選項> 按鈕。 按一下 [控制項自動校正選項,然後清除表格中的填滿公式以建立計算結果欄的核取方塊,以關閉此選項。

    如果您使用的是 Mac,請在主功能表Excel ,然後喜好設定 > 公式和清單> 資料表&篩選>自動填滿公式。

  • 停止自動建立計算結果欄

    在資料表欄中輸入第一個公式之後,按一下顯示的 [自動校正選項> 按鈕,然後按一下 [停止自動建立計算結果欄> 。

您也可以使用樞紐分析表建立自訂計算欄位,您可以在其中建立一個公式Excel然後將它適用于整個資料行。 深入瞭解計算 樞紐分析表中的值

需要更多協助嗎?

您可以隨時詢問 Excel 技術社群中的專家,或是在 Answers 社群取得支援。

另請參閱

Excel 表格概觀

設定 Excel 表格格式

藉由新增或移除列和欄調整表格大小

合計 Excel 表格中的資料

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Office Insiders

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?

Thank you for your feedback!

×