將 Excel 活頁簿儲存為與舊版 Excel 相容的格式

您已升級至新版 Excel,並發現要與尚未升級的使用者共用活頁簿。 執行 [相容性檢查程式] 可協助您識別出舊版可能無法提供的功能或資訊,以便您可以解決部分問題再共用活頁簿。

請將檔案儲存為 .xls 格式,並檢閱 [相容性檢查程式] 問題

請遵循下列步驟:

  1. 按一下[檔案>匯出>變更檔案類型

    在 [匯出] 索引標籤上變更 [檔案] 類型

  2. 在 [匯出] 索引標籤上變更 [檔案] 類型

  3. [活頁簿檔案類型] 下,按兩下 [Excel 97-2003 Workbook (*.xls)]

    Excel 97-2003 活頁簿格式

  4. 在儲存 快顯視窗中,為活頁簿選擇資料夾位置。

  5. 在檔案名 方塊 中,輸入新的 (名稱,或使用已存在的檔案名) 。

  6. 按一下 [儲存]

  7. 如果出現 相容性檢查程式 ,請檢閱找到的任何相容性問題。

    相容性檢查程式顯示「稍微影響逼真度」問題

    尋找 連結 會將您帶至工作表中的該位置,而説明 連結會 將您帶至問題及可能的解決方案相關資訊。
     

附註: 

  • 在新版 Excel 中,您剛儲存為 .xls 格式的活頁簿會在 [相容模式] 中開啟。 若計劃與使用舊版 Excel 開啟活頁簿的人員來回傳送這個活頁簿,請繼續在這個模式中工作。

  • 當您不再需要向後相容性時,請按一下 [檔案>資訊>轉換以將活頁簿轉換成目前的檔案格式,以便利用 Excel中的新增功能

執行適用於 Excel 2007 和更新版本的相容性檢查程式

若要確認活頁簿是否相容於 Excel 2013、2010 或 2007,請在第一次儲存活頁簿時手動執行 [相容性檢查程式]。 然後,將 [相容性檢查程式] 設定為每次儲存該活頁簿時自動執行。

請遵循下列步驟:

  1. 按一下 [檔案] > [資訊] > [查看問題]

    檢查相容性

  2. 選擇 檢查相容性

  3. 若要從現在開始自動檢查相容性,請核取 [儲存此活頁簿時檢查相容性] 方塊。
     

    提示: 您也可以在檢查相容性Excel指定要包含的版本。 根據預設,所有版本都會檢查,因此只要取消核取您不想要加入的版本。

    相容性檢查程式,顯示要檢查的版本

    如果發現任何問題,則尋找連結會將您帶至工作表中的該位置,而説明連結會將您帶至問題相關資訊及可能的解決方案。

使用 Access 合併使用多個資料表之資料功能的資料來源

附註: 您也可以使用 Excel中的 VLOOKUP函數來解決此問題,但程式有點複雜,而且會隨著合併的資料來源數目增加而變得更加複雜。

Excel 2010 和較舊版本不支援分析多個資料表的資料功能,因為這些Excel版本沒有資料模型。 如果您的活頁簿包含任何這類功能,您可以結合功能資料來源至單一資料表,然後使用該新資料表做為資料來源,以準備這些功能,以用於較舊版本。

其中一個方法就是使用 Access 合併資料來源,並複製資料來源做為查詢,然後您可以將其導入至您的活頁簿。 程式如下所示:

  1. 在 Access 中 ,將 每個原始資料來源作為新資料表。

  2. 在 Excel中,按一下 [資料與資料工具> [資料工具>以開啟 [資料庫關係>,並記下原始資料來源之間的關係。

  3. 在 Access 中,重新建立每個關係

  4. 在 Access中,建立包含所有欄位的查詢,Excel資料功能需求。

  5. 在 Excel中,將查詢以表格輸入至新工作表。

資料位於 Excel 中的一個資料表中後,請選擇該資料表做為使用多個資料表之資料功能的資料來源,或重新使用資料功能,然後選擇新資料表做為資料來源。

需要更多協助嗎?

您可以隨時詢問 Excel 技術社群中的專家、在 Answers 社群取得支援,或是在 Excel User Voice 上建議新功能或增強功能。

另請參閱

Excel格式和未移轉到其他檔案格式的功能

工作表相容性問題

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Office Insiders

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?

Thank you for your feedback!

×