什麼是自動儲存?

Applies To
Excel for Microsoft 365 Word for Microsoft 365 PowerPoint for Microsoft 365 Excel for Microsoft 365 for Mac Word for Microsoft 365 for Mac PowerPoint for Microsoft 365 for Mac Excel 2024 PowerPoint 2024 Excel 2024 for Mac Word 2024 for Mac PowerPoint 2024 for Mac Excel 2021 Word 2021 PowerPoint 2021 Excel 2021 for Mac Word 2021 for Mac PowerPoint 2021 for Mac Excel 2019 Excel 2016

Office 中的自動儲存切換

自動儲存是 Excel、Word 和 Microsoft 365 PowerPoint 訂閱者皆可使用的新功能,它會在您工作時每幾秒鐘自動儲存一次檔案。

當檔案儲存在 OneDrive、商務用 OneDrive 或 SharePoint Online 上時,預設會在 Microsoft 365 啟用自動儲存。

重要

您是否在對原始文件或範本進行變更後,使用 [檔案>另存新檔] ? 如果是這樣,建議您先使用 [ 檔案>儲存複本]再 進行變更。 這樣一來,[自動儲存] 就不會以變更內容覆寫原始檔案。 如果 [自動儲存] 以變更內容覆寫了檔案,請參閱<我不想儲存所做的變更,該如何回到先前的狀態?>一節。

在 Windows 上,自動儲存功能可在 Excel、Word 和 Microsoft 365 PowerPoint 訂閱者中使用。 以下是有關該功能的常見問題集。

我不想儲存變更。 該如何回到先前的狀態?

您可以使用 [版本歷程記錄] 還原檔案的某個先前版本。

使用游標按一下檔案名稱,查看所有版本 按一下視窗頂端的 [檔案名稱],然後按一下 [版本歷程記錄]。 檢閱日期和時間來尋找您要還原的版本,然後按一下 [開啟版本]。 第二個視窗隨即開啟並顯示該版本的檔案。 若要復原到此版本,按一下 [還原] 按鈕。 如需有關版本歷程記錄的詳細資訊,請參閱檢視 Office 檔案的歷程記錄版本。

當您開啟文件並首次進行變更時,自動儲存功能會儲存這些變更,並將新版文件新增到版本歷程記錄中。 在此之後,即使自動儲存會固定儲存對檔案的變更,但只會定期將新版本新增到版本歷程記錄 (大約每 10 分鐘),以儲存編輯工作階段的剩餘部分。

如何在共用檔案時防止其他人不小心變更檔案內容?

如果您是檔案擁有者,可以將之設為一律以唯讀方式開啟。 當使用者開啟具備此項設定的檔案時,除非特別啟用編輯,否則他們無法儲存編輯至該檔案。 若要開啟檔案的這項設定,請移至 [ 檔案>資訊>] [保護文件>] [一律以唯讀方式開啟]。 之後若要再關閉,請重複這個程序。

已選取 [保護文件] 控制項,顯示 [永遠以唯讀方式開啟] 選項。

還有其他方式可協助您防止檔案遭到編輯。 如果檔案位於 OneDrive 上,您可以變更檔案權限。 如果檔案位於 SharePoint 上,您可以設定需要簽出的文件庫。

[檔案 > 另存新檔] 發生了什麼問題?

檔案 > 儲存複本 當您從 OneDrive、商務用 OneDrive 或 SharePoint Online 開啟檔案時,[另存新檔] 不會在 [檔案] 功能表上。 在這種狀況下,[儲存複本] 命令會出現在 [檔案] 功能表上。

您經常使用 [另存新檔] 嗎? 許多人習慣在檔案上處理檔案,然後使用 [檔案 > 另存新檔] 來保留複本中的變更,而非原始檔案。 然而,當開啟 [自動儲存] 時,您所做的變更會持續儲存至原始檔。 因此,如果您想要將變更套用到複本而非原始複本,建議您在進行任何變更之前先使用 [檔案>儲存複本]。

找不到 [自動儲存]。 我要如何確保檔案已被儲存?

如果您是 Microsoft 365 訂閱者,且已安裝最新版的 Windows 版 Excel、Word 和 PowerPoint,自動儲存會顯示在標題列上的左上角。 請注意,如果您擁有公司或學校帳戶,則您的系統管理員可能會控制您可安裝的 Office 版本,而且可能不是最新版本。 請參閱何時可以取得 Microsoft 365 中的最新功能?

如果您不是訂閱者也不用擔心, 我們還有 [自動回復] 功能。 [自動回復] 會在當機時協助保護您的檔案。 如果您在當機後重新開啟檔案,儲存您最新變更的版本會出現在 [文件復原] 窗格中。 如需了解開啟此功能的詳細資訊,請參閱在當機時協助保護您的檔案。

當然,您始終可以像往常一樣手動保存,方法是按 CTRL+S、單擊 “保存” 按鈕或轉到“ 文件>保存”。

我是最新版本 Office 的訂閱者。 為什麼 [自動儲存] 停用?

當您處理儲存至 OneDrive、商務用 OneDrive 或 SharePoint​​ Online 的檔案時,系統就會啟用 [自動儲存]。 如果檔案儲存至別的位置 (或完全沒有儲存),則會停用 [自動儲存]。 如果您的檔案位於 SharePoint 內部部署網站、檔案伺服器、某種其他的雲端儲存服務,或是儲存至如 C:\ 的本機路徑,就會發生這種情況。

還有其他原因可能會停用 [自動儲存]。 以下為常見的停用原因:

  • 您的檔案是較舊的格式,例如 .xls、.ppt 或 .doc。
  • 您的檔案位於本機 OneDrive 資料夾中,而 OneDrive 同步處理已暫停。
  • 您的檔案正由舊版的 OneDrive 同步處理應用程式同步處理。 如需有關更新 OneDrive 的詳細資訊,請參閱在 Windows 中使用 OneDrive 同步處理檔案。
  • 您的檔案內嵌在其他 Office 檔案中。
  • 您的簡報處於投影片放映模式中。

如果您使用 Excel 且嘗試過上述方法,可能是您的檔案包含自動儲存不支援的功能。 請執行下列其中一或多項操作來啟用:

注意

關閉自動儲存後,共同作業的效率可能會降低,需要較長的時間來納入其他人的更新,並增加衝突的可能性。 因此,如果您打算共同處理檔案,建議依照下列指示重新啟用自動儲存。

  • 關閉共用活頁簿功能。 此功能是一種較舊的共用方法。 它有許多限制,而且已由共同撰寫取代。
  • 可能的話,請以敏感度標籤取代密碼加密。 首先移除密碼:移至 [檔案>資訊>] [保護活頁簿]。 接著,刪除密碼,然後按一下 [確定]。 之後,在書籍上貼上適當的標籤: 首頁 > 敏感度 > 選擇正確的標籤
  • 可能的話,請以敏感度標籤取代 [限制存取]。 首先移除限制存取:移至 [檔案>資訊>保護] [活頁簿>限制存取 ],然後按一下 [不受限制的存取]。 接著在書籍上套用適當的標籤: 首頁 > 敏感度 > 選擇正確的標籤
  • 如果要從 SharePoint 開啟活頁簿快照,請選擇開啟檔案,而不是快照。
  • 停用造成 [自動儲存] 停用的增益集。 選取 [檔案>選項]、[>增益集]、[Excel 增益集>]、[>前往],然後清除該增益集的核取方塊。
  • 移除相容性檢查: 檔案 > 資訊 > 檢查活頁簿 > 檢查相容性。 然後取消選取 [ 儲存此活頁簿時檢查相容性]。
  • 如果檔案包含內嵌物件,請考慮以連結取代這些物件。 查看更多詳細信息 請點擊這裡.

如果我想要快速執行一些我不想讓別人看到的「假設」變更,該怎麼辦?

簡易的方法是在變更之前,將 [自動儲存] 關閉。 如果那些變更為暫時性且不需要儲存,請關閉檔案。 然後在系統詢問您是否要儲存時,按一下 [否]。 如果您決定要儲存所做的變更,請重新開啟 [自動儲存]。

如果我關閉檔案的 [自動儲存],會發生什麼情況?

如果您不想持續儲存,也不想向其他人顯示您的變更,可以關閉自動儲存。 然後,當您準備好時,按一下 [ 儲存 (] 或按 CTRL+S) 儲存並向任何其他在處理檔案的人員顯示您的變更。 (或者,您也可以重新開啟 [自動儲存],來儲存及共用您的變更)。

針對位於 Microsoft 雲端的檔案,[自動儲存] 預設一律為 [開啟]。 不過,如果您針對某個別檔案將 [自動儲存] 設為 [關閉],程式將會記得此設定,並在每次重新開啟該檔案時關閉該功能。 如果您針對某個檔案將該功能切換回 [開啟],程式也會持續針對檔案開啟該功能。

關閉 [自動儲存] 時,如果系統在您的檔案為開啟狀態時當機,[自動回復] 的功能仍會運作。

如何預設為不要自動儲存?

如果您關閉個別檔案的 [ 自動儲存],每次重新開啟該檔案時,程式都會記得將其關閉。 如果您針對某個檔案將該功能切換回 [開啟],程式也會持續針對檔案開啟該功能。

如果您想要預設關閉所有檔案的自動儲存,請移至 [檔案>選項]>儲存並取消勾選應用程式>預設為<自動儲存 OneDrive 和 SharePoint Online 檔案旁的方塊。

[檔案 > 選項 > 儲存] 對話方塊顯示啟用或停用自動儲存的核取方塊

重新啟動 Word (或您所在的應用程式),然後變更就會生效。

注意

  • 如果您要針對所有 Office 應用程式 (例如 PowerPoint 和 Excel ) 將 [自動儲存] 預設為關閉,您需要對那些程式一一重複這些步驟。
  • 如果您要讓個別的檔案仍能 [自動儲存],您可以開啟那些檔案,然後手動為那些檔案的 [自動儲存] 重新設回 [開啟]。

深入了解

如何啟用自動儲存?