在 Office 中檢查拼字及文法

所有的 Microsoft Office 程式都可以檢查拼字,大部分可以檢查文法。 

如果您發現拼字或文法檢查無法如預期般運作,請參閱拼字及文法檢查器運作結果不如預期 (機器翻譯)。 如果您想要檢查預設語言以外的語言的拼字或文法,請參閱檢查不同語言的拼字及文法

使用 Office 365 嗎? 您可能會想要了解 Word 中的強大全新編輯工具功能! 請參閱編輯工具 - 您的寫作小幫手以了解詳細資訊。

手動執行拼字及文法檢查器

若要開始在檔案中進行拼字及文法檢查,您只需要按下 F7 或依照下列步驟進行:

  1. 開啟大部分的 Office 程式,按一下功能區上的 [校閱] 索引標籤。 在 Access 或 InfoPath 中,您可以略過此步驟。 在專案中,您必須移至 專案 索引標籤。

  2. 按一下 [拼字] 或 [拼字及文法檢查]。

    [校閱] 功能區上的 [拼字及文法檢查] 按鈕

  3. 若程式找到拼字錯誤,則會顯示對話方塊,其中會提供拼字檢查找到的第一個拼錯的單字。

  4. 決定如何解決拼字錯誤 (忽略、新增到程式的字典,或是變更) 後,程式會移至下一個有拼字錯誤的單字。

按一下下列標題以取得詳細資訊

大部分的 Office 程式都會在您打字的同時自動檢查可能的拼字及文法錯誤,所以您不需要執行任何操作,程式也會在您工作過程中顯示錯誤。 

附註: 

  • 自動拼字及文法檢查功能不適用於 Access、Excel 或 Project。 您可以按 F7 鍵手動開始拼字檢查。

  • 自動文法檢查功能僅限 Outlook、Word、PowerPoint 2013 (或更新版本) 可使用。

Office 會以紅色波浪線標示可能的拼字錯誤,並以藍色波浪線標示可能的文法錯誤。

如果拼字或文法錯誤沒有標示出來,表示自動檢查功能可能關閉了。 您可以開啟自動拼字及文法檢查器

當您看到您需要取得修正協助的拼字或文法錯誤時,請以滑鼠右鍵按一下含有底線的單字或片語,然後選擇其中一個選項來修正錯誤。

如果 Office 將單字標幟為拼字錯誤,但這是您想要的拼字方式,則請選取 [新增至字典],教導 Office 日後不要將該單字標幟為拼字錯誤。 如需相關詳細資訊,請參閱:新增或編輯拼字檢查字典中的單字

如果您不希望 Office 在您工作過程中以波浪線標示出可能的錯誤,可以關閉自動拼字及文法檢查:

  1. 開啟拼字及文法選項:

    • 在 OneNote、PowerPoint、Publisher、Visio 及 Word 中:在 [檔案] 功能表上,按一下 [選項],然後按一下 [校訂]。

    • 在 InfoPath 中​​:在 [常用] 索引標籤上,按一下 [拼字檢查] 旁邊或下面的箭號,然後按一下 [拼字檢查選項]。

    • 在 Outlook 中:在 [檔案] 功能表上,按一下 [選項],然後按一下 [郵件],再按一下 [拼字檢查及自動校正]。

  2. 選取或清除 [自動拼字檢查] 核取方塊。 在有自動文法檢查的程式中,您也可以選取或清除 [自動標記文法錯誤] 核取方塊。

    選取 [自動拼字檢查] 核取方塊

    附註: 在 Word 中,您在開啟或關閉拼字檢查器時,可以選擇僅限處理中的文件,或適用於所有新文件。 選取 [例外] 清單中的選項,然後選取或清除 [只隱藏文件中的拼字錯誤] 及 [只隱藏文件中的文法錯誤] 核取方塊。

如果您完全不希望 Office 檢查文法 (不論是執行拼字檢查時或在您打字時),可以關閉此功能:

  1. 開啟拼字及文法選項:

    • 在 OneNote、PowerPoint、Publisher、Visio 及 Word 中:在 [檔案] 功能表上,按一下 [選項],然後按一下 [校訂]。

    • 在 InfoPath 中​​:在 [常用] 索引標籤上,按一下 [拼字檢查] 旁邊或下面的箭號,然後按一下 [拼字檢查選項]。

    • 在 Outlook 中:在 [檔案] 功能表上,按一下 [選項],然後按一下 [郵件],再按一下 [拼字檢查及自動校正]。

  2. 清除 [自動標記文法錯誤] 及 [拼字檢查時亦檢查文法] 核取方塊。

    文法檢查核取方塊

    附註: 並非每個 Office 程式都有這兩個選項。

您可以在 Word、Outlook、PowerPoint 2013 (或更新版本) 中執行下列步驟,強制再次檢查先前略過的單字及文法:

  1. 開啟您要檢查的文件或郵件。

  2. 在 [檔案] 功能表上,依序按一下 [選項] > [校對] > [重新檢查文件]。 在 Outlook 中,您可以在 [檔案] > [選項] > [郵件] > [拼字檢查和自動校正] 底下找到此選項。

  3. 當您看到警告訊息表示將重設拼字及文法檢查器時,按一下 [是]。

  4. 按一下對話方塊中的 [確定] 以返回文件,然後再次執行拼字及文法檢查器

我們隨時洗耳恭聽!

本文章由 Ben2019 年 10 月 28 日 更新。 如果您覺得本文很實用 (如果您覺得不實用則更是如此),請使用下方的意見反應控制項提供有建設性的建議,讓我們知道如何繼續改善。

另請參閱

測試您的文件的可讀性

拼字及文法檢查器運作結果不如預期

在 Office 2013 及更舊版本中選取文法及書寫樣式選項

將單字新增至拼字檢查字典

拼字或文法檢查器無法正確檢查其他語言的文字

選取大小寫、拼字和符號的自動校正選項

在 Outlook 中在傳送郵件前檢查拼字

Mac 版 Office 應用程式會在您輸入內容時,自動檢查可能的拼字及文法錯誤。 如果您想要等候編寫完成之後再檢查拼字及文法,您可以關閉自動檢查,或是勾選一次全部檢查拼字及文法。

Word

輸入時自動檢查拼字及文法

Word 會以紅色波浪線標示可能的拼字錯誤,並以綠色波浪線標示可能的文法錯誤。

提示: 如果沒有標示拼字或文法錯誤,您可能需要開啟自動拼字及文法檢查,下一個程序中將說明此動作。

當您看到拼字或文法錯誤時,請按住 Control 並同時按一下有錯的單字或片語,然後選擇其中一個選項。

如果 Word 不正確地將某個字詞標示為拼錯,而您想要將該字詞新增至字典,讓 Word 日後能夠正確辨識該字詞,請參閱新增或編輯拼字檢查字典中的單字

  1. [Word] 功能表上,按一下 [喜好設定] > [拼字及文法檢查]

  2. [拼字及文法檢查] 對話方塊中的 [拼字檢查] 底下,核取或清除 [自動拼字檢查] 方塊。

  3. [文法檢查] 底下,核取或清除 [自動文法檢查] 方塊。

  4. 關閉對話方塊,儲存您所做的變更。

  1. 按一下 [檢閱] 索引標籤上的 [拼字及文法檢查]

  2. Word 一旦找到可能的錯誤,便會開啟 [拼字及文法檢查] 對話方塊,拼字錯誤會以紅色文字顯示,文法錯誤則會以綠色文字顯示。

  3. 若要修正錯誤,請執行以下其中一個動作:

    • 在方塊中輸入校正,然後按一下 [變更]

    • [建議] 底下,按一下您要使用的單字,然後按一下 [變更]

    若要跳過錯誤,請執行下列其中一項動作:

    • 按一下 [略過],跳過錯誤的該單一例項。

    • 按一下 [全部略過],略過錯誤的所有例項。

    • 如果是文法錯誤,請按 [下一句],跳過錯誤的那個例項,然後移到下一個錯誤。

    若要跳過所有文件中某個拼錯的字,請按一下 [加入],將它新增到字典中。 這只適用於拼錯的字。 您不能將自訂文法新增到字典中。

  4. 待您校正、略過或跳過錯誤之後,Word 便會移到下一個錯誤。 Word 將文件檢閱完畢之後,您會看到一則訊息,告訴您拼字及文法檢查已經完成。

  5. 按一下 [確定] 返回文件。

您可以清除或重設略過的拼字及文法清單,Word 便會檢查您之前設定要略過的拼字及文法問題。

附註: 當您重設略過的拼字及文法檢查清單時,只會針對目前開啟的文件清除該清單。 您在其他文件中設定要 Word 略過的任何拼字或文法問題將不受影響。

  1. 開啟所要檢查的文件。

  2. 在 [工具] 功能表上,指向 [拼字及文法檢查],然後按一下 [重設略過的拼字及文法]。

    若要清除 Word 忽略的拼字及文法清單,請按一下 [重設略過的拼字及文法]。

    Word 會顯示有關重設拼字檢查器和文法檢查器操作的相關警告。

    按一下 [是],讓 Word 檢查您之前要求 Word 略過的拼字及文法。
  3. 按一下 [是] 以繼續進行。

  4. 按一下 [校閱] 索引標籤,然後按一下 [拼字及文法檢查] 以檢查拼字及文法。

Outlook

輸入時自動檢查拼字及文法

根據預設,Outlook 會在您輸入時檢查拼字錯誤。 Outlook 使用虛線紅色底線來指出可能的拼字錯誤,並使用綠色虛線指出可能的文法錯誤。

  1. 當您看到含有虛線底線的字詞時,請住 CTRL 並按一下該字詞或片語,然後選擇其中一個選項。

  2. 在捷徑功能表上,執行以下其中一個動作:

    • 在捷徑功能表頂端,按一下其中一個猜測值。

    • 按一下 [略過拼字檢查],略過該字詞的一個執行個體。

    • 按一下 [學習拼字檢查],將該字詞新增到拼字字典中。

開啟電子郵件訊息之後:

  • 若要讓 Outlook 自動修正拼字錯誤,請在 [Outlook] 功能表中,按一下 [喜好設定]。 按一下 [個人設定] 下的 [拼字及文法檢查]。 按一下 [自動拼字檢查] 旁的方塊。

  • 若要開啟或關閉自動文法檢查,請在 [Outlook] 功能表上按一下 [喜好設定]。 按一下 [個人設定] 下的 [拼字及文法檢查]。 按一下 [自動文法檢查] 旁的方塊。

在您輸入時檢查拼字的喜好設定

在您完成撰寫郵件或其他 項目 之後,可以同時校正所有拼字及文法問題。

  1. 在 [編輯] 功能表上,指向 [拼字及文法檢查],然後按一下 [拼字及文法檢查]...

  2. 執行下列任何一個動作:

    • 在建議清單中,按一下您要使用的字詞,或在頂端方塊中輸入新的拼字,然後按一下 [變更]。

    • 按一下 [略過],略過這個字詞,並且移至下一個拼錯的字詞。

    • 按一下 [新增],將該字詞新增到拼字字典中。

提示: 跳到下一個拼字檢查或文法錯誤的鍵盤快速鍵是 命令 + ;。

PowerPoint

您可以在 PowerPoint 中檢查拼字,但不能檢查文法。

輸入時自動檢查拼字

PowerPoint 會自動檢查可能的拼字錯誤,並以波浪狀紅色底線標示。

提示: 如果沒有標示拼字錯誤,您可能需要開啟自動拼字檢查,下一個程序中將說明此動作。

當您看到拼字錯誤時,請在單字或片語按一下 Ctrl + 按一下,或是按一下滑鼠右鍵,然後選擇其中一個建議的選項。

  1. 在 [PowerPoint] 功能表上,按一下 [喜好設定] > [拼字檢查]。

  2. 在 [拼字檢查] 對話方塊中,選取或清除 [自動拼字檢查] 方塊。

  1. 在 [校閱] 索引標籤上,按一下 [拼字檢查]。

  2. 如果 PowerPoint 找到可能的錯誤,就會開啟 [拼字檢查] 窗格並顯示拼字錯誤。

  3. 若要修正錯誤,請執行以下其中一個動作:

    • 修正投影片上的錯誤。

    • 在 [拼字檢查] 窗格中,按一下其中一個建議的單字,然後再按一下 [變更]。

    若要跳過錯誤,請執行下列其中一項動作:

    • 按一下 [略過],跳過錯誤的該單一例項。

    • 按一下 [全部略過],略過錯誤的所有例項。

    • 若要跳過所有文件中某個拼錯的字,請按一下 [新增],將其新增到字典中。

  4. 待您校正、略過或跳過錯誤之後,PowerPoint 便會移到下一個錯誤。 PowerPoint 將簡報檢閱完畢之後,您會看到一則訊息,告訴您拼字檢查已經完成。

  5. 按一下 [確定] 返回簡報。 

Excel

您可以在 Excel 中檢查拼字,但不能檢查文法。

一次檢查所有拼字

  1. 在 [校閱] 索引標籤上,按一下 [拼字檢查]。

    附註: 如果沒有偵測到拼字錯誤,或是字典中已包含您嘗試新增的字詞,[拼字檢查] 對話方塊就不會開啟。

  2. 執行下列任何一個動作。

    若要

    執行此動作

    變更單字

    在 [建議] 下,按一下要使用的單字,然後按一下 [變更]。

    變更這份文件中這個單字的所有出現處。

    在 [建議] 下,按一下要使用的單字,然後按一下 [全部變更]。

    忽略這個單字,並且移到下一個拼錯的單字

    按一下 [略過一次]。

    忽略這份文件中出現的這個單字,並且移到下一個拼錯的單字

    按一下 [全部略過]。

另請參閱

檢查不同語言的拼字及文法

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與我們的其中一個 Office 支援專員連絡以深入了解您的意見。

×