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Id. de artículo: 910341 - Última revisión: miércoles, 05 de diciembre de 2007 - Versión: 2.1

Mensajes de error que puede recibir cuando trata de descargar e instalar actualizaciones desde el sitio Web Windows Update, desde Microsoft Update o desde un servidor WSUS: "0x800704DD", "0x80240020" o ambos



Importante: este artículo contiene información acerca de cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si se produce algún problema. Para obtener información acerca de cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Definición del Registro de Microsoft Windows

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Resumen

En este artículo se describe cómo solucionar los problemas que indican los mensajes de error que aparecen al intentar descargar actualizaciones de los sitios Web Microsoft Windows Update o Microsoft Update, o desde un servidor Microsoft Windows Server Updates Services (WSUS). Para solucionar este problema, la sección "Resolución" incluye procedimientos para Microsoft Windows 2000, Microsoft Windows Server 2003 y Microsoft Windows XP. En este artículo también se incluye una sección "Solución alternativa". Puede seguir los pasos de la sección "Solución alternativa" si con el procedimiento de la sección "Resolución" no se resuelve el problema.

Síntomas

Cuando intenta descargar e instalar actualizaciones desde los sitios de Microsoft Windows Update Web o Microsoft Update Web, o desde un servidor Windows Server Update Services (WSUS), puede aparecer alguno de los mensajes de error siguientes:
0x800704DD
0x80240020

Causa

Este problema se produce si el servicio Actualizaciones automáticas no puede suplantar al usuario que ha iniciado sesión para terminar la descarga e instalación de la actualización.

Solución

Para resolver este problema en un equipo que ejecuta Windows 2000, siga los pasos de la sección A. Para resolverlo en un equipo que ejecuta Windows Server 2000 o Windows XP, siga los pasos de la sección B.

Sección A: Windows 2000

Paso 1: iniciar sesión en Microsoft Internet Explorer y ejecutarlo como un usuario que sea miembro del grupo local Administradores

  1. Inicie sesión como un usuario que sea miembro del grupo local Administradores.
  2. Haga clic con el botón secundario del mouse en el icono Internet Explorer, haga clic en Ejecutar como y ejecute el programa como un usuario que sea miembro del grupo local Administradores.
  3. Visite el sitio Web Windows Update, el sitio Web Microsoft Update o conéctese a un servidor WSUS.

Paso 2: comprobar que está instalado Cliente para redes Microsoft

  1. Haga clic en Inicio y en Ejecutar, escriba ncpa.cpl y haga clic en Aceptar.
  2. Haga clic con el botón secundario del mouse en la conexión de área local que esté asociada al adaptador de red y haga clic en Propiedades.
  3. Compruebe que Cliente para redes Microsoft aparece en el cuadro Esta conexión utiliza los siguientes elementos. Compruebe que la casilla que aparece junto a Cliente para redes Microsoft está activada. Si Cliente para redes Microsoft no aparece en el cuadro Esta conexión utiliza los siguientes elementos, siga estos pasos:
    1. Haga clic en Instalar, haga clic en Cliente y haga clic en Agregar.
    2. Haga clic en Cliente para redes Microsoft, haga clic en Aceptar y haga clic en .

Paso 3: comprobar que el Servicio de transferencia inteligente en segundo plano y el Servicio de notificación de sucesos de sistema están iniciados

Nota: el Servicio de transferencia inteligente en segundo plano (BITS, Background Intelligent Transfer Service) depende del Servicio de notificación de sucesos de sistema (SENS, System Event Notification Service) en Windows 2000.
  1. Haga clic en Inicio y en Ejecutar, escriba services.msc y haga clic en Aceptar.
  2. En la lista Nombre, haga doble clic en Notificación de sucesos de sistema.
  3. En el cuadro Tipo de inicio, haga clic en Automático.
  4. Haga clic en Inicio, espere a que el servicio se inicie y haga clic en Aceptar.
  5. Repita los pasos 2 a 4 de este procedimiento para el Servicio de transferencia inteligente en segundo plano.

Paso 4: iniciar sesión en la consola de Windows 2000 Server

Nota: este paso sólo es aplicable en Windows 2000 Server.

Nota: BITS no admite sesiones de Servicio de Terminal Server en Windows 2000. BITS puede enviar el trabajo de descarga sólo con credenciales de equipo. Si el firewall o el servidor proxy requieren autenticación de usuario, el trabajo de descarga no podrá ejecutarse.
  1. Inicie sesión en el equipo de forma local. No use una sesión de Servicios de Terminal Server.
  2. Visite el sitio Web Windows Update, el sitio Web Microsoft Update o conéctese a un servidor WSUS.

Paso 5: comprobar que las entradas del Registro siguientes están presentes

Advertencia: pueden producirse problemas graves si modifica incorrectamente el Registro mediante el Editor del Registro o con cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.
  1. Haga clic en Inicio y en Ejecutar, escriba Regedit y haga clic en Aceptar.
  2. Expanda la siguiente subclave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\SensLogn
  3. Comprobar que las entradas del Registro siguientes están presentes
    Contraer esta tablaAmpliar esta tabla
    NombreTipo de datos:Información del valor
    AsynchronousDWORD00000001
    DLLNameCadenaWlNotify.dll
    ImpersonateDWORD00000001
    LockCadenaSensLockEvent
    LogoffCadenaSensLogoffEvent
    LogonCadenaSensLogonEvent
    MaxWaitDWORD00000258
    SafeDWORD00000001
    ShutdownCadenaSensShutdownEvent
    StartScreenSaverCadenaSensStartScreenSaverEvent
    StartShellCadenaSensStartShellEvent
    Startup CadenaSensStartupEvent
    StopScreenSaverCadenaSensStopScreenSaverEvent
    UnlockCadenaSensUnlockEvent
  4. Realice los cambios o incorporaciones necesarios.

    En el ejemplo siguiente se explica cómo cambiar el valor de la entrada del Registro Shutdown:
    1. Haga clic con el botón secundario del mouse en Shutdown y, a continuación, haga clic en Modificar.
    2. En el cuadro Información del valor, escriba SensShutdownEvent para sobrescribir el valor existente y haga clic en Aceptar.
    En el ejemplo siguiente se explica cómo agregar una nueva entrada del Registro:
    1. En el panel izquierdo, haga clic en SensLogn.
    2. Haga clic en Modificar, seleccione Nuevo y haga clic en el tipo de valor que desee. En nuestro ejemplo, haga clic en Valor DWORD.
    3. Escriba Impersonate y presione ENTRAR.
    4. Haga clic con el botón secundario del mouse en Impersonate y, a continuación, haga clic en Modificar.
    5. En el cuadro Información del valor, escriba 1 y haga clic en Aceptar.
  5. Si ha hecho algún cambio en el Registro, reinicie el equipo. Después, vuelva a intentar descargar e instalar la actualización.

Sección B: Windows Server 2003 y Windows XP

Paso 1: iniciar sesión en Internet Explorer y ejecutarlo como un usuario que sea miembro del grupo local Administradores

  1. Inicie sesión como un usuario que sea miembro del grupo local Administradores.
  2. Haga clic con el botón secundario del mouse en el icono Internet Explorer, haga clic en Ejecutar como y ejecute el programa como un usuario que sea miembro del grupo local Administradores.
  3. Visite el sitio Web Windows Update, el sitio Web Microsoft Update o conéctese a un servidor WSUS.

Paso 2: comprobar que las entradas del Registro siguientes están presentes

Advertencia: pueden producirse problemas graves si modifica incorrectamente el Registro mediante el Editor del Registro o con cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.
  1. Haga clic en Inicio y en Ejecutar, escriba Regedit y haga clic en Aceptar.
  2. Expanda la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\SensLogn
  3. Comprobar que las entradas del Registro siguientes están presentes
    Contraer esta tablaAmpliar esta tabla
    NombreTipo de datos:Información del valor
    AsynchronousDWORD00000001
    DisconnectCadenaSensDisconnectEvent
    DLLNameCadenaWlNotify.dll
    ImpersonateDWORD00000001
    LockCadenaSensLockEvent
    LogoffCadenaSensLogoffEvent
    LogonCadenaSensLogonEvent
    MaxWaitDWORD00000258
    PostShellCadenaSensPostShellEvent
    ReconnectCadenaSensReconnectEvent
    SafeDWORD00000001
    ShutdownCadenaSensShutdownEvent
    StartScreenSaverCadenaSensStartScreenSaverEvent
    StartShellCadenaSensStartShellEvent
    Startup CadenaSensStartupEvent
    StopScreenSaverCadenaSensStopScreenSaverEvent
    UnlockCadenaSensUnlockEvent
  4. Realice los cambios o incorporaciones necesarios.

    En el ejemplo siguiente se explica cómo cambiar el valor de la entrada del Registro Shutdown:
    1. Haga clic con el botón secundario del mouse en Shutdown y, a continuación, haga clic en Modificar.
    2. En el cuadro Información del valor, escriba SensShutdownEvent para sobrescribir el valor existente y haga clic en Aceptar.
    En el ejemplo siguiente se explica cómo agregar una nueva entrada del Registro:
    1. En el panel izquierdo, haga clic en SensLogn.
    2. Haga clic en Modificar, seleccione Nuevo y haga clic en el tipo de valor que desee. En nuestro ejemplo, haga clic en Valor DWORD.
    3. Escriba Impersonate y presione ENTRAR.
    4. Haga clic con el botón secundario del mouse en Impersonate y, a continuación, haga clic en Modificar.
    5. En el cuadro Información del valor, escriba 1 y haga clic en Aceptar.
  5. Si ha hecho algún cambio en el Registro, reinicie el equipo. Después, vuelva a intentar descargar e instalar la actualización.
Nota: las subclaves y valores del Registro de la tabla en el paso 3 sólo corresponden a Windows Server 2003 y Windows XP. No puede importar estas subclaves y valores del Registro desde un equipo basado en Windows Server 2003 o en Windows XP en un equipo basado en Windows 2000.

Solución

Como solución alternativa para este problema, configure Actualizaciones automáticas para descargar e instalar actualizaciones. Para ello, siga estos pasos.

Windows 2000

  1. Haga clic en Inicio, seleccione Configuración y haga clic en Panel de control.
  2. Haga doble clic en Actualizaciones automáticas.
  3. Haga clic en Descargar automáticamente las actualizaciones e instalarlas en la fecha y hora especificadas.
  4. Haga clic para seleccionar la fecha y la hora a las que desee descargar e instalar las actualizaciones y después haga clic en Aceptar.

Windows XP

  1. Haga clic en Inicio y, después, en Panel de control.
  2. Haga doble clic en Actualizaciones automáticas.
  3. Haga clic en Automático (recomendado).
  4. Haga clic para seleccionar la fecha y la hora a las que desee descargar e instalar las actualizaciones y después haga clic en Aceptar.

Windows Server 2003

  1. Haga clic en Inicio y, después, en Panel de control.
  2. Haga doble clic en Actualizaciones automáticas.
  3. Haga clic para activar la siguiente casilla:
    Mantener mi equipo al día. Con esta opción habilitada, el software Windows Update puede actualizarse automáticamente antes de aplicar cualquier otra actualización.
  4. Haga clic en Descargar automáticamente las actualizaciones e instalarlas en la fecha y hora especificadas.
  5. Haga clic para seleccionar la fecha y la hora a las que desee descargar e instalar las actualizaciones y después haga clic en Aceptar.
Para obtener más información acerca de cómo programas Actualizaciones automáticas, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
327838  (http://support.microsoft.com/kb/327838/ ) Cómo programar actualizaciones automáticas en Windows Server 2003, en Windows XP y en Windows 2000

Referencias

Para obtener más información al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
902093  (http://support.microsoft.com/kb/902093/ ) Cómo leer el archivo Windowsupdate.log

La información de este artículo se refiere a:
  • Microsoft Update
  • Microsoft Windows Update
Palabras clave: 
kbtshoot kbprb KB910341

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