Błąd Stop podczas próby pobrania aktualizacji za pomocą usługi Windows Update na komputerze z systemem Windows Vista: 0x80070246

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 942968 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Próba pobrania aktualizacji za pomocą usługi Windows Update na komputerze z systemem Windows Vista może spowodować wyświetlenie następującego komunikatu o błędzie Stop:
STOP 0x80070246
ERROR_ILLEGAL_CHARACTER
Ponadto w pliku WindowsUpdate.log może zostać zarejestrowany następujący wpis:
Błąd usługi Aktualizacje automatyczne; Instalacja zawartości; Błąd instalacji: system Windows nie może zainstalować następującej aktualizacji z powodu błędu 0x80070246: nazwa_aktualizacji
Uwaga Plik WindowsUpdate.log znajduje się w następującej lokalizacji:
%Windir%\WindowsUpdate.log

Przyczyna

Ten problem występuje, gdy plik GlobalInstallOrder.xml jest uszkodzony. Plik GlobalInstallOrder.xml znajduje się w następującej lokalizacji:
%Windir%\Winsxs\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.0.6000.16386_none_07289f4cca5f6990\GlobalInstallOrder.xml

Rozwiązanie

Aby rozwiązać ten problem, należy zamienić plik GlobalInstallOrder.xml w systemie na taki sam plik znajdujący się na nośniku instalacyjnym systemu Windows Vista. W tym celu wykonaj następujące czynności:
  1. Pobierz sterownik filtru WIM z zestawu zautomatyzowanej instalacji systemu Windows (Windows AIK). Aby pobrać i zainstalować zestaw Windows AIK, odwiedź następującą witrynę firmy Microsoft w sieci Web:
    http://www.microsoft.com/downloads/details.aspx?displaylang=pl&FamilyID=c7d4bc6d-15f3-4284-9123-679830d629f2
  2. Kliknij przycisk Start, wskaż polecenie Wszystkie programy, kliknij polecenie Microsoft Windows AIK, kliknij prawym przyciskiem myszy polecenie Wiersz polecenia narzędzi środowiska preinstalacyjnego systemu Windows, a następnie kliknij polecenie Uruchom jako administrator.

    Jeśli zostanie wyświetlony monit o podanie hasła administratora, wpisz hasło. Jeśli zostanie wyświetlony monit o kontynuowanie, kliknij przycisk Kontynuuj.
  3. W wierszu polecenia wpisz następujące polecenie, a następnie naciśnij klawisz ENTER:
    MD c:\Mount
    To polecenie tworzy folder o nazwie Mount.
  4. Umieść nośnik instalacyjny systemu Windows Vista w stacji dysków CD lub DVD.
  5. W wierszu polecenia wpisz następujące polecenie, a następnie naciśnij klawisz ENTER:
    Imagex /mount litera_stacji_dvd\sources\install.wim 1 \mount
  6. W wierszu polecenia wpisz następujące polecenie, a następnie naciśnij klawisz ENTER:
    CD \mount\Windows\winsxs\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.0.6000.16386_none_07289f4cca5f6990
    To polecenie powoduje przejście do folderu źródłowego.
  7. W wierszu polecenia wpisz następujące polecenie, a następnie naciśnij klawisz ENTER:
    xcopy GlobalInstallOrder.xml %windir%\winsxs\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.0.6000.16386_none_07289f4cca5f6990
    To polecenie kopiuje plik GlobalInstallOrder.xml do folderu docelowego.

Więcej informacji

Aby uzyskać więcej informacji na temat zamieniania uszkodzonego pliku za pomocą narzędzia Sfc.exe, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
929833 Niektóre funkcje systemu Windows Vista mogą nie działać lub system Windows Vista może przestać odpowiadać

Właściwości

Numer ID artykułu: 942968 - Ostatnia weryfikacja: 14 września 2010 - Weryfikacja: 4.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows Update
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Microsoft Update
Słowa kluczowe: 
kbexpertiseinter kbtshoot kbprb KB942968

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com