Messaggio di errore quando si tenta di connettersi al sito Windows Update o Microsoft Update: "0x80240030"

Traduzione articoli Traduzione articoli
Identificativo articolo: 957309 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di connettersi al sito Web Windows Update o Microsoft Update, viene potrebbe essere visualizzato il seguente messaggio di errore:
0x80240030

Cause

Questo problema può verificarsi se il proxy o firewall vengono configurate in modo non corretto. In questo caso, la connessione dal computer client al server di Windows Update ha esito negativo.

Risoluzione

Per risolvere il problema, utilizzare i metodi riportati di seguito nell'ordine in cui sono presentate.

Metodo 1: Rimuovere i caratteri dall'elenco di eccezioni proxy e quindi deselezionare la cache del proxy

Attenersi alla procedura appropriata per il sistema operativo è in esecuzione.

Windows XP, Windows Server 2003 e Windows 2000

  1. Fare clic su Start , scegliere Esegui , digitare notepad e quindi fare clic su OK o premere INVIO.
  2. Copiare i seguenti comandi e quindi incollarlo nuovamente la finestra aperta del blocco note:
    proxycfg -d
    net stop wuauserv
    net start wuauserv
    
  3. Fare clic su Salva con nome dal menu file e quindi digitare fixproxy.bat .
  4. Fare clic su tipo e quindi selezionare Tutti I file .
  5. Salvare il file fixproxy.bat sul desktop.
  6. Fare doppio clic sul fixproxy.bat file per registrare i file di Windows Update
  7. Provare a reinstallare gli aggiornamenti
Nota Quando gli aggiornamenti vengono installati correttamente, è possibile eliminare il file fixproxy.bat. Se questa procedura non viene risolto il problema, passare al metodo 2.

Windows Vista e Windows Server 2008

  1. Fare clic su Start
    Riduci l'immagineEspandi l'immagine
    Start button
    e quindi digitare il blocco note nella casella di testo Inizia ricerca .
  2. Fare clic su Blocco note nell'elenco programmi .
  3. Copiare i seguenti comandi e quindi incollarlo nuovamente la finestra aperta del blocco note:
    proxycfg -d
    net stop wuauserv
    net start wuauserv
    
  4. Fare clic su file , fare clic su Salva con nome e quindi digitare fixproxy.bat .
  5. Fare clic su Salva come tipo e quindi selezionare tutti i file (*. *) .
  6. Salvare il file fixproxy.bat sul desktop.
  7. Fare clic con il pulsante destro del mouse sul fixproxy.bat file e quindi fare clic su Esegui come amministratore .

    Riduci l'immagineEspandi l'immagine
    User Account Control
				permission
    Se viene chiesto di immettere una password di amministratore o di confermare, digitare la password o fare clic su Continua .
  8. Provare a installare nuovamente gli aggiornamenti.
Nota Quando gli aggiornamenti vengono installati correttamente, è possibile eliminare il file fixproxy.bat.

Metodo 2: Attiva l'opzione "Rileva automaticamente impostazioni" in Internet Explorer

Nota Utilizzare questo metodo se il sistema operativo in uso è Windows 2000, Windows XP o Windows Server 2003.
  1. Avviare Windows Internet Explorer.
  2. Nel menu Strumenti , fare clic su Internet opzioni .

    Nota Se dal menu Strumenti di Internet Explorer è disponibile in Internet Explorer, premere il tasto ALT per visualizzare il menu.
  3. Fare clic sulla scheda connessioni e quindi scegliere LAN impostazioni .
  4. Fare clic per selezionare la casella di controllo Rileva automaticamente impostazioni e quindi fare clic su OK .
  5. Provare a installare nuovamente gli aggiornamenti.

Proprietà

Identificativo articolo: 957309 - Ultima modifica: mercoledì 10 settembre 2008 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Update
  • Microsoft Update
Chiavi: 
kbmt kbprb kbexpertisebeginner kbtshoot KB957309 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 957309
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com