Mensaje de error cuando intenta instalar actualizaciones mediante el sitio Web de Windows Update o el sitio Web de Microsoft Update: "0 x 80070422"

Seleccione idioma Seleccione idioma
Id. de artículo: 958043 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta instalar actualizaciones mediante el sitio Web de Windows Update o el sitio Web de Microsoft Update, puede recibir el mensaje de error siguiente:
0 x 80070422

Causa

Este problema puede producirse si no se está ejecutando un servicio necesario.

Solución

Microsoft Windows 2000, Windows XP y Windows Server 2003

Para resolver este problema, inicie los servicios necesarios. Para hacer esto en Windows 2000, en Windows XP o en Windows Server 2003, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo Bloc de notasy, a continuación, haga clic en ACEPTAR o presione ENTRAR.
  2. Copie el texto siguiente y, a continuación, pegue el texto en el Bloc de notas:
    sc config wuauserv start= auto
    sc config bits start= auto
    sc config DcomLaunch start= auto
    net stop wuauserv
    net start wuauserv
    net stop bits
    net start bits
    net start DcomLaunch
    
  3. Haga clic en Archivo, haga clic en Guardar comoy, a continuación, escriba Repair.bat.
  4. En el Guardar como tipo Haga clic en Todos los archivos.
  5. En el Guardar en Haga clic en Escritorioy, a continuación, haga clic en Guardar.
  6. En el Archivo menú, haga clic en Salir.
  7. Haga doble clic en el archivo Repair.bat que guardó en el paso 5. Esta acción inicia los servicios necesarios.
  8. Intente volver a instalar las actualizaciones. Si puede instalar las actualizaciones, elimine el archivo de Repair.bat. Para eliminar el archivo Repair.bat, haga clic en Repair.bat, haga clic en Eliminary, a continuación, haga clic en .

Windows Vista y Windows Server 2008

Para iniciar los servicios necesarios en Windows Vista o en Windows Server 2008, siga estos pasos:
  1. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
     Botón Inicio
    , tipo Bloc de notas en el Iniciar búsqueda cuadro y haga clic en Bloc de notas en el Programas lista.
  2. Copie el texto siguiente y, a continuación, pegue el texto en el Bloc de notas:
    sc config wuauserv start= auto
    sc config bits start= auto
    sc config DcomLaunch start= auto
    net stop wuauserv
    net start wuauserv
    net stop bits
    net start bits
    net start DcomLaunch 
    
  3. Haga clic en Archivo, haga clic en Guardar comoy, a continuación, escriba Repair.bat.
  4. En el Guardar como tipo Haga clic en Todos los archivos (*. *).
  5. En el Guardar en Haga clic en Escritorioy, a continuación, haga clic en Guardar.
  6. En el Archivo menú, haga clic en Salir.
  7. Derecha - haga clic en el archivo Repair.bat que guardó en el paso 5 y, a continuación, haga clic en Ejecutar como administrador. Esta acción inicia los servicios necesarios.

    Contraer esta imagenAmpliar esta imagen
    Permiso de Control de acceso de usuario
    Si se le pide una contraseña de administrador o una confirmación, escriba la contraseña o haga clic en Continuar.
  8. Intente volver a instalar las actualizaciones. Si puede instalar las actualizaciones, elimine el archivo de Repair.bat. Para eliminar el archivo Repair.bat, haga clic en Repair.bat, haga clic en Eliminary, a continuación, haga clic en ..
Para obtener más información acerca de cómo solucionar este problema con Windows Update o Microsoft Update, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support

Propiedades

Id. de artículo: 958043 - Última revisión: martes, 11 de septiembre de 2012 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Windows Update
  • Microsoft Update
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Starter
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Palabras clave: 
kbwindowsupdate kbexpertisebeginner kbtshoot kbprb kbmt KB958043 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 958043

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com