Windows Update Web サイトまたは Microsoft Update Web サイトを使用して更新プログラムをインストールするときにエラー コード "0x8007064C" が表示される

文書翻訳 文書翻訳
文書番号: 958055 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Windows Update Web サイトまたは Microsoft Update Web サイトで利用可能な更新プログラムを検索するときに、次のエラー コードが表示されます。
0x8007064C

原因

この問題は、Windows Update または Microsoft Update が、ダウンロードされた更新プログラムを見つけることができない場合に発生することがあります。

解決方法

この問題を解決するには、以下の方法に記載されている手順を実行します。 方法 1 から始めます。方法 1 で問題が解決しない場合は、方法 2 に進みます。

方法 1 : Windows Update のダウンロード フォルダの名前を変更する

この問題を解決するには、Windows Update の一時ダウンロード フォルダの名前を変更します。

Windows Update の一時ダウンロード フォルダの名前を変更するには、使用している Windows のバージョンに応じて以下の手順を実行します。

重要 : ダウンロード済みの更新プログラムをまだインストールしていない場合は、それらの更新プログラムを Windows Update Web サイトまたは Microsoft Update Web サイトを使用して再度ダウンロードする必要があります。

Windows Vista および Windows Server 2008

Windows Vista および Windows Server 2008 の場合は、次の手順を実行します。
  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[検索の開始] ボックスに notepad と入力して、Enter キーを押します。
  2. 次のコマンドをコピーしてメモ帳の新規文書に貼り付けます。
    net stop wuauserv

    cd %systemroot%\SoftwareDistribution

    ren Download Download.old

    net start wuauserv
  3. [ファイル] メニューの [名前を付けて保存] をクリックします。
  4. [保存する場所] ボックスの一覧の [デスクトップ] をクリックします。
  5. [ファイルの種類] ボックスの一覧の [すべてのファイル (*.*)] をクリックします。
  6. [ファイル名] ボックスに Rename.bat と入力します。
  7. [保存] をクリックします。
  8. [ファイル] メニューの [メモ帳の終了] をクリックし、メモ帳を終了します。
  9. デスクトップで Rename.bat ファイルを右クリックし、[管理者として実行] をクリックします。

    元に戻す画像を拡大する
    ユーザー アカウント制御の許可
    管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [続行] をクリックします。
  10. Windows Update Web サイトまたは Microsoft Update Web サイトを使用して、更新プログラムを再度インストールします。
  11. 更新プログラムが正常にインストールされた場合は、手順 1. 〜 7. で保存した Rename.bat ファイルを削除します。

Windows 2000、Windows XP、および Windows Server 2003

Windows 2000、Windows XP、および Windows Server 2003 の場合は、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、[名前] ボックスに notepad と入力し、[OK] をクリックします。
  2. 次のコマンドをコピーしてメモ帳の新規文書に貼り付けます。
    net stop wuauserv

    cd %systemroot%\SoftwareDistribution

    ren Download Download.old

    net start wuauserv
  3. [ファイル] メニューの [名前を付けて保存] をクリックします。
  4. [保存する場所] ボックスの一覧の [デスクトップ] をクリックします。
  5. [ファイルの種類] ボックスの一覧の [すべてのファイル] をクリックします。
  6. [ファイル名] ボックスに Rename.bat と入力します。
  7. [保存] をクリックします。
  8. [ファイル] メニューの [メモ帳の終了] をクリックし、メモ帳を終了します。
  9. デスクトップで Rename.bat ファイルをダブルクリックします。
  10. Windows Update Web サイトまたは Microsoft Update Web サイトを使用して、更新プログラムを再度インストールします。
  11. 更新プログラムが正常にインストールされた場合は、手順 1. 〜 7. で保存した Rename.bat ファイルを削除します。
  • 問題が解決されない場合は、方法 2. に進みます。
  • 問題が解決され、更新プログラムを正常にダウンロードしてインストールできた場合は、Download.old フォルダを削除して、ディスク領域を回復しても問題ありません。

方法 2 : 更新プログラムを手動でダウンロードしてインストールする

更新プログラムを手動でダウンロードしてインストールするには、以下の手順を実行します。
  1. 失敗した更新プログラムに対応する「サポート技術情報」 (Microsoft Knowledge Base) の文書番号を確認します。 これを行うには、以下のいずれかの操作を実行します。
    • エラー コード メッセージを参照します。
    • Windows Update Web サイトまたは Microsoft Update Web サイトで、更新履歴を確認します。 これを行うには、以下の手順を実行します。
      1. 次の Microsoft Update Web サイトにアクセスします。
        http://update.microsoft.com
      2. [オプション] の下にある [更新履歴の表示] をクリックします。
      3. [更新プログラム] 列で、失敗した更新プログラムに対応する「サポート技術情報」の文書番号を確認します。
  2. 以下の Windows ダウンロード Web サイトにアクセスします。
    http://www.microsoft.com/japan/windows/downloads/default.mspx
  3. [ダウンロード] ページの検索ボックスに、手順 1. で確認した「サポート技術情報」 (Microsoft Knowledge Base) の文書番号を入力し、虫眼鏡ボタンをクリックします。

    : 更新プログラムに対応する「サポート技術情報」の文書番号が KB123456 の場合は、[ダウンロード] ページの検索ボックスに 123456 と入力し、虫眼鏡ボタンをクリックします。
  4. 検索結果の一覧を参照し、ダウンロードのリンクが記載されている「サポート技術情報」の資料を見つけます。

    : Windows の検証を求めるメッセージが表示されることがあります。 Windows の検証を求めるメッセージが表示されたら、指示に従って Windows を検証し、ダウンロードを続行します。
  5. [ダウンロード] をクリックします。ファイルを実行するか保存するかを確認するメッセージが表示されたら [保存] をクリックします。 ファイルをデスクトップに保存します。
  6. ダウンロードが完了したら、更新プログラムをダブルクリックしてインストールします。
: 更新プログラムが Windows のバージョンに適していない場合は、更新プログラムのインストールが引き続き失敗することがあります。

プロパティ

文書番号: 958055 - 最終更新日: 2009年5月21日 - リビジョン: 1.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows Update
  • Microsoft Update
キーワード:?
kbexpertisebeginner kbtshoot kberrmsg kbprb KB958055
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com