Vzorce můžou někdy kromě vrácení neočekávaných hodnot taky způsobit chybové hodnoty. Připravili jsme si pro vás několik nástrojů, které vám pomůžou najít chyby, zjistit jejich příčiny a určit řešení.

Poznámka: Tohle téma se zabývá technikami, které jsou užitečným pomocníkem při opravě chyb ve vzorcích. Seznam metod není vyčerpávající a nezaručuje opravu všech možných chyb ve vzorcích. Pomoc s konkrétními chybami můžete najít na fóru komunity Excelu, kde si vyhledáte podobné otázky nebo uveřejníte svou vlastní.

Odkaz na fórum komunity Excelu

Jak zadávat jednoduché vzorce?

Vzorce jsou rovnice provádějící výpočty hodnot v listu. Vzorec vždy začíná rovnítkem (=). Například v tomhle vzorci sčítáme 3 a 1:

=3+1

Vzorec může taky obsahovat některé (nebo všechny) tyto části: funkce, odkazy, operátory a konstanty.

Části vzorce

Části vzorce

  1. Funkce: Funkce v Excelu jsou vytvořenými vzorci, které provádějí konkrétní výpočty. Například funkce PI() vrátí hodnotu čísla pí: 3,142...

  2. Odkazy: Odkazují na jednotlivé buňky nebo oblasti buněk. A2 vrátí hodnotu v buňce A2.

  3. Konstanty: Číselné nebo textové hodnoty zadané přímo do vzorce, třeba hodnota 2.

  4. Operátory: Operátor * (hvězdička) slouží k násobení a operátor ^ (stříška) umocní číslo na zadanou mocninu. Pomocí + a - můžete přičítat a odečítat hodnoty a pomocí / můžete dělit.

    Poznámka: Některé funkce vyžadují argumenty. Argumenty jsou hodnoty, které určité funkce používají k provádění výpočtů. Pokud se vyžadují, umísťují se argumenty mezi závorky funkce (). Funkce PI nevyžaduje žádné argumenty, proto jsou závorky prázdné. Některé funkce vyžadují jeden nebo více argumentů a můžou mít místo pro další argumenty. K oddělení argumentů je potřeba používat čárku nebo středník (;) v závislosti na místním nastavením.

Funkce SUMA například vyžaduje jenom jeden argument, celkově jich ale může mít až 255.

SUMA

=SUMA(A1:A10) je příkladem jednoho argumentu.

=SUMA(A1:A10; C1:C10) je příkladem několika argumentů.

V následující tabulce najdete souhrn některých nejběžnějších chyb, které uživatelé při zadávání vzorců dělají. Pak taky vysvětluje, jak takové chyby opravit:

Je třeba zkontrolovat následující skutečnosti

Další informace

Každá funkce musí začínat symbolem = (rovná se)

Pokud znaménko rovná se vypíšete, může se typ textu zobrazit jako text nebo jako datum. Pokud například napíšete SUMA(A1:A10),Excel zobrazí textový řetězec SUMA(A1:A10) a neprovádí výpočet. Pokud napíšete 11/2, Excel místo dělení 11 krát 2 zobrazí datum 2. listopadu (za předpokladu, že je formát buňky obecný).

Párování všech levých a pravých závorek

Zkontrolujte, že máte všechny závorky v páru (vždycky levou i pravou). Pokud ve vzorci použijete funkci, musí být všechny závorky správně umístěné, jinak funkce nebude správně fungovat. Tady je příklad: Vzorec = KDYŽ(B5<0);"Není platné";B5*1,05) nebude fungovat, protože obsahuje dvě pravé závorky a jenom jednu levou závorku (přitom by v něm měla být jenom jedna levá a jedna pravá závorka). Vzorec musí vypadat takhle: =KDYŽ(B5<0;"Není platné";B5*1,05).

Označení oblasti pomocí dvojtečky

Když chcete odkazovat na oblast buněk, oddělte odkaz na první buňku v oblasti od poslední buňky v oblasti pomocí dvojtečky (:). Například =SUMA(A1:A5), ne =SUMA(A1 A5),která by vrátila #NULL! Chyba.

Zadání všech požadovaných argumentů

Některé funkce vyžadovaly argumenty. Taky se ujistěte, že jste nezadali příliš moc argumentů.

Zadání správných argumentů

Některé funkce, jako třeba SUMA, vyžadují číselné argumenty. Jiné funkce, jako třeba NAHRADIT, vyžadují minimálně pro jeden ze svých argumentů textovou hodnotu. Pokud jako argument použijete nesprávný typ dat, Excel může vrátit neočekávané výsledky nebo zobrazit chybu.

Počet vnořených funkcí nesmí přesáhnout 64

V rámci jedné funkce můžete zadat nebo vnořit maximálně 64 úrovní funkcí.

Uzavření názvů jiných listů do jednoduchých uvozovek

Pokud vzorec odkazuje na hodnoty nebo buňky v jiných listech nebo sešitech a název daného listu nebo sešitu obsahuje mezery nebo jiné než abecední znaky, musíte jeho název zadat do jednoduchých uvozovek ('), například ='Čtvrtletní data'!D3 nebo =‘123’!A1.

Když na list odkazujete ve vzorci, umístěte za jeho název vykřičník (!)

Pokud třeba chcete, aby se vám vrátila hodnota buňky D3 z listu s názvem Čtvrtletní data ve stejném sešitu, použijte vzorec ='Čtvrtletní data'!D3.

Uvedení cesty k externím sešitům

Zkontrolujte, jestli každý externí odkaz obsahuje název sešitu a cestu k danému sešitu.

Odkaz na sešit obsahuje název sešitu a musí být uzavřený v závorkách ([název_sešitu.xlsx]). Odkaz musí taky obsahovat název listu v sešitu.

Odkazovat můžete ve vzorci i na sešit, který v Excelu zrovna otevřený není. Stačí zadat úplnou cestu k souboru, jak vidíte třeba tady: =ŘÁDKY('C:\My Documents\[Operace Q2.xlsx]Prodej'!A1:A8). Tenhle vzorec vrátí počet řádků v oblasti, která zahrnuje buňky A1 až A8 v jiném sešitu (8).

Poznámka: Pokud celá cesta obsahuje mezery, jako je to třeba v příkladu výš, cestu je potřeba uzavřít do jednoduchých uvozovek (na začátku cesty a za název listu před vykřičníkem).

Zadání čísel bez formátování

Když čísla zadáváte do vzorce, neformátujte je. Pokud je hodnota, kterou chcete zadat, třeba 1,000 Kč, do vzorce zadejte 1000. Když jako součást čísla zadáte taky čárku, Excel ji bude pokládat za oddělovač. Jestli chcete, aby se čísla zobrazovala s oddělovačem tisíců nebo miliónů nebo se symbolem měny, naformátujte buňky až po zadání čísel.

Pokud například chcete přidat 3100 k hodnotě v buňce A3 a zadáte vzorec =SUMA(3 100;A3),Excel přidá čísla 3 a 100 a potom tento součet přidá k hodnotě z A3, místo toho, abyste přidali 3100 do A3, což by bylo =SUMA(3100;A3). Nebo pokud zadáte vzorec =ABS(-2 134), Excel zobrazí chybu, protože funkce ABS přijímá jenom jeden argument: =ABS(-2134).

Můžete využít určitá pravidla pro kontrolu chyb ve vzorcích. Tato pravidla nezaručují, že se na příslušném listu nevyskytují žádné chyby, ale odhalí většinu běžných chyb. Podle potřeby můžete jednotlivá pravidla vypnout nebo zapnout.

Chyby jde označovat a opravovat dvěma způsoby. Je možné opravovat jednu chybu po druhé (jako právě při kontrole pravopisu), nebo je jde opravovat hned, jak je při zadávání dat na listu uděláte.

Chybu můžete vyřešit pomocí možností, které Excel, nebo ji můžete ignorovat kliknutím na Ignorovat chybu. Pokud chybu v určité buňce ignorujete, chyba v této buňce se nezobrazí při dalších kontrolách chyb. Všechny dříve ignorované chyby ale můžete obnovit tak, aby se znovu objevily.

  1. Pokud Excel v Windows, klikněte na >možnosti > vzorcenebo
    v Excel macu klikněte na nabídku Excel > Předvolby > Kontrola chyb

    V Excel 2007 klikněte na tlačítko Microsoft Office Obrázek tlačítka Office > Možnosti aplikace Excel > Vzorce.

  2. V části Kontrola chyb zaškrtněte políčko Povolit kontrolu chyb v pozadí. Všechny nalezené chyby se označí trojúhelníkem v levém horním rohu buňky.

    Buňka s problémem se vzorcem
  3. Jestliže chcete změnit barvu trojúhelníku označujícího chybu, vyberte požadovanou barvu v seznamu Označit chyby pomocí této barvy.

  4. V části Pravidla kontroly aplikace Excel zaškrtněte nebo zrušte zaškrtnutí políček u libovolného z následujících pravidel:

    • Buňky obsahující vzorce, kterémají za následek chybu : Vzorec neobsahuje očekávanou syntaxi, argumenty ani datové typy. Mezi chybové hodnoty patří #DIV/0!, #N/A, #NAME?, #NULL!, #NUM!, #REF!a #VALUE!. Každá z těchto chybových hodnot má různé příčiny a řeší se různými způsoby.

      Poznámka: Pokud zadáte chybovou hodnotu přímo do buňky, uloží se jako daná chybová hodnota, ale nebude označená jako chyba. Pokud ale na tuto buňku odkazuje vzorec v jiné buňce, vzorec vrátí chybovou hodnotu z téhle buňky.

    • Nekonzistentnívzorec počítaného sloupce v tabulkách: Počítaný sloupec může zahrnovat jednotlivé vzorce, které se liší od vzorce hlavního sloupce, což vytváří výjimku. Výjimky počítaného sloupce se vytvoří v případě, že uděláte některou z těchto věcí:

      • Zadáte do buňky počítaného sloupce jiná data než vzorec.

      • Zadejte vzorec do buňky počítaného sloupce a potom použijte kombinaci kláves Ctrl+Z nebo klikněte na Undo button na panelu nástrojů Rychlý přístup.

      • Zadáte do počítaného sloupce, který již obsahuje nejméně jednu výjimku, nový vzorec.

      • Zkopírujete do počítaného sloupce data neodpovídající vzorci daného počítaného sloupce. Pokud kopírovaná data obsahují vzorec, přepíše tento vzorec data v počítaném sloupci.

      • Přesunete nebo odstraníte v jiné oblasti listu buňku, na kterou odkazuje jeden či více řádků počítaného sloupce.

    • Buňky obsahující roky představovanéjako 2 číslice : Buňka obsahuje textové datum, které se při použití ve vzorcích může nesprávně interpretovat jako nesprávné století. Třeba datum ve vzorci =ROK("1/1/31") může představovat rok 1931 nebo 2031. Tohle pravidlo slouží ke kontrole dvojznačných kalendářních dat zadaných ve formátu textu.

    • Čísla formátovaná jako text nebo předchází apostrof: Buňka obsahuje čísla uložená jako text. K tomu obvykle dochází při importu dat z jiných zdrojů. Čísla uložená jako text mohou způsobit neočekávané chování při řazení, a proto je nejlepší je převést na čísla. '=SUMA(A1:A10) je vidět jako text.

    • Vzorce nekonzistentnís jinými vzorci v oblasti : Vzorec neodpovídá vzoru dalších vzorců v jeho blízkosti. V mnoha případech se vzorce, které sousedí s jinými vzorci, liší pouze použitými odkazy. V následujícím příkladu čtyř sousedních vzorců zobrazí Excel chybu vedle vzorce =SUMA(A10:C10) v buňce D4, protože sousední vzorce se zvyšují o jeden řádek a že jeden z nich se zvýší o 8 řádků – Excel očekává vzorec =SUMA(A4:C4).

      Pokud vzorec neodpovídá modelu sousedících vzorců, Excel zobrazí chybu.

      Jestliže odkazy použité ve vzorci nejsou konzistentní s odkazy v sousedících vzorcích, zobrazí aplikace Excel chybu.

    • Vzorce, které vymisíbuňky v oblasti : Vzorec nemusí automaticky obsahovat odkazy na data, která vložíte mezi původní oblast dat a buňku obsahující vzorec. Toto pravidlo porovnává odkazy ve vzorci s oblastí buněk, která ve skutečnosti sousedí s buňkou obsahující vzorec. Pokud sousední buňky obsahují další hodnoty a nejsou prázdné, Excel zobrazí vedle vzorce chybu.

      Excel při použití tohoto pravidla třeba vloží chybu vedle vzorce =SUMA(D2:D4), protože buňky D5, D6 a D7 sousedí s buňkami, na které vzorec odkazuje, a s buňkou, ve které je vzorec zapsán (D8), přičemž tyto buňky obsahují data, na která by vzorec měl taky odkazovat.

      Pokud vzorec vynechá buňky v oblasti, Excel zobrazí chybu.
    • Odemčené buňky obsahující vzorce:Vzorec není uzamčený kvůli ochraně. Ve výchozím nastavení jsou všechny buňky na listu zamknuté, takže je nelze změnit, když je list zamknutý. Můžete se tak vyhnout neúmyslnému omylu, jako je náhodné odstranění nebo změna vzorců. Tato chyba označuje, že je buňka nastavená tak, aby byla odemknutá, ale list není zamknutý. Zkontrolujte, jestli nechcete buňku zamknutou nebo ne.

    • Vzorce odkazující na prázdné buňky: Pokud vzorec obsahuje odkaz na prázdnou buňku, může to způsobit neočekávané výsledky, jako v následujícím příkladu.

      Předpokládejme, že chcete vypočítat průměr z čísel uvedených v následujícím sloupci buněk. Pokud je třetí buňka prázdná, nebude do výpočtu zahrnutá a výsledek bude 22,75. Jestli třetí buňka obsahuje nulu, výsledek bude 18,2.

      Pokud vzorec odkazuje na prázdné buňky, Excel zobrazí chybu.
    • Data zadaná v tabulce jsou neplatná:V tabulce je chyba ověření. Zkontrolujte nastavení ověření buňky tak, že na kartě Data > Data Tools > Data Validation.

  1. Vyberte list, ve kterém chcete hledat chyby.

  2. Pokud je list počítán ručně, přepočtěte jej stisknutím klávesy F9.

    Pokud se nezobrazí dialog Kontrola chyb, klikněte na kartu Vzorce > Závislosti vzorců > tlačítko Kontrola chyb.

  3. Pokud jste některé chyby dříve ignorovali, můžete je znovu překontrolovat následujícím způsobem – klikněte na Soubor > Možnosti > Vzorce. Pokud Excel macu, klikněte na nabídku Excel a > předvolby > kontrola chyb.

    V části Kontrola chyb klikněte na Obnovit ignorované chyby > OK.

    Kontrola chyb

    Poznámka: Obnovením ignorovaných chyb obnovíte všechny chyby na všech listech v aktivním sešitu.

    Tip: Můžete taky umístit dialogové okno Kontrola chyb přímo pod řádek vzorců.

    Přesuňte okno Kontrola chyb pod řádek vzorců.
  4. Klikněte na některé z tlačítek akcí v pravé části dialogového okna. Dostupné akce jsou jiné pro každý typ chyby.

  5. Klikněte na Další.

Poznámka: Kliknete-li na možnost Ignorovat chybu, bude chyba označena a při následujících kontrolách přeskakována.

  1. Vedle buňky klikněte na tlačítko Kontrola chyb, Ikona Kontrola chyb se zobrazí, a potom klikněte na požadovanou možnost. Dostupné příkazy se liší pro každý typ chyby a první položka chybu popisuje.

    Pokud kliknete na možnost Ignorovat chybu, chyba se označí a při následujících kontrolách se bude přeskakovat.

    Přesuňte okno Kontrola chyb pod řádek vzorců.

Pokud vzorec nemůže správně vyhodnotit výsledek, zobrazí Excel chybovou hodnotu, například #####, #DIV/0!, #N/A, #NAME?, #NULL!, #NUM!, #REF!a #VALUE!. Každý typ chyby má různé příčiny a různá řešení.

Následující tabulka obsahuje odkazy na články, které tyhle chyby podrobně popisují, a nabízí taky stručný popis, díky kterému budete moci začít pracovat.

Téma

Popis

Oprava chyby ####

Excel tuhle chybu zobrazí, když sloupec není dost široký, aby se v něm zobrazily všechny znaky v buňce, nebo když buňka obsahuje zápornou hodnotu data nebo času.

To se může stát třeba v případě, že vzorec odečte datum v budoucnosti od data v minulosti (třeba =06/15/2008-07/01/2008. Výsledkem je pak záporná hodnota data.

Tip: Pokuste se buňku automaticky přizpůsobit poklikáním mezi záhlaví sloupců. Pokud se chyba ### zobrazuje kvůli tomu, že Excel nemůže zobrazit všechny znaky, tímto chybu odstraníte.

# chyba

Oprava chyby #DIV/0! #BUSY!

Excel tuhle chybu zobrazí při dělení čísla nulou (0) nebo buňkou, která neobsahuje žádnou hodnotu.

Tip: Přidejte obslužnou rutinu chyby, jako v následujícím příkladu: =KDYŽ(C2;B2/C2;0).

K pokrytí chyb se dají použít funkce zpracování chyb, jako je třeba KDYŽ.

Oprava chyby #NENÍ_K_DISPOZICI

Excel tuhle chybu zobrazí, když hodnota není pro funkci nebo vzorec dostupná.

Pokud používáte funkci jako SVYHLEDAT, shoduje se vámi hledaná položka s položkou v prohledávané oblasti? Většinou ne.

Zkuste použít funkci CHYBHODN k potlačení chyby #NENÍ_K_DISPOZICI. V takovém případě byste mohli použít:

=CHYBHODN(SVYHLEDAT(D2;$D$6:$E$8;2;PRAVDA);0)

Chyba #NENÍ_K_DISPOZICI

Oprava chyby #NÁZEV? #BUSY!

Tahle chyba se zobrazí, když Excel nerozpozná text ve vzorci. Může se třeba stát, že název oblasti nebo funkce nejsou správně napsané.

Poznámka: Pokud používáte funkci, zkontrolujte, že je její název správně napsaný. V tomto případě je SUMA napsáno nesprávně. Odeberte „e“ a Excel název opraví.

Excel zobrazí #NAME? chyba, když má název funkce překlep

Oprava #NULL! #BUSY!

Excel tuhle chybu zobrazí, když zadáte průnik dvou oblastí, které se ve skutečnosti neprotínají (nekříží). Jako operátor průniku funguje znak mezery, který odděluje odkazy ve vzorci.

Poznámka: Zkontrolujte, jestli jsou oblasti správně oddělené – oblasti C2:C3 a E4:E6 se neprotínají, takže zadáním vzorce =SUMA(C2:C3 E4:E6) se vrátí #NULL! . Když mezi oblasti C a E zasunout čárku, opraví se to =SUMA(C2:C3;E4:E6)

#NULL! #BUSY!

Oprava chyby #ČÍSLO! #BUSY!

Excel tuhle chybu zobrazí, když vzorec nebo funkce obsahuje neplatné číselné hodnoty.

Používáte funkci, která provádí iterace, třeba funkci MÍRA.VÝNOSNOSTI nebo ÚROKOVÁ.MÍRA? Pokud ano, je chyba #NUM!. pravděpodobně výsledkem toho, že funkce nemůže najít výsledek. Kroky řešení zkuste najít v tématech nápovědy.

Oprava chyby #ODKAZ! #BUSY!

Excel zobrazí tuto chybu, když odkaz na buňku není platný. Například jste odstranili buňky, na které odkazují jiné vzorce, nebo jste vsouvali buňky, které jste přesunuli nad buňky, na které odkazují jiné vzorce.

Odstranili jste omylem řádek nebo sloupec? Ve vzorci =SUMA(A2;B2;C2) jsme odstranili sloupec B a podívejte se, co se stalo.

Můžete buď použít příkaz Zpět (Ctrl+Z) a vrátit zpět operaci odstranění, můžete vzorec vytvořit znovu nebo můžete použít odkaz na souvislou oblast, třeba =SUMA(A2:C2), který by se při odstranění sloupce B aktualizoval.

Excel chybu #ODKAZ! zobrazí, když odkaz na buňku není platný.

Oprava chyby #HODNOTA! #BUSY!

Excel může tuhle chybu zobrazit, když váš vzorec obsahuje buňky, které obsahují různé datové typy.

Používáte matematické operátory (+, -, *, / ^) s různými typy dat? V takovém případě zkuste místo nich použít funkci. Tento problém vyřeší funkce =SUMA(F2:F5).

#HODNOTA! #BUSY!

Pokud buňky na listu nevidíte, můžete se na dané buňky i jejich vzorce podívat pomocí panelu nástrojů okna kukátka. Okno kukátka nabízí praktický způsob prohlížení, kontroly a ověřování výpočtů a výsledků vzorců ve velkých listech. Díky oknu kukátka se nemusíte opakovaně posouvat v listu ani přecházet do jeho různých částí.

Okno kukátka umožňuje snadno sledovat vzorce použité v listu.

Tento panel nástrojů můžete přesunout nebo ukotvit jako jakýkoliv jiný panel nástrojů. Můžete ho třeba ukotvit v dolní části okna. Panel nástrojů sleduje následující vlastnosti buňky: 1) Sešit, 2) List, 3) Název (pokud má buňka odpovídající pojmenovanou oblast), 4) Adresa buňky, 5) Hodnota a 6) Vzorec.

Poznámka: Každou buňku můžete sledovat jenom jednou.

Přidání buněk do okna kukátka

  1. Vyberte buňky, které chcete sledovat.

    Když chcete vybrat všechny buňky na listu se vzorci, na kartě Domů ve skupině Úpravy klikněte na Najít a vybrat (nebo můžete použít kombinaci kláves Ctrl+G nebo na Macu Control+G), pak na Přejít na – jinak > Vzorce.

    Dialog Přejít na – jinak
  2. Na kartě Vzorce klikněte ve skupině Závislosti vzorců na tlačítko Okno kukátka.

  3. Klikněte na Přidat kukátko.

    Kliknutím na Přidat kukátko přidáte kukátko do vaší tabulky.
  4. Potvrďte, že jste vybrali všechny buňky, které chcete sledovat, a klikněte na Přidat.

    V části Přidat kukátko zadejte oblast buněk, která se má sledovat.
  5. Pokud chcete změnit šířku sloupce Okno kukátka, přetáhněte okraj na pravé straně záhlaví sloupce.

  6. Pokud chcete zobrazit buňku, na kterou odkazuje položka v panelu nástrojů Okno kukátka, poklikejte na danou položku.

    Poznámka: Buňky s externími odkazy na jiné sešity se v panelu nástrojů Okno kukátka zobrazí, jenom když jsou dané sešity otevřené.

Odebrání buněk z Okna kukátka

  1. Pokud panel nástrojů Okno kukátka není zobrazený, klikněte na kartě Vzorce ve skupině Závislosti vzorců na tlačítko Okno kukátka.

  2. Vyberte buňky, které chcete odebrat.

    Pokud chcete vybrat víc buněk, stiskněte klávesu CTRL a pak klikněte na příslušné buňky.

  3. Klikněte na Odstranit kukátko.

    Odstranit kukátko

Někdy není lehké pochopit, jak vnořený vzorec došel ke konečnému výsledku, protože provádí řadu průběžných výpočtů a logických testů. Dialogové okno Vyhodnocení vzorce ale umožňuje zobrazit různé části vnořeného vzorce, které se za účelem výpočtu vzorce vyhodnocují. Tak třeba vzorec =KDYŽ(PRŮMĚR(D2:D5)>50,SUMA(E2:E5);0) je hned jasnější, když se podíváte na následující průběžné výsledky:

Vyhodnocení vzorce pomáhá zjistit, jak se různé části vnořeného vzorce vyhodnocují.

V dialogovém okně Vyhodnocení vzorce

Popis

=KDYŽ(PRŮMĚR(D2:D5) > 50;SUMA(E2:E5);0)

Nejdřív se zobrazí vnořený vzorec. Funkce PRŮMĚR a SUMA jsou vnořené ve funkci KDYŽ.

Oblast buněk D2:D5 obsahuje hodnoty 55, 35, 45 a 25. Výsledek funkce PRŮMĚR(D2:D5) je tím pádem 40.

=KDYŽ(40>50;SUMA(E2:E5);0)

Oblast buněk D2:D5 obsahuje hodnoty 55, 35, 45 a 25. Výsledek funkce PRŮMĚR(D2:D5) je tím pádem 40.

=KDYŽ(Nepravda;SUMA(E2:E5);0)

40 není větší než 50, a proto je výraz v prvním argumentu funkce KDYŽ (argumentu Podmínka) Nepravda.

Funkce KDYŽ vrátí hodnotu třetího argumentu (argumentu Ne). Funkce SUMA se nevyhodnocuje, protože je druhým argumentem funkce KDYŽ (argument Ano) a vrátí se, jenom když je výraz pravdivý.

  1. Vyberte buňky, které chcete vyhodnotit. Buňky můžete upravovat jenom jednotlivě.

  2. Vyberte kartu Vzorce > Závislosti vzorců > Vyhodnocení vzorce.

  3. Kliknutím na Vyhodnotit prozkoumejte hodnotu podtrženého odkazu. Výsledek vyhodnocení se zobrazí kurzívou.

    Pokud podtržená část vzorce tvoří odkaz na jiný vzorec, kliknutím na Vstoupit zobrazte další vzorec v okně Vyhodnocení. Kliknutím na Vystoupit se vraťte k předchozí buňce a vzorci.

    Tlačítko Vstoupit není pro odkaz dostupné při druhém zobrazení odkazu ve vzorci, a to ani když vzorec odkazuje na buňku v samostatném sešitu.

  4. Klikejte dál na Vyhodnotit, dokud nevyhodnotíte všechny části vzorce.

  5. Pokud chcete znovu zobrazit vyhodnocení, klikněte na Restartovat.

  6. Pokud chcete vyhodnocení ukončit, klikněte na Zavřít.

Poznámky: 

  • Některé části vzorce, které používají funkce KDYŽ a ZVOLIT, se nevyhodnotí. V takovém případě se v poli Vyhodnocení zobrazí #NENÍ_K_DISPOZICI.

  • Pokud je odkaz prázdný, zobrazí se v poli Vyhodnocení nulová hodnota (0).

  • Následující funkce se přepočítají pokaždé, když se v listu něco změní. Může se proto stát, že se v dialogovém okně Vyhodnotit vzorec zobrazí jiné výsledky než v příslušné buňce: NÁHČÍSLO, POČET.BLOKŮ, INDEX, POSUN, POLÍČKO, NEPŘÍMÝ.ODKAZ, ŘÁDKY, SLOUPCE, NYNÍ, DNES, RANDBETWEEN.

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Zobrazení vztahů mezi vzorci a buňkami

Jak se vyhnout nefunkčním vzorcům

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?
Co ovlivnilo váš názor?

Děkujeme za váš názor!

×