Importovat data z Excelu, Accessu, sharepointových webů, SQL Server a jiných externích zdrojů

Platí pro
Visio Professional 2024 Visio Standard 2024 Visio Professional 2021 Visio Standard 2021 Visio Professional 2019 Visio Standard 2019 Visio Professional 2016 Visio Standard 2016

Data můžete rychle importovat a zobrazit přímo na obrazcích ve Visiu. Prvním krokem je připojení ke zdroji dat a import dat do výkresu. Druhým krokem je propojení importovaných dat s obrazci.

Krok 1: Import dat

V tomto prvním kroku naimportujete data pomocí Průvodce výběrem dat.

Data, která se zobrazí v okně Externí data , jsou snímkem zdrojových dat v době importu. Data ve výkresu lze aktualizovat tak, aby odpovídala změnám ve zdrojových datech. Zdroj dat však nelze aktualizovat změnou dat ve výkresu. Viz Aktualizace importovaných dat.

  1. Na kartě Data klikněte ve skupině Externí data na možnost Propojit data s obrazci.

  2. Na první stránce Průvodce výběrem dat zvolte, který z následujících typů zdrojů dat chcete použít:

    • Sešit aplikace Microsoft Excel
    • Databáze aplikace Microsoft Access
    • Seznam Microsoft SharePoint Foundation
    • Databáze systému Microsoft SQL Server
    • Jiný zdroj dat OLEDB nebo ODBC
    • dříve vytvořené připojení.
  3. Dokončete zbývající část průvodce.

    Poznámka

    Pokud na první stránce průvodce zvolíte jinou možnost než sešit aplikace Excel, databázi aplikace Access nebo seznam služby SharePoint, můžete být při dokončování Průvodce výběrem dat dočasně přesměrováni na Průvodce datovým připojením.

Po kliknutí na tlačítko Dokončit na poslední stránce Průvodce datovým připojením se zobrazí okno Externí data s importovanými daty zobrazenými v mřížce.

Existují tři způsoby propojení řádků dat s obrazci ve výkresu: řádky můžete propojit s existujícími obrazci jeden po druhém, řádky můžete propojit s obrazci automaticky nebo můžete vytvořit obrazce z dat.

Tento přístup je nejvhodnější pro existující výkresy s relativně malým počtem obrazců.

  • Přetáhněte řádek z okna Externí data na obrazec ve výkresu.

    Poznámka

    Pokud se okno Externí data nezobrazí, přejděte na kartu Data a ve skupině Zobrazit či skrýt zaškrtněte políčko vedle okna Externí data.

    Data se zobrazí v obrazci a vlevo od řádku v okně Externí data se zobrazí ikona odkazu.
    Přetažení řádku na obrazec

    Poznámka

    • Můžete propojit jeden řádek s více obrazci, nemůžete však propojit více řádků s jedním obrazcem.
    • Pokud chcete změnit nebo vylepšit vzhled obrazců a dat, přečtěte si článek Vylepšení dat pomocí datových symbolů.
    • Chcete-li zobrazit okno Externí data , klikněte v nabídce Zobrazit na příkaz Okno Externí data.

Tento přístup je nejvhodnější pro existující výkresy s velkým počtem obrazců. Tento postup funguje jenom v případě, že obrazce už obsahují data, která můžete přiřadit k datům ve zdroji dat.

  1. V nabídce Data klikněte na Aktualizovat vše a vyberte Automaticky propojit po aktualizaci , pokud jste to ještě neudělali.
  2. Postupujte podle pokynů v Průvodci automatickým propojením.
    Data se zobrazí v obrazcích. Pokud chcete změnit nebo vylepšit vzhled obrazců a dat, přečtěte si článek Vylepšení dat pomocí datových symbolů.

Metoda 3: Vytvoření obrazců z dat

Tento přístup je nejlepší, pokud výkres ještě neobsahuje obrazce a nepotřebujete použít zvláštní obrazce.

  1. Klikněte na obrazec v podokně Obrazce .
  2. Přetáhněte řádek nebo skupinu řádků z okna Externí data na prázdné místo ve výkresu.
    Pro každý řádek, který přetáhnete do výkresu, se zobrazí jedna instance obrazce, na který kliknete.