Funktionen LOPSLAG

Tip!: Prøv at bruge den nye XLOOKUP-funktion, en forbedret version af LOPSLAG, der fungerer i alle retninger og som standard returnerer nøjagtige match, hvilket gør det nemmere og mere praktisk at bruge end den foregående.

Brug LOPSLAG, når du har brug for at finde ting i en tabel eller et område efter række. Slå f.eks. en pris på en bildel op ved hjælp af delnummeret, eller find et medarbejdernavn baseret på vedkommendes medarbejder-id.

Tip!: Se disse YouTube-videoer fra Microsoft Creators for at få mere hjælp til LOPSLAG!

I sin simpleste form lyder funktionen LOPSLAG:

=LOPSLAG(Det, du vil slå op, hvor du vil søge efter det, kolonnenummeret i det område, der indeholder den værdi, der skal returneres, returnerer en omtrentlig eller nøjagtig værdi – angivet som 1/SAND eller 0/FALSK).

Din browser understøtter ikke video.

Tip!: Hemmeligheden bag LOPSLAG er at organisere dine data, så den værdi, du slår op (Frugt), er til venstre for den returværdi, du vil finde (Antal).

Du kan bruge funktionen LOPSLAG til at slå en værdi op i en tabel.

Syntaks

LOPSLAG(opslagsværdi; tabelmatrix; kolonneindeks_nr; [intervalopslag])

Det kunne f.eks. være:

  • =LOPSLAG(A2;A10:C20;2;SAND)

  • =LOPSLAG( "Fontana";B2:E7;2;FALSK)

  • =LOPSLAG(A2;'Klientdetaljer'! A:F,3,FALSK)

Argumentnavn

Beskrivelse

opslagsværdi    (påkrævet)

Den værdi, du vil slå op. Den værdi, du vil slå op, skal være i den første kolonne i det celleområde, du angiver i table_array argument.

Hvis tabelmatrixen strækker sig over cellerne B2:D7, skal lookup_value være i kolonne B.

Opslagsværdi kan være en værdi eller en reference til en celle.

Tabelmatrix    (påkrævet)

Det celleområde, hvor LOPSLAG vil søge efter opslagsværdi, samt returværdien. Du kan bruge et navngivet område eller en tabel, og du kan bruge navne i argumentet i stedet for cellereferencer. 

Den første kolonne i celleområdet skal indeholde lookup_value. Celleområdet skal også indeholde den returværdi, du vil finde.

Lær at markere områder i et regneark.

kolonneindeks_nr    (påkrævet)

Kolonnenummeret (begyndende med 1 for kolonnen yderst til venstre i table_array),der indeholder returværdien.

områdeopslag    (valgfrit)

En logisk værdi, der angiver, om LOPSLAG skal søge efter en omtrentlig værdi eller en præcis værdi:

  • Omtrentligt match – 1/SAND antager, at den første kolonne i tabellen er sorteret enten numerisk eller alfabetisk, og der søges derefter efter den nærmeste værdi. Dette er standardmetoden, hvis du ikke selv angiver en. F.eks. =LOPSLAG(90;A1:B100;2;SAND).

  • Nøjagtigt match – 0/FALSK søger efter den nøjagtige værdi i den første kolonne. F.eks. =LOPSLAG("Smith",A1:B100,2,FALSK).

Sådan kommer du i gang

Der er fire oplysninger, som du skal bruge til at opbygge syntaksen for LOPSLAG:

  1. Den værdi, du vil slå op, også kaldet opslagsværdien.

  2. Det område, hvor opslagsværdien er placeret. Husk, at opslagsværdien altid skal være i den første kolonne i området, for at LOPSLAG kan fungere korrekt. Hvis din opslagsværdi f.eks. er i celle C2, skal dit område starte med C.

  3. Kolonnenummeret i det område, der indeholder returværdien. Hvis du f.eks. angiver B2:D11 som området, skal du tælle B som den første kolonne, C som den anden kolonne osv.

  4. Du kan også vælge at angive SAND, hvis du vil et omtrentligt match for returværdien, eller FALSK, hvis du vil have et nøjagtigt match for returværdien. Hvis du ikke angiver noget, vil standardværdien altid være SAND eller omtrentlig værdi.

Nu kan du sammensætte alle ovenstående på følgende måde:

=LOPSLAG(opslagsværdi, område, der indeholder opslagsværdien, kolonnenummeret i det område, der indeholder returværdien, Omtrentlig værdi (SAND) eller Nøjagtigt match (FALSK)).

Eksempler

Her er nogle eksempler på LOPSLAG:

Eksempel 1

LOPSLAG-eksempel 1

Eksempel 2

LOPSLAG-eksempel 2

Eksempel 3

LOPSLAG-eksempel 3

Eksempel 4

LOPSLAG-eksempel 4

Eksempel 5

LOPSLAG-eksempel 5

Du kan bruge LOPSLAG til at kombinere flere tabeller i én, så længe en af tabellerne har felter til fælles med alle de andre. Dette kan især være nyttigt, hvis du har brug for at dele en projektmappe med personer, der har ældre versioner af Excel, som ikke understøtter datafunktioner med flere tabeller som datakilder – ved at kombinere kilderne i én tabel og ændre datafunktionens datakilde til den nye tabel kan datafunktionen bruges i ældre versioner af Excel (forudsat at selve datafunktionen understøttes af den ældre version).

Et regneark med kolonner, der bruger LOPSLAG til at hente data fra andre tabeller

Her har kolonnerne A-F og H værdier eller formler, der kun bruger værdier i regnearket, og resten af kolonnerne bruger LOPSLAG og værdierne i kolonne A (klientkode) og kolonne B (advokat) til at hente data fra andre tabeller.

  1. Kopiér den tabel, der indeholder de fælles felter, til et nyt regneark, og giv den et navn.

  2. Klik > Dataværktøjer > relationer for at åbne dialogboksen Administrer relationer.

    Dialogboksen Administrer relationer
  3. For hver af de viste relationer skal du være opmærksom på følgende:

    • Det felt, der sammenkæder tabellerne (angivet i parentes i dialogboksen). Dette er lookup_value for LOPSLAG-formlen.

    • Navnet på den relaterede opslagstabel. Dette er table_array i LOPSLAG-formlen.

    • Feltet (kolonnen) i den relaterede opslagstabel, der indeholder de ønskede data i den nye kolonne. Disse oplysninger vises ikke i dialogboksen Administrer relationer . Du skal se på den relaterede opslagstabel for at se, hvilket felt du vil hente. Du vil notere kolonnenummeret (A=1) – dette er col_index_num i formlen.

  4. Hvis du vil føje et felt til den nye tabel, skal du angive din LOPSLAG-formel i den første tomme kolonne ved hjælp af de oplysninger, du indsamlede i trin 3.

    I vores eksempel bruger kolonne G Attorney (the lookup_value) til at hente data om fakturasatsen fra den fjerde kolonne (col_index_num = 4) fra regnearkstabellen Attorneys, tblAttorneys (table_array) med formlen =LOPSLAG([@Attorney],tbl_Attorneys,4,FALSK).

    Formlen kan også bruge en cellereference og en områdereference. I vores eksempel ville det være =VLOOKUP(A2,'Attorneys'! A:D,4,FALSK).

  5. Fortsæt med at tilføje felter, indtil du har alle de felter, du skal bruge. Hvis du forsøger at forberede en projektmappe, der indeholder datafunktioner, der bruger flere tabeller, skal du ændre datakilden for datafunktionen til den nye tabel.

Problem

Hvad der gik galt

Der blev returneret en forkert værdi

Hvis områdeopslag er SAND eller udeladt, skal den første kolonne sorteres alfabetisk eller numerisk. Hvis den første kolonne ikke er sorteret, kan den returnerede værdi være noget uventet. Sortér enten den første kolonne, eller brug FALSK som et nøjagtigt match.

#I/T i en celle

  • Hvis Intervalopslag er SAND, og hvis værdien i opslagsværdi er mindre end den mindste værdi i første kolonne i tabelmatrix, så får du fejlværdien #I/T.

  • Hvis Intervalopslag er FALSK, så angiver fejlværdien #I/T, at det nøjagtige tal ikke blev fundet.

Du kan finde flere oplysninger om løsning af #i/t-fejl i LOPSLAG under Sådan rettes en #i/t-fejl i funktionen LOPSLAG.

#REFERENCE! i en celle

Hvis kolonneindeks_nr er større end antallet af kolonner i tabelmatrix, returneres #REFERENCE! fejlværdien.

Få mere at vide om at løse #REFERENCE!-fejlværdier. Se Sådan retter du en #REFERENCE!-fejl for at få mere at vide om LOPSLAG-fejl..

#VÆRDI! i en celle

Hvis tabelmatrixen er mindre end 1, returneres #VÆRDI! fejlværdien.

Få mere at vide om at løse #VÆRDI!-fejlværdier. Se Sådan retter du en #VÆRDI!-fejl i funktionen LOPSLAG for at få mere at vide om LOPSLAG-fejl..

#NAVN? i en celle

Hvad med #NAVN? Denne fejlværdi betyder som regel, at formlen mangler anførselstegn. Hvis du vil slå en persons navn op, skal du sørge for at bruge anførselstegn rundt om navnet i formlen. Indtast f.eks. navnet som "Fontana" i =LOPSLAG("Fontana", B2:E7,2,FALSK).

Se Sådan retter du en #NAVN!-fejl for at få flere oplysninger..

Fejl med #OVERLØB! i en celle

Denne bestemte #SPILL! betyder som regel, at din formel er afhængig af et implicit skæringspunkt for opslagsværdien og brug af en hel kolonne som reference. F.eks. =LOPSLAG( A:A,A:C,2,FALSK). Du kan løse problemet ved at forankre opslagsreferencen med operatoren@ som dette: =LOPSLAG( @A:A,A:C,2,FALSK). Du kan også bruge den traditionelle LOPSLAG-metode og referere til en enkelt celle i stedet for en hel kolonne: =LOPSLAG(A2,A:C,2,FALSK).

Skal du

Hvorfor?

Brug af absolutte referencer til Intervalopslag

Brug af absolutte referencer giver dig mulighed for at udfylde en formel, så den altid ser på præcis det samme opslagsområde.

Lær at bruge absolutte cellereferencer.

Gem ikke tal- eller datoværdier som tekst.

Når du søger efter tal eller datoværdier, skal du sikre dig, at dataene i den første kolonne af tabelmatrix ikke er gemt som tekstværdier. Ellers kan LOPSLAG returnere en forkert eller uventet værdi.

Sortere den første kolonne

Sortér den første kolonne i tabellen, inden du bruger LOPSLAG, når Intervalopslag er SAND .

Brug af jokertegn

Hvis område_opslag er FALSK, og opslagsværdi er tekst, kan du bruge jokertegnene – spørgsmålstegn (?) og stjerne (*) – i opslagsværdi Et spørgsmålstegn matcher enkelttegn. En stjerne matcher tegnsekvenser. Hvis du ønsker at søge efter et faktisk spørgsmålstegn eller en faktisk stjerne, skal du indtaste en tilde (~) foran tegnet.

Eksempelvis søger =LOPSLAG("Skrifttype?",B2:E7,2,FALSK) efter alle forekomster af Fontana med et sidste bogstav, der kan variere.

Kontrollér, at dine data ikke indeholder nogen forkerte tegn.

Når du søger efter tekstværdier i den første kolonne, skal du sikre dig, at dataene i den første kolonne ikke indeholder indledende mellemrum, afsluttende mellemrum, inkonsekvent brug af lige ( ' eller " ) og krøllede ( ‘ eller “) anførselstegn eller tegn, der ikke kan udskrives. I så fald kan LOPSLAG returnere en forkert eller uventet værdi.

For at få præcise resultater kan du prøve at bruge funktionen RENS eller funktionen FJERN.OVERFLØDIGE.BLANKE for at fjerne efterstillede mellemrum efter tabeværdier i en celle.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Se også

Oversigtskort: Opdatering af LOPSLAG
Oversigtskort: Tip til fejlfinding af LOPSLAG
YouTube: LOPSLAG-videoer fra Microsoft Creators
Sådan retter du en #VALUE!-fejlen i funktionen LOPSLAG
Sådan retter du en #I/T-fejl i funktionen LOPSLAG
Oversigt over formler i Excel
Sådan undgår du ødelagte formler
Registrer fejl i formler
Excel-funktioner (alfabetisk)
Excel-funktioner (efter kategori)
LOPSLAG (gratis forhåndsvisning)

Har du brug for mere hjælp?

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×