Error message when you try to install the.NET Framework 2.0 on a computer that has the.NET Framework 2.0 Service Pack 1 installed: "Setup cannot continue because this version of the.NET Framework is incompatible with a previously installed one"

SYMPTOMS
When you try to install the Microsoft .NET Framework 2.0 on a computer that has the .NET Framework 2.0 Service Pack 1 installed, you may receive an error message that resembles the following:
Setup cannot continue because this version of the .NET Framework is incompatible with a previously installed one. For more information, see http://support.microsoft.com/kb/906894.
CAUSE
The .NET Framework 2.0 Service Pack 1 is a later version of the .NET Framework 2.0. The earlier version cannot be installed over the later version.
RESOLUTION
To resolve this problem, uninstall the .NET Framework 2.0 Service Pack 1 before you install the .NET Framework 2.0.
MORE INFORMATION

Steps to reproduce the problem

  1. On a computer that is running Microsoft Windows Server 2003 Service Pack 1 or Windows XP Service Pack 2, install the .NET Framework 2.0 Service Pack 1 or the .NET Framework 3.5.
  2. Install the .NET Framework 2.0.
You receive the error message that is mentioned in the "Symptoms" section.
गुण

आलेख ID: 906894 - पिछली समीक्षा: 09/28/2011 16:22:00 - संशोधन: 6.0

Microsoft .NET Framework 2.0, WinFX Runtime Components 3.0

  • kbvideotech kbuninstall kbtshoot kbprb KB906894
प्रतिक्रिया