You are currently offline, waiting for your internet to reconnect

Error message when you try to install updates by using the Windows Update Web site or the Microsoft Update Web site: "0x80070422"

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

SYMPTOMS
When you try to install updates by using the Windows Update Web site or the Microsoft Update Web site, you may receive the following error message:
0x80070422
CAUSE
This problem can occur if a required service is not running.
RESOLUTION

Microsoft Windows 2000, Windows XP, and Windows Server 2003

To resolve this problem, start the required services. To do this in Windows 2000, in Windows XP, or in Windows Server 2003, follow these steps:
  1. Click Start, click Run, type Notepad, and then click OK or press ENTER.
  2. Copy the following text, and then paste the text into Notepad:
    sc config wuauserv start= autosc config bits start= autosc config DcomLaunch start= autonet stop wuauservnet start wuauservnet stop bitsnet start bitsnet start DcomLaunch
  3. Click File, click Save As, and then type Repair.bat.
  4. In the Save as type box, click All Files.
  5. In the Save in box, click Desktop, and then click Save.
  6. On the File menu, click Exit.
  7. Double-click the Repair.bat file that you saved in step 5. This action starts the required services.
  8. Try to install the updates again. If you can install the updates, delete the Repair.bat file. To delete the Repair.bat file, right-click Repair.bat, click Delete, and then click Yes.

Windows Vista and Windows Server 2008

To start the required services in Windows Vista or in Windows Server 2008, follow these steps:
  1. Click Start Start button , type Notepad in the Start Search box, and then click Notepad in the Programs list.
  2. Copy the following text, and then paste the text into Notepad:
    sc config wuauserv start= autosc config bits start= autosc config DcomLaunch start= autonet stop wuauservnet start wuauservnet stop bitsnet start bitsnet start DcomLaunch 
  3. Click File, click Save As, and then type Repair.bat.
  4. In the Save as type box, click All Files (*.*).
  5. In the Save in box, click Desktop, and then click Save.
  6. On the File menu, click Exit.
  7. Right -click the Repair.bat file that you saved in step 5, and then click Run as administrator. This action starts the required services.

    User Access Control permission If you are prompted for an administrator password or confirmation, type the password, or click Continue.
  8. Try to install the updates again. If you can install the updates, delete the Repair.bat file. To delete the Repair.bat file, right-click Repair.bat, click Delete, and then click Yes..
For more information about how to troubleshoot this problem with Windows Update or Microsoft Update, visit the following Microsoft Web site:
0x80070422 80070422
Properties

Article ID: 958043 - Last Review: 09/29/2008 19:48:18 - Revision: 1.0

Microsoft Windows Update, Microsoft Update, Windows Vista Ultimate, Windows Vista Enterprise, Windows Vista Business, Windows Vista Home Premium, Windows Vista Home Basic, Windows Vista Starter, Microsoft Windows XP Professional, Microsoft Windows XP Home Edition, Windows Server 2008 Standard, Windows Server 2008 Enterprise, Windows Server 2008 Datacenter, Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Standard x64 Edition, Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems, Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise x64 Edition, Microsoft Windows Server 2003, Datacenter x64 Edition, Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems, Microsoft Windows Server 2003, Datacenter Edition (32-bit x86), Microsoft Windows 2000 Server, Microsoft Windows 2000 Professional Edition

  • kbwindowsupdate kbexpertisebeginner kbtshoot kbprb KB958043
Feedback