Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Applies to:

Microsoft .NET Framework 2.0 Microsoft .NET Framework 3.0 Microsoft .NET Framework 4.6.2

REMINDER Windows Embedded 7 Standard and Windows Server 2008 R2 SP1 have reached the end of mainstream support and are now in extended security update (ESU) support.

Starting in July 2020, there will no longer be optional, non-security releases (known as "C" releases) for this operating system. Operating systems in extended support have only cumulative monthly security updates (known as the "B" or Update Tuesday release).

Verify that you have installed the required updates listed in the How to get this update section before installing this update.ใ€€

Customers who have purchased the Extended Security Update (ESU) for on-premises versions of these operating systems must follow the procedures in KB4522133 to continue receiving security updates after extended support ends on January 14, 2020.ใ€€For more information on ESU and which editions are supported, see KB4497181. For more information, see the ESU blog.

REMINDER All updates for .NET Framework 4.7.2, 4.7.1, 4.7, 4.6.2, 4.6.1, and 4.6 require that the d3dcompiler_47.dll update is installed. We recommend that you install the included d3dcompiler_47.dll update before you apply this update. For more information about the d3dcompiler_47.dll, see KB 4019990.

If you install a language pack after you install this update, you must reinstall this update. Therefore, we recommend that you install any language packs that you need before you install this update. For more information, see Add language packs to Windows.

Summary

CVE-2023-21808 - .NET Framework Remote Code Execution Vulnerability
This security update addresses a vulnerability in the MSDIA SDK where an untrusted pointer dereference can cause memory corruption, leading to a crash or remove code execution. For more information please see CVE-2023-21808.

CVE-2023-21722 - .NET Framework Denial of Service Vulnerability
This security update addresses a vulnerability where the Visual Studio WMI Setup Provider Installer can be used by a low level, local attacker to corrupt local files that SYSTEM can writ to, leading to a potential denial of service. For more information please see CVE-2023-21722.

Known issues in this update

Symptom

After installing this update, WPF apps may have a change in behavior. For more information about this issue, see KB5022083

Workaround

To mitigate this issue, see KB5022083.

Additional information about this update

The following articles contain additional information about this update as it relates to individual product versions.

  • 5022529 Description of the Security Only Update for .NET Framework 2.0, 3.0 for Windows Server 2008 SP2 (KB5022529)

  • 5022526 Description of the Security Only Update for .NET Framework 4.6.2 for Windows Embedded 7 Standard and Windows Server 2008 R2 SP1 and Windows Server 2008 SP2 (KB5022526)

How to get this update

Release Channel

Available

Next Step

Microsoft Update Catalog

Yes

To get the standalone package for this update, go to the Microsoft Update Catalog website.

Windows Server Update Services (WSUS)

Yes

This operating system update will offer, as applicable, and individual .NET Framework product updates will be installed. For more information about individual .NET Framework product updates see additional information about this update section.

This update will automatically sync with WSUS if you configure as follows:

Product: Windows Server 2008 Service Pack 2

Classification: Security Updates

How to obtain help and support for this update

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×