SUMAPRODUCTO (función SUMAPRODUCTO)

La función SUMAPRODUCTO devuelve la suma de los productos de los rangos o matrices correspondientes. La operación predeterminada es la multiplicación, pero la suma, la resta y la división también son posibles.

En este ejemplo, usaremos SUMAPRODUCTO para devolver las ventas totales de un elemento y tamaño determinados:

Ejemplo de uso de la función SUMAPRODUCTO para devolver ventas totales cuando se proporcionan con el nombre del producto, el tamaño y los valores de ventas individuales para cada uno.

SUMAPRODUCTO coincide con todas las instancias del elemento Y/Tamaño M y las suma, por lo que para este ejemplo 21 más 41 es igual a 62.

Sintaxis

Para usar la operación predeterminada (multiplicación):

=SUMAPRODUCTO(matriz1, [matriz2], [matriz3], ...)

La sintaxis de la función SUMAPRODUCTO tiene los siguientes argumentos:

argumento

Descripción

matriz1   

Requerido

Es el primer argumento de matriz cuyos componentes desea multiplicar y después sumar.

[matriz2], [matriz3],...    

Opcional

De 2 a 255 matrices cuyos componentes desea multiplicar y después sumar.

Para realizar otras operaciones aritméticas

Use SUMAPRODUCTO como de costumbre, pero reemplace las comas que separan los argumentos de matriz por los operadores aritméticos que desee (*, /, +, -). Una vez realizadas todas las operaciones, los resultados se suman como siempre.

Nota: Si usa operadores aritméticos, considere la posibilidad de encierre los argumentos de matriz entre paréntesis y use paréntesis para agrupar los argumentos de matriz para controlar el orden de las operaciones aritméticas.

Observaciones

  • Los argumentos de matriz deben tener las mismas dimensiones. Si no lo hacen, SUMAPRODUCTO devuelve la #VALUE! Valor de error Por ejemplo, =SUMAPRODUCTO(C2:C10,D2:D5) devolverá un error ya que los rangos no tienen el mismo tamaño.

  • SUMAPRODUCTO trata las entradas de matriz no numéricas como si fueran ceros.

  • Para obtener el mejor rendimiento, SUMAPRODUCTO no debe usarse con referencias de columna completa. Considere =SUMAPRODUCTO(A:A,B:B), aquí la función multiplicará las 1.048.576 celdas de la columna A por las 1.048.576 celdas de la columna B antes de agregarlas. 

Ejemplo 1

Ejemplo de la función SUMAPRODUCTO usada para devolver la suma de los artículos vendidos cuando se proporciona el costo unitario y la cantidad.

Para crear la fórmula con nuestra lista de ejemplo anterior, escriba =SUMAPRODUCTO(C2:C5,D2:D5) y presione Entrar. Cada celda de la columna C se multiplica por su celda correspondiente en la misma fila de la columna D y los resultados se suman. El importe total de la compra es de 78,97 $.

Para escribir una fórmula más larga que le dé el mismo resultado, escriba =C2*D2+C3*D3+C4*D4+C5*D5 y presione Entrar. Después de presionar Entrar, el resultado es el mismo: 78,97 $. La celda C2 se multiplica por D2 y su resultado se agrega al resultado de la celda C3 veces la celda D3 y así sucesivamente.

Ejemplo 2

En el ejemplo siguiente se usa SUMAPRODUCTO para devolver el total de ventas netas por agente de ventas, donde tenemos ventas totales y gastos por agente. En este caso, estamos usando una tabla de Excel,que usa referencias estructuradas en lugar de rangos estándar de Excel. Aquí verá que los rangos Ventas, Gastos y Agente se hacen referencia por nombre.

Ejemplo de la función SUMAPRODUCTO para devolver ventas totales por representante de ventas cuando se proporcionan ventas y gastos para cada uno.

La fórmula es: =SUMAPRODUCTO(((Tabla1[Ventas])+(Tabla1[Gastos]))*(Tabla1[Agente]=B8)) y devuelve la suma de todas las ventas y gastos del agente enumerado en la celda B8.

Ejemplo 3

En este ejemplo, queremos devolver el total de un artículo concreto vendido por una región determinada. En este caso, ¿cuántas cerezas vendió la región Este?

Examen de usar SUMAPRODUCTO para devolver la suma de elementos por región. En este caso, el número de cerezas que se venden en la región Este.

Aquí, la fórmula es: =SUMAPRODUCTO((B2:B9=B12)*(C2:C9=C12)*D2:D9). Primero multiplica el número de apariciones de Este por el número de apariciones que coinciden con las de las cerezas. Por último, suma los valores de las filas correspondientes en la columna Ventas. Para ver cómo excel calcula esto, seleccione la celda de la fórmula y, a continuación, vaya a Fórmulas > Evaluar fórmula > Evaluar.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtenga soporte en la Comunidad de respuestas.

Vea también

Realizar cálculos condicionales en rangos de celdas

Suma basada en varios criterios con SUMAR.SI.TOTAL

Contar en función de varios criterios con CONTAR.SI.SI

Promedio basado en varios criterios con PROMEDIO.SI.PROMEDIO

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×