Importante: Pruebe a usar la nueva función BUSCARX, una versión mejorada de BUSCARV que funciona en cualquier dirección y devuelve coincidencias exactas de forma predeterminada, lo que facilita y resulta más cómodo de usar que su predecesor.

Al crear una función BUSCARV o BUSCARH, se introduce un rango de celdas, como D2:F39. Ese rango se denomina table_array y un argumento es simplemente un fragmento de datos que una función necesita para ejecutarse. En este caso, la función busca en esas celdas los datos que está intentando encontrar.

El table_array es siempre el segundo argumento de una función BUSCARV o BUSCARH (el primero es el valor que intenta buscar) y las funciones no funcionarán sin él.

El primer argumento, el valor que desea buscar, puede ser un valor específico como "41" o "smith", o bien puede ser una referencia de celda como F2. Por lo tanto, el primer argumento puede tener este aspecto:

=BUSCARV(F2, ...

El table_array siempre sigue el valor de búsqueda, así:

=BUSCARV(F2,B4:D39, ...

El rango de celdas enumerado en el table_array puede usar referencias de celda relativas o absolutas. Si va a copiar la función, debe usar referencias absolutas, como esta:

=BUSCARV(F2,$B$2:BD$39, ...

Además, las celdas del argumento table_array pueden estar en otra hoja de cálculo del libro. Si lo hacen, el argumento incluye el nombre de la hoja y la sintaxis tiene el siguiente aspecto:

=BUSCARV(F2,Hoja2!$C$14:E$42, ...

Asegúrese de colocar un signo de exclamación después del nombre de la hoja.

Por último (whew), escriba un tercer argumento, la columna que contiene los valores que está intentando encontrar. Esto se denomina columna de búsqueda. En nuestro primer ejemplo, hemos usado el rango de celdas B4 a D39, que se ejecuta en tres columnas. Vamos a pretender los valores que desea ver en directo en la columna D, la tercera columna de ese rango de celdas, por lo que el último argumento es un 3.

=BUSCARV(F2;B4:D39;3)

Puede usar un cuarto argumento opcional, verdadero o falso. La mayoría de las veces querrá usar False.

Si usa Verdadero o deja el cuarto argumento en blanco, la función devuelve una coincidencia aproximada con el valor del primer argumento. Por lo tanto, para continuar con el ejemplo, si el primer argumento es "smith" y usa True, la función devolverá "Smith", "Smithberg" y así sucesivamente. Pero si usa False, la función solo devuelve "Smith", una coincidencia exacta y eso es lo que la mayoría de las personas quieren.

Para que el uso de Verdadero sea aún más complicado, si la columna de búsqueda (la columna que especifique en el tercer argumento) no se ordena en orden ascendente (de la A a la Z o de menor a mayor), es posible que la función devuelva el resultado incorrecto. Para obtener más información sobre esto, vea Buscar valores con BUSCARV y otras funciones.

Y para obtener más información sobre las funciones BUSCARV y BUSCARH, vea:

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×